Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#12950 - Modifying package flags shouldn't require reinstallation

Attached to Project: Pacman
Opened by Paolo (peoro) - Sunday, 25 January 2009, 00:11 GMT
Last edited by Allan McRae (Allan) - Monday, 17 May 2010, 03:40 GMT
Task Type Feature Request
Category General
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version 3.2.1
Due in Version 3.4.0
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

To mark a package as installed as a dependency (or as explicitly installed), pacman requires to reinstall such package.
This shouldn't be needed, since sometimes reinstalling the package could be not possible and anyway it's an useless overhead.
This task depends upon

Closed by  Allan McRae (Allan)
Monday, 17 May 2010, 03:40 GMT
Reason for closing:  Implemented
Additional comments about closing:  git commit ac9dde07
Comment by Magnus Therning (magus) - Wednesday, 20 May 2009, 08:58 GMT
It took me about 2 weeks as an Arch user to bump up against this. Sure, re-installing is an option, but that seems to be a bit too much overhead for what essentially is a system-local manipulation of the pacman database.

See the short discussion in the related task for some more info/comments.
Comment by Xavier (shining) - Wednesday, 20 May 2009, 09:23 GMT
Keep in mind that this adds more complexity to pacman switches and it could get messy and confusing.
If you ask for this feature, you should also suggest good pacman switches for it.

Nagy said:
> If someone suggest me good pacman switches, I will provide a patch for
> this. ;-) (I think we need a new main operation, -D/--database for
> example).
Comment by Magnus Therning (magus) - Wednesday, 20 May 2009, 09:29 GMT
I like Nagy's suggestion of -D/--database:

# pacman -D --asdeps <pkg1> <pkg2>
# pacman -D --asexplicit <pkg3> <pkg4>
Comment by Xavier (shining) - Wednesday, 22 July 2009, 12:26 GMT

Loading...