Release Engineering

This project is intented for all release related issues (isos, installer, etc), under the umbrella of the ArchLinux Release Engineers
Tasklist

FS#12949 - `hdparm -I' fails in VMware

Attached to Project: Release Engineering
Opened by Evangelos Foutras (foutrelis) - Saturday, 24 January 2009, 23:20 GMT
Last edited by Dieter Plaetinck (Dieter_be) - Saturday, 14 February 2009, 18:37 GMT
Task Type Bug Report
Category ArchISO
Status Closed
Assigned To Aaron Griffin (phrakture)
Dan McGee (toofishes)
Dieter Plaetinck (Dieter_be)
Architecture All
Severity Low
Priority Normal
Reported Version 2009.01-beta
Due in Version 2009.02
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

`hdparm -I' is used during the partitioning as a way to get the disk's capacity. The error I'm getting is:

"HDIO_DRIVE_CMD(identify) failed: Invalid exchange"

I'm not sure whether this is specific to VMware or could also occur in a normal computer.
This task depends upon

Closed by  Dieter Plaetinck (Dieter_be)
Saturday, 14 February 2009, 18:37 GMT
Reason for closing:  Fixed
Additional comments about closing:  Confirmed by Alexander @ http://www.archlinux.org/pipermail/arch- releng/2009-February/000342.html
Comment by Evangelos Foutras (foutrelis) - Sunday, 25 January 2009, 02:23 GMT
Attached patch substitutes hdparm with fdisk. I've tested it in VMware and on my computer.

Review and corrections are welcome.
Comment by Dieter Plaetinck (Dieter_be) - Monday, 26 January 2009, 19:41 GMT
I'll have a look at it later.
Comment by Evangelos Foutras (foutrelis) - Saturday, 31 January 2009, 12:10 GMT
A little more information; `hdparm -I' seems to fail because VMware emulates a SCSI disk. It works fine if I tell it to emulate a IDE disk.
Comment by Evangelos Foutras (foutrelis) - Saturday, 31 January 2009, 16:31 GMT
Revised patch sent to the mailing list, along with another patch to use MiB instead of MB.

http://www.archlinux.org/pipermail/arch-releng/2009-January/000195.html
Comment by Dieter Plaetinck (Dieter_be) - Sunday, 01 February 2009, 10:15 GMT
Indeed, hdparm works - by design - only with sata/ide disks.

Your patch looks good. If would add a '2>/dev/null' after the fdisk call though (eg i got a stderr message saying 'invalid partition table', cluttering my output)
Can you update your patch to be the one from the ML, but with the adaption above? then we can apply it
Comment by Evangelos Foutras (foutrelis) - Sunday, 01 February 2009, 13:11 GMT
Added stderr redirection to /dev/null as suggested. :)
Comment by Dieter Plaetinck (Dieter_be) - Sunday, 01 February 2009, 13:30 GMT
Dan/Aaron, can you apply 0001-Using-fdisk-instead-of-hdparm-to-get-disc-capacity.patch ? It looks okay to me.
Comment by Aaron Griffin (phrakture) - Tuesday, 03 February 2009, 22:10 GMT
Pushed both patches to git. The second one is important due to sfdisk requiring MiB
Comment by Dieter Plaetinck (Dieter_be) - Wednesday, 11 February 2009, 19:32 GMT
no regressions afaict on vbox 32bit.
although I don't really understand the math:
df uses powers of 1024 by default, so the numbers should be the same (MiB is also powers of 1024), but there is a difference.
in installer <-> df -m
100MiB 99M
10000MiB 9845M
Comment by Dieter Plaetinck (Dieter_be) - Saturday, 14 February 2009, 12:56 GMT
Evangelos, can you test rc2 in your vmware?
Also can you explain me the math question above? thanks :)
Comment by Dieter Plaetinck (Dieter_be) - Saturday, 14 February 2009, 18:36 GMT
I'll ask the math question on the ML. Alexander reported this is fixed :)

Loading...