Release Engineering

This project is intented for all release related issues (isos, installer, etc), under the umbrella of the ArchLinux Release Engineers
Tasklist

FS#12947 - Selection jumps to step 1 (Set Clock) after step 2 (Prepare Hard Drive)

Attached to Project: Release Engineering
Opened by Evangelos Foutras (foutrelis) - Saturday, 24 January 2009, 22:31 GMT
Last edited by Dieter Plaetinck (Dieter_be) - Saturday, 31 January 2009, 13:31 GMT
Task Type Bug Report
Category ArchISO
Status Closed
Assigned To Tobias Powalowski (tpowa)
Aaron Griffin (phrakture)
Dan McGee (toofishes)
Gerhard Brauer (GerBra)
Dieter Plaetinck (Dieter_be)
Architecture All
Severity Low
Priority Low
Reported Version 2009.01-beta
Due in Version 2009.02
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

I think the problem is that NEXTITEM is used for tracking purposes inside prepare_harddrive(). However, this is used in the top-level options list as well, so other functions (besides mainmenu()) shouldn't change it.

Making NEXTITEM local to prepare_harddrive() seems to solve this problem. (see attached tiny patch)
This task depends upon

Closed by  Dieter Plaetinck (Dieter_be)
Saturday, 31 January 2009, 13:31 GMT
Reason for closing:  Fixed
Additional comments about closing:  fixed
Comment by Greg (dolby) - Saturday, 24 January 2009, 23:00 GMT
Yes i noticed that too but i thought it was just me. Nice catch.
Comment by Gerhard Brauer (GerBra) - Monday, 26 January 2009, 14:25 GMT
This is a problem on most/all (sub)menus in current installer. Don't know if we could fix this ASAP on this "next" iso. I'll have a look on it, but myself won't invest much time on the current installer when we maybe have a complete new in 2009.04.
Comment by Dieter Plaetinck (Dieter_be) - Monday, 26 January 2009, 18:12 GMT
actually aif (which will be the next official installer in a while) has the correct behaviour already for a while.
For archlinux-installer: I'm not sure the solution is *this* easy, but I don't intend to invest time to investigate/patch up archlinux-installer.
I doubt any of the archlinux-installer maintainers are interested either. I added them so we'll see...
Comment by Evangelos Foutras (foutrelis) - Monday, 26 January 2009, 19:13 GMT
@Gerhard Brauer, with the exception of system configuration, no submenu had such tracking. I'll be attaching a new patch in a bit which fixes selection tracking on the (sub)menus that is needed.
Comment by Evangelos Foutras (foutrelis) - Monday, 26 January 2009, 19:34 GMT
Revised patch. Adds tracking to select_source() and fixes tracking in prepare_harddrive().
Comment by Gerhard Brauer (GerBra) - Monday, 26 January 2009, 19:50 GMT
Evangelos, the network setup dialog has the same problem, and i mean i have seen it in some other menus also.
@Aaron: if you make a new installer package to fix  FS#12944 , could you apply Evangelos patch?
Comment by Evangelos Foutras (foutrelis) - Monday, 26 January 2009, 19:54 GMT
Above patch messes up the system configuration step (renaming variables without checking if they are reused further down in the code is not good ._.).

I'll post a re-revised patch after some testing. :3
Comment by Dieter Plaetinck (Dieter_be) - Monday, 26 January 2009, 19:59 GMT
Let's not apply untested patches. Also I don't agree this is a 2009.01 showstopper.
Comment by Aaron Griffin (phrakture) - Monday, 26 January 2009, 20:22 GMT
Can't we just change the variable that prepare_harddrive uses? Changing it to NEXT_ITEM or something should prevent it from overwriting the global used for the main menu. If that still fails, I would guess that simply incrementing the answers on this menu would make the $(cat $ANSWER) work as intended.
Comment by Evangelos Foutras (foutrelis) - Monday, 26 January 2009, 20:50 GMT
@Aaron Griffin, making NEXTITEM local to that function (as the first patch suggests), solves the issue at hand with minimal changes.

I'm sorry for posting the second patch without testing it first. Here's the corrected/tested patch that also adds selection tracking to the "FTP Installation" dialog.
Comment by Aaron Griffin (phrakture) - Tuesday, 27 January 2009, 04:14 GMT Comment by Dieter Plaetinck (Dieter_be) - Friday, 30 January 2009, 15:51 GMT
still not fixed in beta3 (for archlinux-installer). after having successfully installed packages, the highlighted item is again "install packages"
Comment by Evangelos Foutras (foutrelis) - Friday, 30 January 2009, 16:00 GMT
It's supposed to return to the step that was previously selected; isn't that the behavior you noticed throughout the installer?
Comment by Dieter Plaetinck (Dieter_be) - Friday, 30 January 2009, 16:04 GMT
imho NEXTITEM should become.. well.. the next item, not the previous one. So that if you complete a step, by default the next one should be hilighted so in 99.9% of the cases you can press enter and not need to use your arrow keys.


That's how I did it in aif at least.
Comment by Aaron Griffin (phrakture) - Friday, 30 January 2009, 16:46 GMT
I agree with Dieter. The next item should change when a step is successful. If "Step 1" is completed fine, it should go to "Step 2". If "Step 1" fails or the user hits Esc, it should not advance.
Comment by Evangelos Foutras (foutrelis) - Friday, 30 January 2009, 16:47 GMT
Yes, the naming was a little confusing. I've since renamed it to CURRENT_SELECTION which makes more sense.

I'm no usability expert, but I believe that returning to the same item is more intuitive; you return to the exact same item you left from.
Comment by Aaron Griffin (phrakture) - Friday, 30 January 2009, 16:50 GMT
Other installers that I can remember (Slackware and Ubuntu) advance the menu items, IIRC
Comment by Evangelos Foutras (foutrelis) - Friday, 30 January 2009, 16:52 GMT
"I've since renamed it to CURRENT_SELECTION which makes more sense" - Maybe this sounded like the naming change isn't included in the 2009.01-2 installer, it is.

If you really believe it should advance to the next item if the previous step completed successfully (I don't, but as I've said I'm no usability expert :>), I can have a look at it.
Comment by Dieter Plaetinck (Dieter_be) - Friday, 30 January 2009, 17:07 GMT
"I'm no usability expert, but I believe that returning to the same item is more intuitive; you return to the exact same item you left from."

I think it depends on what you expect. When I think of it, both your and mine way "behave like expected" depending on how the user expected it. It are just 2 different mindsets. I think some people may intuitively expect your, and others, mine behaviour.

Either way, I think my way is at least technically better, because it decreases the need to use keypresses.

Btw Evangelos, I didn't know you were an official contributor/developer/whatever. I don't think we have met.. Hi, I'm Dieter :-)


"If you really believe it should advance to the next item if the previous step completed successfully (I don't, but as I've said I'm no usability expert :>), I can have a look at it."

Don't put to much time in it.. aif will replace archlinux-installer in the future.
Comment by Evangelos Foutras (foutrelis) - Friday, 30 January 2009, 17:18 GMT
Hey Dieter,

I'm a (relatively new) TU, but I like messing with developers' stuff when time and knowledge allows.

I'll take your advice and won't put much effort into making the installer advance on successful steps; I will give it a shot though.

(aif looks very well-built and hopefully will make our lives easier in future releases, good work!)
Comment by Dieter Plaetinck (Dieter_be) - Saturday, 31 January 2009, 11:14 GMT
I'm filing this back to 2009.04. I don't agree this is a showstopper for 2009.01
Comment by Evangelos Foutras (foutrelis) - Saturday, 31 January 2009, 11:44 GMT
Well, I consider the bug fixed. We're talking about further changing its behavior, which probably won't happen (would require new installer release and could introduce new bugs, plus 2008.06's behaves in exactly the same way).
Comment by Dieter Plaetinck (Dieter_be) - Saturday, 31 January 2009, 13:30 GMT
You're right. The bug was about "Selection jumps to step 1 (Set Clock) after step 2 (Prepare Hard Drive) " and that should be fixed now.
If anyone thinks it's still worth enough to open a new ticket for a behaviour change for archlinux-installer like discussed above, he can open a new ticket and provide a patch...

Loading...