Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#12932 - [mkinitcpio] please add versioned udev dependency

Attached to Project: Arch Linux
Opened by b4283 (b4283) - Saturday, 24 January 2009, 14:21 GMT
Last edited by Tobias Powalowski (tpowa) - Sunday, 31 May 2009, 13:26 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Tobias Powalowski (tpowa)
Aaron Griffin (phrakture)
Thomas B├Ąchler (brain0)
Architecture x86_64
Severity Low
Priority Normal
Reported Version None
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
due to scripts used in newer mkinitcpio package require newer udev as well
please add at least a udev version that has "resolve-modalias" command

also, please add klibc-module-init-tool and gen-init-cpio to dependency as well
because somehow this is how i resolved the problem that mkinitcpio won't load modules before hooks
and hence caused unable to boot after upgrading to 2.6.28

Additional info:
* package version(s)
kernel26 2.6.28-1

* config and/or log files etc.


Steps to reproduce:

upgrading from 2.6.27-9 to 2.6.28-1
in the process of mkinitcpio produces
"/lib/initcpio/functions: line 7: resolve-modalias: command not found"
this is because resolve-modalias only exists in newer udev packages
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Sunday, 31 May 2009, 13:26 GMT
Reason for closing:  Fixed
Comment by Aaron Griffin (phrakture) - Saturday, 24 January 2009, 21:36 GMT
Why do these need to be kernel deps? You are talking about mkinitcpio which depends on all these packages already
Comment by b4283 (b4283) - Sunday, 25 January 2009, 02:10 GMT
but apparently it only asks for package existence WHETHER udev and other packs are new or old.
this makes problem when udev is old enough to omit the command of "resolve-modalias".

please add conditions to a newer version at least the current version for udev, gen-init-cpio & klibc-module-init-tool, of mkinitcpio's dependency.
Comment by Aaron Griffin (phrakture) - Sunday, 25 January 2009, 02:25 GMT
So... you're using an old udev? Why are you partially updating your system like that?
Comment by b4283 (b4283) - Sunday, 25 January 2009, 03:40 GMT
i didn't know !
i thought pacman would automatically upgrade it, but it appears otherwise.
guessing pacman never occured to think about upgrading my udev.
before successfully moved to 2.6.28, my kernel was 2.6.27-9 and udev was 115-1 (as i recall).
Comment by Tobias Powalowski (tpowa) - Sunday, 25 January 2009, 08:10 GMT
something must be messed up on your system if it reacts like this.
kernel depends indirectly on udev through mkinitcpio, so no need of adding it to depend array.
Comment by b4283 (b4283) - Sunday, 25 January 2009, 10:15 GMT
apparently you didn't read my text
i said at least add a condition for newer udev

SOMETHING LIKE udev >= 135
not udev the package itself
only udev without any condition, pacman only verifies that its existence rather more than its version.
Comment by Tobias Powalowski (tpowa) - Friday, 13 February 2009, 09:39 GMT
adding this to mkinitcpio is needed and not to kernel PKGBUILD
Comment by Micah Leier (nixcamic) - Thursday, 19 February 2009, 00:03 GMT
klibc-kbd also needs to be upgraded. however, these bugs have nothing to do with the kernel, klibc should be updated to always require a matching version of klibc-module-init-tool and klibc-kbd, and mkinitcpio should be updated to require a compatible version of udev and gen-init-cpio.
Comment by Tobias Powalowski (tpowa) - Saturday, 23 May 2009, 17:48 GMT
added versioned depend to trunk svn

Loading...