Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#12900 - mplayer don't show subtitles.

Attached to Project: Arch Linux
Opened by Logan (PheniX) - Friday, 23 January 2009, 07:20 GMT
Last edited by Hugo Doria (hdoria) - Monday, 26 January 2009, 12:21 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Hugo Doria (hdoria)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version None
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:
It seem the support of freetype is not compiled in mplayer.
When playing a movie with subtitles, subtitles don't show and this message appear :
"Cannot load bitmap font: /usr/share/mplayer/font/font.desc"

Additional info:
* package version(s)
mplayer-28347-1

* config and/or log files etc.
MPlayer dev-SVN-rUNKNOWN-4.3.2 (C) 2000-2009 MPlayer Team
CPU: Intel(R) Core(TM)2 Duo CPU E6750 @ 2.66GHz (Family: 6, Model: 15, Stepping: 11)
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled with runtime CPU detection.
Creating config file: /home/phenix/.mplayer/config
137 audio & 292 video codecs
Cannot load bitmap font: /usr/share/mplayer/font/font.desc

Steps to reproduce:
Play a movie with subtitles file.
This task depends upon

Closed by  Hugo Doria (hdoria)
Monday, 26 January 2009, 12:21 GMT
Reason for closing:  Fixed
Comment by Jean-Christophe Imbert (Bobyl) - Sunday, 25 January 2009, 16:13 GMT
Confirmed.
Rebuilding mplayer with the --enable-freetype flag solves the problem. The PKGBUILD should be updated.
Comment by Hugo Doria (hdoria) - Monday, 26 January 2009, 12:21 GMT
Fixed in mplayer 28347-2.

Loading...