Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#12889 - doc/I18N-HOWTO missing in intltool

Attached to Project: Arch Linux
Opened by Lyman Li (lyman) - Thursday, 22 January 2009, 13:50 GMT
Last edited by Eric Belanger (Snowman) - Saturday, 07 February 2009, 16:50 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Eric Belanger (Snowman)
Architecture All
Severity Low
Priority Normal
Reported Version None
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

I found that the package intltool does not contain the file doc/I18N-HOWTO, which is contained in official release.

As this file is supposed to be found locally easily, once it is missing even google can not give out useful hint efficiently.

IMHO, this file is vital for the person who is new to gettext/intltool tool-chain (no kidding, more heuristic and important than the manpages).

Additional info:
extra/intltool 0.40.5-1 [installed]
The internationalization tool collection

Steps to reproduce:
1,install intltool
2, pacman -Ql intltool | grep -i howto returns nothing
This task depends upon

Closed by  Eric Belanger (Snowman)
Saturday, 07 February 2009, 16:50 GMT
Reason for closing:  Implemented
Additional comments about closing:  Fixed in svn. I18N-HOWTO will be included at the next package update.
Comment by Greg (dolby) - Thursday, 22 January 2009, 17:22 GMT
This is more of a feature request to include it than a bug report. Which distro have you seen including it if i may ask? Would a seperate intltool-doc make sense?
Comment by Lyman Li (lyman) - Friday, 23 January 2009, 03:58 GMT
You can take a look at pygtk, glade, gettext (I believe there are more) by
pacman -Ql pygtk glade gettext | grep doc

In intltool case, the doc is just a 7.2k text file. I don't think it is a good idea to maintain another PKGBUILD for only a 7.2k text file. Anyway, I don't care much about the package splitting policy in arch. I just want a way to get the doc within arch when I need it. There's no such way in arch at the moment.
Comment by Roman Kyrylych (Romashka) - Monday, 26 January 2009, 16:50 GMT
Arch used to strip all docs except man pages from packages
recently the policy has changed, so by default all docs are included, except when they take too much space.
I believe the file is missing just because the package was updated before !docs was removed from options array in the default makepkg.conf
Comment by Greg (dolby) - Monday, 26 January 2009, 18:11 GMT
I think thats not the case here, although i might be wrong. Judging by the date the package was rebuilt, i think that the document in question needs to be explicitly installed.
Unless JGC's makepkg.conf comes with !docs which i seriously doubt.
Comment by Greg (dolby) - Monday, 26 January 2009, 18:19 GMT
And just confirmed the above with building the package. Even if you set --datarootdir and --docdir theres no /usr/share/doc to be found.

Loading...