Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#12864 - acpi-buggy-bios.patch breaks kernel compilation with ACPI_DEBUG enabled

Attached to Project: Arch Linux
Opened by kludge (kludge) - Tuesday, 20 January 2009, 07:11 GMT
Last edited by Tobias Powalowski (tpowa) - Monday, 02 February 2009, 21:28 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas Bächler (brain0)
Architecture All
Severity High
Priority Normal
Reported Version None
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

line 29 of the acpi-buggy-bios.patch (1) invokes ACPI_DB_WARN, which is no longer available in kernel 2.6.28 (2). this patch fixed buggy AMI BIOSes, but is apparently no longer necessary (3). however, the now-incorrect call to ACPI_DB_WARN prevents 2.6.28 patched with linux-2.6.28-3 from compiling.

Additional info:

(1) http://projects.archlinux.org/?p=linux-2.6-ARCH.git;a=blob;f=patches/acpi-buggy-bios.patch
(2) http://groups.google.com/group/linux.kernel/browse_thread/thread/d9b7b2477e184578
(3) http://bugzilla.kernel.org/show_bug.cgi?id=7578#c96

Steps to reproduce:

enable ACPI_DEBUG in config and compile kernel 2.6.28-3 patched with linux-2.6.28-3.patch
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Monday, 02 February 2009, 21:28 GMT
Reason for closing:  Fixed
Comment by kludge (kludge) - Tuesday, 20 January 2009, 23:08 GMT
here's a fix:

line 29 of (1) reads:
+ ACPI_DEBUG_PRINT((ACPI_DB_WARN, "States [%d] :Wrong processor core frequency %u, set it to 1992\n", j, (u32)pr->performance->states[j].core_frequency));

if it is changed to:

+ ACPI_WARNING((AE_INFO, "States [%d] :Wrong processor core frequency %u, set it to 1992\n", j, (u32)pr->performance->states[j].core_frequency));

the kernel compiles fine.

nb: i'm not 100% this is correct, as i don't have the buggy bios against which to test the fix, and my c/++ is about as weak as it gets. but as far as i can from looking at the function definitions, it should be fine.
Comment by kludge (kludge) - Tuesday, 20 January 2009, 23:21 GMT
for completeness sake, this is related to:

http://bugs.archlinux.org/task/6875
Comment by kludge (kludge) - Thursday, 22 January 2009, 02:19 GMT
i've turned my fix into a patch against patch-2.6.28.1-1-ARCH, which is attached. apparently, though, my fix is insufficient. build fails with:

Building modules, stage 2.
MODPOST 2084 modules
ERROR: "acpi_ut_warning" [drivers/acpi/processor.ko] undefined!
make[1]: *** [__modpost] Error 1
make: *** [modules] Error 2
==> ERROR: Build Failed.
Aborting...

i've opened a thread on the forum looking for advice, as i'm now officially in over my head: http://bbs.archlinux.org/viewtopic.php?id=63560
Comment by Thomas Bächler (brain0) - Monday, 26 January 2009, 17:07 GMT
This patch has no chance of ever getting included upstream, so I'd just say we should remove it completely. If the patch is no longer necessary, then it should have been removed already anyway.
Comment by kludge (kludge) - Monday, 26 January 2009, 19:35 GMT
it's not clear from the upstream bug report that the issue is resolved. is there a way i could help confirm it, not having a machine with that particular bios?
Comment by Tobias Powalowski (tpowa) - Monday, 02 February 2009, 21:28 GMT
removed this patch from git tree, closing this

Loading...