Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#12856 - [source-highlight 2.11.1-1] /usr/share/info/dir should be removed

Attached to Project: Arch Linux
Opened by Xavier (shining) - Monday, 19 January 2009, 12:42 GMT
Last edited by Douglas Soares de Andrade (dsa) - Monday, 02 February 2009, 02:15 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Douglas Soares de Andrade (dsa)
Architecture All
Severity Low
Priority Normal
Reported Version None
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

/usr/share/info/dir should be removed from source-highlight package.
This task depends upon

Closed by  Douglas Soares de Andrade (dsa)
Monday, 02 February 2009, 02:15 GMT
Reason for closing:  Fixed
Comment by Dan McGee (toofishes) - Tuesday, 20 January 2009, 01:18 GMT
Confirmed for i686, probably both architectures:

error: could not prepare transaction
error: failed to commit transaction (conflicting files)
source-highlight: /usr/share/info/dir exists in filesystem
Errors occurred, no packages were upgraded.
Comment by Peter Simons (peti) - Thursday, 22 January 2009, 18:54 GMT
I have the same problem on my x86 machine and cannot upgrade source-highlight because of it. It would be nice to have that fixed.
Comment by Christophe-Marie Duquesne (duquesnc) - Thursday, 22 January 2009, 21:26 GMT
Same bug here, x86_64.

$ pacman -S source-highlight
resolving dependencies...
looking for inter-conflicts...

Targets (1): source-highlight-2.11.1-2

Total Download Size: 0.00 MB
Total Installed Size: 3.16 MB

Proceed with installation? [Y/n] Y
checking package integrity...
(1/1) checking for file conflicts [####################################################################################################] 100%
error: could not prepare transaction
error: failed to commit transaction (conflicting files)
source-highlight: /usr/share/info/dir exists in filesystem
Errors occurred, no packages were upgraded.
Comment by Xavier (shining) - Sunday, 25 January 2009, 15:16 GMT
It seems the first -2 version contained a wrong fix :
http://repos.archlinux.org/viewvc.cgi/source-highlight/trunk/PKGBUILD?r1=24664&r2=24714
It was then fixed but the version is still -2 :
http://repos.archlinux.org/viewvc.cgi/source-highlight/trunk/PKGBUILD?r1=24714&r2=25093

Also it looks like only 686 contains the fix now, not x86_64.
Otherwise, info pages should be kept, only this stupid dir file should be removed.
rm -rf $startdir/pkg/usr/share/info/
should be
rm -f $pkgdir/usr/share/info/dir
Comment by Christophe-Marie Duquesne (duquesnc) - Sunday, 25 January 2009, 17:07 GMT
I'm confirming this is still not fixed on x86_64.

Loading...