Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#12821 - X.org + intel + 2.6.28 kernel freezing on composite waiting for vblank

Attached to Project: Arch Linux
Opened by Julian Scheel (jusst) - Friday, 16 January 2009, 19:16 GMT
Last edited by Jan de Groot (JGC) - Sunday, 15 February 2009, 00:46 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Tobias Powalowski (tpowa)
Jan de Groot (JGC)
Architecture All
Severity Critical
Priority Normal
Reported Version None
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

When updating to kernel 2.6.28 in combination with an intel graphics chipset and using the composite extension after a few minutes of working X.org will enter an infinite loop.
The Xorg.0.log will show:
[mi] EQ overflowing. The server is probably stuck in an infinite loop.

Only possible action afterwards is moving the mouse.

This is actually a known Xorg/intel bug, for which a fix exists:
https://bugs.freedesktop.org/show_bug.cgi?id=18922

As this is a real show-stopper bug it would be important to get it fixed soon.
This task depends upon

Closed by  Jan de Groot (JGC)
Sunday, 15 February 2009, 00:46 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed with libdrm-2.3.1-3.
Comment by Jan M. (funkyou) - Saturday, 17 January 2009, 13:30 GMT
I can confirm this issue. Sometimes it happens after some minutes, sometimes after some hours.

Using these patches from Jesse Barnes solved it for me:

https://bugs.freedesktop.org/show_bug.cgi?id=18922#c25

I have attached these 3 patches. 2 of them are against kernel26 and one against the current libdrm in Arch. The libdrm patch had to be rediffed a bit, because a small part of the changes (just one line) are already in the current libdrm sources used by Arch, and it needed some more small changes in Makefile.in to make it compile.
Comment by Jonas Pollok (jonas.p) - Sunday, 18 January 2009, 10:15 GMT
I just wanted to confirm that the patch fixed the issue for me, too.

Thanks.
Comment by Tobias Powalowski (tpowa) - Monday, 19 January 2009, 06:27 GMT
kernel is fixed in testing, Jan do you go for libdrm?
Comment by Julian Scheel (jusst) - Tuesday, 20 January 2009, 08:24 GMT
kernel-2.6.28.1 from today + libdrm-newest from AUR (2.4.4) seems to fix it. so updating libdrm (it's outdated anyway) would be nice
Comment by Jan de Groot (JGC) - Tuesday, 20 January 2009, 08:36 GMT
Updating libdrm won't happen because it breaks things on both the ATI and Intel driver. We need a new version of mesa to get this thing working correctly. I will apply the patch suggested in this bugreport soon.
Comment by Julian Scheel (jusst) - Tuesday, 20 January 2009, 09:49 GMT
In how far does the new libdrm break things? - I run the intel driver and haven't seen breakage yet.
Comment by Jan de Groot (JGC) - Tuesday, 20 January 2009, 09:57 GMT
I haven't been able to draw any window borders with compiz for example, and the xf86-video-ati driver turns black completely when using compiz with newer versions of libdrm.
Comment by Dan Spector (dakor) - Wednesday, 21 January 2009, 13:14 GMT
Updating libdrm from the AUR worked for me. Did not break my Intel driver.

Loading...