Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#12798 - [mysql] mysqld rc-script must not use pidof

Attached to Project: Arch Linux
Opened by Pierre Schmitz (Pierre) - Thursday, 15 January 2009, 11:08 GMT
Last edited by Douglas Soares de Andrade (dsa) - Monday, 08 June 2009, 12:47 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Pierre Schmitz (Pierre)
Douglas Soares de Andrade (dsa)
Andrea Scarpino (BaSh)
Architecture All
Severity High
Priority High
Reported Version None
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

The current implementation of the mysqld rc script uses pidof to determine the pid of the mysqld process. But this way one cannot say if the process was started by the rc script or something else.

For example akonadi starts its own mysqld as a user process. The result is that you cannot use mysqld and KDE at the same time. A better method is to use the pid file by mysql.

I have attached a quick-dirty patch to solve this.
This task depends upon

Closed by  Douglas Soares de Andrade (dsa)
Monday, 08 June 2009, 12:47 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in the lastest release. We will just kill the mysqld process owned by the mysql user, any other will remain (as the ones opened by akonadi).
Comment by Pierre Schmitz (Pierre) - Tuesday, 20 January 2009, 11:00 GMT
  • Field changed: Status (Unconfirmed → Assigned)
  • Field changed: Severity (Low → High)
  • Field changed: Priority (Normal → High)
I increased the priority because this is a showstopper for KDE 4.2.
Comment by Pierre Schmitz (Pierre) - Saturday, 31 January 2009, 10:59 GMT
Somehow this chagnes were reverted in the latest mysql version.
Comment by Douglas Soares de Andrade (dsa) - Saturday, 31 January 2009, 11:32 GMT
Hi Pierre,

Could you provide a patch that fixes the issue ? I have done two patches, even the last one that worked for me but i could not understand why there where some people that mysql did not started in the boot.
Comment by Damjan Georgievski (damjan) - Sunday, 01 February 2009, 21:10 GMT
@dsa

not everyone need mysql all the time... I only start it (and apache) to test or work on some Web stuff.. most of the time I dont need it, so I want them off to preserve RAM and battery.
Comment by Damjan Georgievski (damjan) - Sunday, 01 February 2009, 21:16 GMT
Here's an updated patch to the latest version of MySQL 5.0.75-4
Comment by Damjan Georgievski (damjan) - Monday, 09 February 2009, 16:06 GMT
I wonder if there's a need for reminders on these tasks?
Comment by Pierre Schmitz (Pierre) - Thursday, 04 June 2009, 15:06 GMT
This is not fixed! The rc.d script still kills any mysql process started by a user. This breaks KDE.

Loading...