Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#12729 - Annoying sound in console and in gnome kernel 2.6.28

Attached to Project: Arch Linux
Opened by Ionut Biru (wonder) - Saturday, 10 January 2009, 15:32 GMT
Last edited by Roman Kyrylych (Romashka) - Monday, 26 January 2009, 11:13 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To No-one
Architecture i686
Severity Low
Priority Normal
Reported Version None
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
The sound appear after upgrading to kernel 2.6.28 from testing the first release.
the fix that i found was to load pcspkr. now with the latest release from testing the sound had appear and is stopping ONLY if i load pcspkr after i log in in gnome.
more here: http://bbs.archlinux.org/viewtopic.php?id=61914

i can provie more information if needed but i don't know how to debug this issue

Additional info:
* package version(s)
* config and/or log files etc.

kernel26 2.6.28-3

Steps to reproduce:
log in, open terminal, run vi and hit backspace.
This task depends upon

Closed by  Roman Kyrylych (Romashka)
Monday, 26 January 2009, 11:13 GMT
Reason for closing:  Not a bug
Comment by Matthew Gyurgyik (pyther) - Saturday, 10 January 2009, 20:26 GMT
You should blacklist pcspkr and snd_pcsp in your MODULES=(...) unless if you need them. You wouldn't wan to load them as that is what is making the beeping noise.

Ex: MODULES=(!pcspkr !snd_pcsp ...)
Comment by Ionut Biru (wonder) - Saturday, 10 January 2009, 20:37 GMT
if you would read the link from bbs you'll find out that in the beginning i had blacklisted those module.
Comment by Matthew Gyurgyik (pyther) - Saturday, 10 January 2009, 20:58 GMT
Well the link from the bbs is very misleading as it is marked as solved. Anyways are you able to post the output of lsmod?
Comment by Ionut Biru (wonder) - Saturday, 10 January 2009, 21:08 GMT
lsmod output
   lsmod (3.9 KiB)
Comment by Matthew Gyurgyik (pyther) - Saturday, 10 January 2009, 21:12 GMT
Does this happen on other distributions with the same kernel? You have tried to rmmod pcspkr with this current kernel version correct? Is the beeping indeed coming from the pc speaker, or from your actual speakers?

This sounds as if it is an up stream bug and not an arch related bug.
Comment by Ionut Biru (wonder) - Saturday, 10 January 2009, 21:22 GMT
1. don't know. i only use archlinux
2. i mention that on forum that the problem has appear only after upgrading to testing a.k.a 2.6.28.
3. speakers
Comment by Matthew Gyurgyik (pyther) - Saturday, 10 January 2009, 22:37 GMT
Well if it is coming from the speakers... run alsamixer and see if there is a pc speaker mixer.
I had a card a while ago, with such a mixer, however it didn't do anything for me.
Comment by Ionut Biru (wonder) - Saturday, 10 January 2009, 22:50 GMT
heh. that was it. i had to mute pc beep
Comment by Matthew Gyurgyik (pyther) - Saturday, 10 January 2009, 23:03 GMT
Cool, must have been a new "feature" :)
Comment by Alessandro Doro (adoroo) - Sunday, 11 January 2009, 13:38 GMT
If you really don't want the terminal beep you should put the line:
set bell-style visible
or:
set bell-style none
in your .inputrc

If you want to completly disable beeping/flashing in vim I also suggest you to add:
set vb t_vb=
to your .vimrc
Comment by Ionut Biru (wonder) - Sunday, 11 January 2009, 14:19 GMT
that's no configuration issue. vi was just an example. the beeping appear also in pidgin, xchat, thunderbid.
the fix was to mute Pc Beep channel from alsamixer

Loading...