Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#12707 - Mouse left click not working properly after packages upgrade

Attached to Project: Arch Linux
Opened by Radu Potop (wooptoo) - Thursday, 08 January 2009, 00:34 GMT
Last edited by Aaron Griffin (phrakture) - Wednesday, 21 January 2009, 07:16 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture i686
Severity High
Priority Normal
Reported Version None
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
After I upgraded the following packages my mouse stopped working properly:

[2009-01-03 03:10] upgraded hwdetect (2008.12-3 -> 2008.12-4)
[2009-01-03 03:10] upgraded libdc1394 (2.0.1-1 -> 2.0.3-1)
[2009-01-03 03:10] upgraded libexif (0.6.16-1 -> 0.6.17-1)
[2009-01-03 03:10] upgraded mcpp (2.6.4-2 -> 2.7.2-1)

I have to press the left click button 3-4 times to make a click. Sometimes it works with only one press, but that's rare. It simply doesn't register the event properly. The other buttons work as expected and the mouse isn't broken physically. I tried downgrading hwdetect to 2008.12-3 with no success. This problem isn't specific to X11, since it doesn't work with gpm either.


Additional info:

The mouse is a Microsoft Laser Mouse 6000 on USB.

I also tried this:

$ lsmod|grep mouse
psmouse 38288 0

Why isn't the module used and is it the right module?
This task depends upon

Closed by  Aaron Griffin (phrakture)
Wednesday, 21 January 2009, 07:16 GMT
Reason for closing:  Not a bug
Additional comments about closing:  LOL :)
Comment by Radu Potop (wooptoo) - Monday, 19 January 2009, 22:23 GMT
the mouse is actually broken physically :(

Loading...