Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#12646 - Certain Packages cannot be built as regular user with makepkg

Attached to Project: Pacman
Opened by Gereon Schomber (IncredibleLaser) - Friday, 02 January 2009, 22:35 GMT
Last edited by Allan McRae (Allan) - Wednesday, 07 January 2009, 02:44 GMT
Task Type Bug Report
Category makepkg
Status Closed
Assigned To Allan McRae (Allan)
Architecture All
Severity Medium
Priority Normal
Reported Version None
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
The building process of certain packages fails when initiated by makepkg as a regular user because of segmentation fault.

Additional info:
* pacman version 3.2.1-2
I cannot compile amarok2-svn and mplayer-svn from the AUR. I could post my makepkg.conf, but the mplayer-svn gets a segfault when running configure, so it's neither a makeflag, nor a C(XX)FLAG. The packages compile without problems when running "sudo makepkg --asroot". The error is documented at http://bbs.archlinux.org/viewtopic.php?id=59500 and at http://aur.archlinux.org/packages.php?ID=16935 (I get the same error at another point in the process). Building them manually as regular user works. Another user reports the same problem at http://bbs.archlinux.org/viewtopic.php?id=62013 . Happens to me both on 32 and 64 bit. Long story short:

Problematic package
- can be compiled by hand as regular user
- can be compiled by makepkg as root
- cannot be compiled by makepkg as regular user

Sadly, I cannot say what causes this. As only certain packages are affected, I'm flagging this as Medium.

Steps to reproduce:
Try to compile these packages (mplayer-svn without my patch, amarok2-svn) as regular user with makepkg.
This task depends upon

Closed by  Allan McRae (Allan)
Wednesday, 07 January 2009, 02:44 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#12653 
Comment by Allan McRae (Allan) - Saturday, 03 January 2009, 04:09 GMT
I can not replicate the failure in mplayer-svn-28238 (although build fails later on...) and amarok2-svn-904578

The only real difference between building in amkepkg and building as a user is fakeroot usage. I am using fakeroot-1.11.4-1 from [testing]. Perhaps that fixes the issue.
Comment by Gereon Schomber (IncredibleLaser) - Saturday, 03 January 2009, 10:10 GMT
Yes, the new fakeroot fixes the problem. I wasn't even aware that there is a testing repository, even though I'm using unstable. Thank you very much! That was a bit stupid... I even tried out fakeroot-ng, but never had the idea to just update the original one... both seem to compile with small modifications in the PKGBUILD (copying the svn-dir to a build-dir and using that one). I just donated you guys some money for being my distribution of choice and the quick help you provided.
Comment by Attila (attila) - Tuesday, 06 January 2009, 19:16 GMT
  • Field changed: Percent Complete (100% → 0%)
Sorry for re-open but i recognized the same and the new fakeroot 1.11.4-1 from core don't solves it.
Comment by Allan McRae (Allan) - Wednesday, 07 January 2009, 02:44 GMT
A new bug report was opened before this one was re-opened. Continue the discussion in  FS#12653 .

Loading...