Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#12614 - Touchpad problem with kernel 2.6.28

Attached to Project: Arch Linux
Opened by Matthias Dienstbier (fs4000) - Monday, 29 December 2008, 22:46 GMT
Last edited by Jan de Groot (JGC) - Sunday, 15 March 2009, 17:42 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To No-one
Architecture x86_64
Severity Medium
Priority Normal
Reported Version None
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


With kernel 2.6.28 from testing tapping on my tpuchpad does not work anymore. Recently the touchpad did not respond at all until I restarted X.
Curiously everything works fine with my own kernel. I did not use any patches.

Here is my kernel config:
Diff Arch's config with mine:

I hope this is not only a different default configuration of evdev or something like that, but even then there is no reason for the touchpad not to respond at all.

Thanks for your time.

Additional info:
* package version(s)
kernel26 2.6.28
This task depends upon

Closed by  Jan de Groot (JGC)
Sunday, 15 March 2009, 17:42 GMT
Reason for closing:  Fixed
Additional comments about closing:  ETPS/2 touchpads are setup with synaptics by default now. Fixed in 1.1.0 in testing.
Comment by Jan de Groot (JGC) - Tuesday, 30 December 2008, 16:04 GMT
Can you attach the output of dmesg?

Note that with the new kernel26 package, Elantech touchpads are recognized as ETPS/2 touchpads instead of logitech IMPS/2 devices. With my laptop, I had to switch to the synaptics driver to get tapping back. The evdev driver somehow doesn't respond to taps with the new kernel.
Comment by Matthias Dienstbier (fs4000) - Tuesday, 30 December 2008, 18:54 GMT
You must be right, this line doesn't appear on my kernel.
input: ETPS/2 Elantech Touchpad as /class/input/input6
Then I don't know what caused the touchpad to fail once. I thought there would be a relation between these erorrs. But when the first one is in fact a "feature", perhaps it was just coincidence. I'll keep testing Arch's kernel. If it occurs again, I'll report back.
Comment by Matthias Dienstbier (fs4000) - Tuesday, 30 December 2008, 20:23 GMT
Now I'm able to reproduce it. After a vt-switch the touchpad doesn't respond until X gets reset by kdm after a logout or restarted. There are no problems with my USB-mouse. Also I didn't notice that when running my kernel.
Comment by Adrian C. (anrxc) - Tuesday, 30 December 2008, 22:04 GMT
I just tried it, switching to vc1 and coming back to X my touchpad worked fine (using synaptics) along with tapping. However I lost my keyboard (using evdev), I managed to reset it by c/p:

echo -n "i8042" > /sys/bus/platform/drivers/i8042/unbind
echo -n "i8042" > /sys/bus/platform/drivers/i8042/bind

The keyboard worked, but half of my keys were wrongly mapped (mainly media keys, but some of them are double purpose and important, like up/dn). Restarting X after that didn't make a difference. If this happened with 2.6.27 and older evdev I haven't noticed, being that I hardly ever switch consoles. Should I redirect this to another bug report?
Comment by Tobias Powalowski (tpowa) - Friday, 02 January 2009, 11:37 GMT
you need to configure your x correct, with the new kernel also touchpads are handled with the synaptics driver
Comment by Matthias Dienstbier (fs4000) - Friday, 02 January 2009, 15:47 GMT
Now I'm using synaptics. My previous problems are gone, but there is a new one: The cursor always moves 2 pixels.
I modified 11-x11-synaptics.fdi to also handle "ETPS/2 Elantech Touchpad" because it wasn't detected as a touchpad.
Even with Option "AutoAddDevices" "False" in xorg.conf and only having synaptics as driver result in this problem.
Comment by Jan de Groot (JGC) - Friday, 02 January 2009, 16:01 GMT
I wonder how you can move exactly one pixel with a touchpad. When I start moving slowly on my ETPS/2 touchpad, my cursor always moves either 2 or 3 pixels.

to test synaptics settings, you should turn on input hotplugging and edit the fdi file you use for your synaptics settings. Settings are reloaded whenever the mouse gets attached and detached, something that can be done by rmmodding and insmodding the psmouse kernel module. This is easier than restarting X everytime you want to try new settings.
Another option is using SHMConfig and some GUI tool to make settings.
Comment by Matthias Dienstbier (fs4000) - Saturday, 03 January 2009, 01:04 GMT
Tried several options with synaptics, but I cannot solve the problem. Well, it's not really obstructive, therefore you may close this bug.
Just inform the users about that change: They need a new HAL-policy for this touchpad.
<match key="info.capabilities" contains="input.touchpad"> doesn't comprehend it.
I used <match key="info.product" contains="ETPS/2 Elantech Touchpad">

Thanks :-)
Comment by Casey Jones (CJones) - Saturday, 03 January 2009, 07:42 GMT
I can confirm this is a problem with the Arch Linux patchset. I had this problem on my Eee PC 900 using the kernel in testing. Going back to 2.6.27-7 fixed it. Today I compiled a vanilla 2.6.28 kernel on my Gentoo machine (compiling sucks on this Eee ;)) and I'm running it now on my Eee and I am not experiencing this bug, and I've been using the same xorg.conf this whole time.
Comment by Jan de Groot (JGC) - Saturday, 03 January 2009, 12:38 GMT
This is caused by the new CONFIG_MOUSE_PS2_ELANTECH option which is set in the default archlinux kernel. Without this option, the touchpad is emulated as a Logitech IMPS/2 mouse, which was the case for 2.6.27. The disadvantage of this option is that evdev doesn't detect tapping anymore, but the bright side of this is that the synaptics driver supports the touchpad when this option is set, and allows much more configuration than the standard mousedrivers available.
Comment by Adrian C. (anrxc) - Saturday, 14 February 2009, 21:43 GMT
I am very glad to say that what I reported above in comment 36835 is fixed with the latest bundle of updates from 13.02. I am able to switch between consoles and keyboard is still working when I return to X if using evdev.
Comment by Jan de Groot (JGC) - Saturday, 14 February 2009, 21:50 GMT
So this bug is actually fixed with latest xf86-input-evdev and/or xf86-input-synaptics packages?
Comment by Adrian C. (anrxc) - Saturday, 14 February 2009, 22:09 GMT
I did not have a touchpad problem like OP did, unfortunately I did with my keyboard and I was able to find only one or two other people (on the BBS) that experienced the same (evdev keyboard stops working on console switch). I directed them to this report but I see that neither checked in.

So the keyboard is fixed with the upgrade, definitely.
While the touchpad "bug" was never really a bug as I understand it... just people not reading documentation/changelog.
Comment by Jan de Groot (JGC) - Saturday, 14 February 2009, 22:23 GMT
OK, so the keyboard works fine now and the touchpad works fine after changing the .fdi file to load synaptics instead of evdev for Elantech touchpads? In that case I'll update the default synaptics fdi file to match on elantech touchpads too and close this bug.
Comment by Matthias Dienstbier (fs4000) - Sunday, 15 February 2009, 14:08 GMT
Yes, it works then. But to get all functions back (tapping, scrolling, ...) additional options are needed. Even the edges aren't detected correctly.
But I haven't used synaptics before, so I don't know how well it should work.
Comment by Martin Sandsmark (sandsmark) - Saturday, 14 March 2009, 02:34 GMT
Tapping still doesn't work. Edge-scrolling doesn't work (but two-finger-scrolling does). Any hints on how to enable it again are very welcome.
Comment by Tobias Powalowski (tpowa) - Saturday, 14 March 2009, 07:27 GMT
this is a config issue setup your /etc/hal/policy/11-synaptics... correct for this, it is disabled by hal by default.
You need to copy synaptics file to /etc/hal/... to correct this.
Comment by Martin Sandsmark (sandsmark) - Saturday, 14 March 2009, 11:43 GMT
My /etc/hal/fdi/policy/11-x11-synaptics.fdi:

<?xml version="1.0" encoding="ISO-8859-1"?>
<deviceinfo version="0.2">
<match key="info.capabilities" contains="input.mouse">
<match key="info.product" contains="ETPS/2 Elantech Touchpad">
<merge key="input.x11_driver" type="string">synaptics</merge>
<merge key="input.x11_options.SHMConfig" type="string">on</merge>

I've tried enabling tapping et al in gsynaptics (and ksynaptics), but still no go. I can adjust all the other parameters without problem.
Comment by Matthias Dienstbier (fs4000) - Saturday, 14 March 2009, 23:54 GMT
You need some more configuration, here's my current config:;id=20;thread=11767;post=2
You can test settings with synclient.