Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#12588 - opera browser dependencies

Attached to Project: Arch Linux
Opened by Josef Lusticky (EVRAMP) - Saturday, 27 December 2008, 17:10 GMT
Last edited by Isenmann Daniel (ise) - Tuesday, 10 February 2009, 17:10 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Isenmann Daniel (ise)
Architecture i686
Severity Low
Priority Normal
Reported Version None
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Opera 9.63 in extra has Qt as dependency for i686, but the PKGBUILD uses opera static build already shipping Qt.
Please use Qt3-shared build (as for x64_86) or remove Qt dependency.
This task depends upon

Closed by  Isenmann Daniel (ise)
Tuesday, 10 February 2009, 17:10 GMT
Reason for closing:  None
Additional comments about closing:  The i686 version will be use Qt4 static and the x86_64 will use Qt3 shared as long as their is no Qt4 version. If there is a Qt4 shared version, both will be switched to it. The Qt dependency of the i686 version will be removed in next release.
Comment by Alessandro Doro (adoroo) - Sunday, 28 December 2008, 14:12 GMT Comment by Josef Lusticky (EVRAMP) - Sunday, 28 December 2008, 16:28 GMT
A year ago we had Opera dynamically compiled against Qt3 => Qt3 was a dependency.
Now we have the same for x64_86, but for i686 PKGBUILD fetches opera STATIC Qt4 build (needed part of qt4 is already in opera) => Qt4 is not a dependency.
However Opera has no Qt4 dynamic build (these will be in Opera 10). I suggest building Qt3 dynamic version, so both architectures will have the same.
Plus one more reason, Qt3 is still present on many computers - even when using KDE4 (not all apps from KDE are already Qt4, e.g. K3b).
Comment by Isenmann Daniel (ise) - Sunday, 28 December 2008, 16:42 GMT
You are not completly right about opera 10 and qt4 dynamic builds. At the moment there are no Qt4 shared builds of the alpha version of Opera 10. I have told many times in the forum that the users should complain at opera that there should be a Qt4 shared version. But it seems that no one have done it. A few months ago there were some users who want the Qt4 build, no matter if shared or static. I have changed it for the i686 version, because x86_64 version don't have a Qt4 build at all. Now you are complaining about changing it back or removing Qt dependencies.

You are right about the Qt dependency, it isn't necessary for the i686 version. I will ask the other developers for further process of static or shared builds. This topic annoys me. Every new version of opera it appears again.
Comment by Josef Lusticky (EVRAMP) - Sunday, 28 December 2008, 16:55 GMT
ok sorry for annoying :(

>You are not completly right about opera 10 and qt4 dynamic builds.
try this one: http://snapshot.opera.com/unix/10.0-Alpha-1/intel-linux/opera-10.00-4102.gcc4-qt4.i386.tar.bz2
Comment by Isenmann Daniel (ise) - Sunday, 28 December 2008, 17:10 GMT
This is not a shared version, this is a static build.

It's not you who annoys me, it's the topic... ;)

Loading...