Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#12566 - Report 'Upgrade' Size

Attached to Project: Pacman
Opened by Sander Jansen (GogglesGuy) - Wednesday, 24 December 2008, 23:47 GMT
Last edited by Allan McRae (Allan) - Friday, 15 July 2011, 04:37 GMT
Task Type Feature Request
Category General
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version 3.2.1
Due in Version 4.0.0
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

When doing a pacman -Suy, the "Installed Size" is not very handy in determining if you have enough disk space, since upgrading most of the time replaces existing files on disk. So would be nice, in addition of having the Installed Size, to show the "Upgrade" Size, which would be calculated:

(Upgrade Size) = (New Package Revision Installed Size) - (Old Packge Revision Installed Size)

And yes, this could become negative if newer packages require less disk space.
This task depends upon

Closed by  Allan McRae (Allan)
Friday, 15 July 2011, 04:37 GMT
Reason for closing:  Implemented
Additional comments about closing:  http://projects.archlinux.org/pacman.git /commit/?id=8f30e1b1
Comment by Nagy Gabor (combo) - Wednesday, 14 January 2009, 18:07 GMT
Well, during install you need more disk space than your preferred "Upgrade Size" (package cache etc).

Personally I prefer the old "Installed Size" over "Upgrade Size" (or do you want to print both infos?). I don't know the size of most of my installed packages, so "Upgrade Size" 15 Kb doesn't seem too informative.
Comment by Sander Jansen (GogglesGuy) - Wednesday, 14 January 2009, 19:56 GMT
"in addition of having the Installed Size".

I think the download, install and upgrade sizes are handy to have imho.
Comment by Laszlo Papp (djszapi) - Friday, 30 October 2009, 21:47 GMT
What about this request ? Maybe it makes sense to give it a try to implement.
Comment by mattia (nTia89) - Monday, 02 May 2011, 21:06 GMT
quote the feature request
Comment by Dan McGee (toofishes) - Wednesday, 01 June 2011, 22:15 GMT
dmcgee@galway ~/projects/pacman (master)
$ sudo ./src/pacman/pacman -Su
:: Starting full system upgrade...
resolving dependencies...
looking for inter-conflicts...

Targets (1): telepathy-glib-0.14.7-1

Total Download Size: 1.07 MiB
Total Installed Size: 15.72 MiB
Net Upgrade Size: -0.29 MiB

Proceed with installation? [Y/n] ^C
Interrupt signal received

Patch on ML: http://mailman.archlinux.org/pipermail/pacman-dev/2011-June/013211.html
Comment by Luke (masteryod) - Tuesday, 09 August 2011, 08:36 GMT
Very handy! :) but "Net Upgrade Size" isn't that name little tricky to understand for users not familiar with pacman bugs/requests? Maybe something like:

Storage/Disk(?) Upgrade Cost: +10.54MB

(or something else, any ideas?)

yep I'm thinking about plus sign to be also visible, what you think about it?
Comment by mattia (nTia89) - Tuesday, 09 August 2011, 15:45 GMT
imho arch users, because are arch users, they are naturally familiar with pacman

for plus sign, instead, is right. also for me is a good idea keep it
Comment by Luke (masteryod) - Tuesday, 09 August 2011, 21:46 GMT
Yes but (of course imho) that "Net" name is little misleading (you see "net" you think "network", I assume in this case "net" should indicate "netto"?) I'm not from english spoken country (you should know that by my grammar skills ;) and that "Net Upgrade Size" could be tricky for many people as I can see

The feature itself is awesome though :)
Comment by Dan McGee (toofishes) - Tuesday, 09 August 2011, 22:06 GMT
"Net" definition: http://www.learnersdictionary.com/search/net%5B3%5D

Please stop using the bug report as a forum. This isn't changing, it is done, implemented, and the bug is closed. Any improvements should come in another bug report with a patch attached or on the pacman-dev mailing list.

Loading...