Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#12551 - Unichrome (via) driver is obsolete

Attached to Project: Arch Linux
Opened by Filipp Andjelo (scorp) - Tuesday, 23 December 2008, 11:57 GMT
Last edited by Jan de Groot (JGC) - Sunday, 08 March 2009, 13:13 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Architecture i686
Severity Medium
Priority Normal
Reported Version None
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Unichrome driver was not recompiled after last xorg-server
(or kernel?) update, so via driver is not valid now. Openchrome
is not yet an alternative for unichrome, so X is not usable.

Additional info:
* package version(s)
- xorg-server 1.5.3-4
- xf86-video-unichrome 0.2.6-8


Steps to reproduce:
1) Install unichrome driver (via)
2) Try to start X
This task depends upon

Closed by  Jan de Groot (JGC)
Sunday, 08 March 2009, 13:13 GMT
Reason for closing:  Won't fix
Additional comments about closing:  unichrome is an unofficial driver. The only thing I can do is packaging git snapshots. If it works, you're happy. If it doesn't, try a different driver (openchome or vesa).
Comment by Filipp Andjelo (scorp) - Wednesday, 24 December 2008, 14:23 GMT
It was essentialy for me to have the unichrome diver running, so I've tried to compile it from source
(both, directly and ABS). The Problem seems to be larger than I thought. The driver is not compileable.
I've analysed code and the compile error messages and, if I see it right, unichrome driver is not
libpciacces capable and a modification like [http://www.x.org/wiki/PciReworkHowto] is needed.

It seems not to be an ArchLinux problem, so I think, the Task could be closed. At this point there is
no acceptable drivers for VIA Unichrome chips, openchrome driver seems to have problems too
[see Task ID 12311], it's very instable and too slow on playing videos. I don't know what's going on.
Comment by Jan de Groot (JGC) - Thursday, 25 December 2008, 18:28 GMT
I updated the unichrome driver to the latest git version. The sourceforge project is outdated and the driver hasn't had any releases. The developer is still committing things now and then though. The latest git version compiled fine with the current version of xorg-server. Please test it (0.2.7-0.1).
Comment by Filipp Andjelo (scorp) - Friday, 26 December 2008, 05:28 GMT
First of all thank you for your work, you guys are the best. Even on Christmas you don't make a pause.
To our problem, I've just tested the new drivers you uploaded and this is what I get:
...
(EE) UNICHROME(0): Internal error: could not map framebuffer
(EE) UNICHROME(0): Internal error: could not map framebuffer

Fatal server error:
AddScreen/ScreenInit failed for driver 0
...

I have to say, that I could satisfy openchrome with some workarounds to run. I still have some video issues particularly with VLC, but it's better than nothing. If you say unichrome is not really developed anymore, than it could be dropped from repository for the benefit of openchrome. What do you think?

Loading...