Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#12540 - makepkg should fail when >= is used in provides=()

Attached to Project: Pacman
Opened by shapeshifter (shapeshifter) - Monday, 22 December 2008, 16:21 GMT
Last edited by Dan McGee (toofishes) - Saturday, 03 January 2009, 05:28 GMT
Task Type Feature Request
Category makepkg
Status Closed
Assigned To Allan McRae (Allan)
Architecture All
Severity Low
Priority Normal
Reported Version 3.2.1
Due in Version 3.2.2
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Quite a few people submitting PKGBUILDs to AUR unknowingly use provides=('something>=1.2.3') when writing the PKGBUILD. Using ">=" in "provides" doesn't make sense and can lead to dependency resolution issues.

That is why makepkg should fail if its provided with such a PKGBUILD.

This task depends upon

Closed by  Dan McGee (toofishes)
Saturday, 03 January 2009, 05:28 GMT
Reason for closing:  Implemented
Additional comments about closing:  Addressed in commit 2f59996c54da473
Comment by Dan McGee (toofishes) - Monday, 22 December 2008, 18:16 GMT
It is documented in the man page (PKGBUILD.5), but maybe we should make it more clear that only = is supported?

This should be a good starter for anyone looking to contribute.
Comment by Allan McRae (Allan) - Thursday, 01 January 2009, 18:18 GMT Comment by tdy (tdy) - Friday, 02 January 2009, 13:18 GMT
I was just about to post something for this FS report with grep "[<>]" but looks like you already handled it. The for loop with bash subs later on is a better implementation anyway.

Loading...