Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#12403 - memory errors in X

Attached to Project: Arch Linux
Opened by userlander (userlander) - Wednesday, 10 December 2008, 14:52 GMT
Last edited by Hugo Doria (hdoria) - Saturday, 21 March 2009, 21:37 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Thomas B├Ąchler (brain0)
Architecture i686
Severity High
Priority Normal
Reported Version None
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description: many memory errors reported in X, impaired performance

Additional info:

ATI Radeon 9600

xf86-video-ati radeon driver

X.Org X Server 1.5.3
Release Date: 5 November 2008
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.27-ARCH i686
Current Operating System: Linux homer 2.6.27-ARCH #1 SMP PREEMPT Fri Nov 28 10:56:24 UTC 2008 i686
Build Date: 05 December 2008 09:10:55PM

Dec 10 08:52:04 desktop X:11400 conflicting memory types d0000000-d8000000 write-combining<->uncached-minus
Dec 10 08:52:04 desktop reserve_memtype failed 0xd0000000-0xd8000000, track write-combining, req write-combining
Dec 10 08:52:04 desktop X:11400 conflicting memory types d0000000-d8000000 write-combining<->uncached-minus
Dec 10 08:52:04 desktop reserve_memtype failed 0xd0000000-0xd8000000, track write-combining, req write-combining
Dec 10 08:52:04 desktop X:11404 freeing invalid memtype d0000000-d8000000
Dec 10 08:52:05 desktop X:11400 conflicting memory types d0000000-d8000000 write-combining<->uncached-minus
Dec 10 08:52:05 desktop reserve_memtype failed 0xd0000000-0xd8000000, track write-combining, req write-combining
Dec 10 08:52:05 desktop X:11410 freeing invalid memtype d0000000-d8000000
Dec 10 08:52:05 desktop [drm] Num pipes: 1
Dec 10 08:52:06 desktop X:11400 freeing invalid memtype d0000000-d8000000
Dec 10 08:53:41 desktop agpgart-amd64 0000:00:00.0: AGP 3.0 bridge
Dec 10 08:53:41 desktop agpgart-amd64 0000:00:00.0: putting AGP V3 device into 8x mode
Dec 10 08:53:41 desktop pci 0000:01:00.0: putting AGP V3 device into 8x mode
Dec 10 08:53:41 desktop [drm] Setting GART location based on new memory map
Dec 10 08:53:41 desktop [drm] Loading R300 Microcode
Dec 10 08:53:41 desktop [drm] Num pipes: 1
Dec 10 08:53:41 desktop [drm] writeback test succeeded in 1 usecs
Dec 10 08:53:42 desktop X:11464 conflicting memory types d0000000-d8000000 write-combining<->uncached-minus
Dec 10 08:53:42 desktop reserve_memtype failed 0xd0000000-0xd8000000, track write-combining, req write-combining
Dec 10 08:53:42 desktop X:11464 conflicting memory types d0000000-d8000000 write-combining<->uncached-minus
Dec 10 08:53:42 desktop reserve_memtype failed 0xd0000000-0xd8000000, track write-combining, req write-combining
Dec 10 08:53:42 desktop X:11468 freeing invalid memtype d0000000-d8000000
Dec 10 08:53:43 desktop X:11464 conflicting memory types d0000000-d8000000 write-combining<->uncached-minus
Dec 10 08:53:43 desktop reserve_memtype failed 0xd0000000-0xd8000000, track write-combining, req write-combining
Dec 10 08:53:43 desktop X:11474 freeing invalid memtype d0000000-d8000000
Dec 10 09:12:27 desktop [drm] Num pipes: 1
Dec 10 09:12:27 desktop X:11464 freeing invalid memtype d0000000-d8000000
Dec 10 09:15:06 desktop agpgart-amd64 0000:00:00.0: AGP 3.0 bridge
Dec 10 09:15:06 desktop agpgart-amd64 0000:00:00.0: putting AGP V3 device into 8x mode
Dec 10 09:15:06 desktop pci 0000:01:00.0: putting AGP V3 device into 8x mode
Dec 10 09:15:06 desktop [drm] Setting GART location based on new memory map
Dec 10 09:15:06 desktop [drm] Loading R300 Microcode
Dec 10 09:15:06 desktop [drm] Num pipes: 1
Dec 10 09:15:06 desktop [drm] writeback test succeeded in 1 usecs
Dec 10 09:15:07 desktop X:11974 conflicting memory types d0000000-d8000000 write-combining<->uncached-minus
Dec 10 09:15:07 desktop reserve_memtype failed 0xd0000000-0xd8000000, track write-combining, req write-combining
Dec 10 09:15:07 desktop X:11974 conflicting memory types d0000000-d8000000 write-combining<->uncached-minus
Dec 10 09:15:07 desktop reserve_memtype failed 0xd0000000-0xd8000000, track write-combining, req write-combining
Dec 10 09:15:07 desktop X:11979 freeing invalid memtype d0000000-d8000000
Dec 10 09:15:08 desktop [drm] Num pipes: 1
Dec 10 09:15:08 desktop X:11974 freeing invalid memtype d0000000-d8000000
Dec 10 09:15:41 desktop agpgart-amd64 0000:00:00.0: AGP 3.0 bridge
Dec 10 09:15:41 desktop agpgart-amd64 0000:00:00.0: putting AGP V3 device into 8x mode
Dec 10 09:15:41 desktop pci 0000:01:00.0: putting AGP V3 device into 8x mode
Dec 10 09:15:41 desktop [drm] Setting GART location based on new memory map
Dec 10 09:15:41 desktop [drm] Loading R300 Microcode
Dec 10 09:15:41 desktop [drm] Num pipes: 1
Dec 10 09:15:41 desktop [drm] writeback test succeeded in 1 usecs
Dec 10 09:15:42 desktop X:12009 conflicting memory types d0000000-d8000000 write-combining<->uncached-minus
Dec 10 09:15:42 desktop reserve_memtype failed 0xd0000000-0xd8000000, track write-combining, req write-combining
Dec 10 09:15:42 desktop X:12009 conflicting memory types d0000000-d8000000 write-combining<->uncached-minus
Dec 10 09:15:42 desktop reserve_memtype failed 0xd0000000-0xd8000000, track write-combining, req write-combining
Dec 10 09:15:42 desktop X:12013 freeing invalid memtype d0000000-d8000000
Dec 10 09:17:39 desktop [drm] Num pipes: 1
Dec 10 09:17:40 desktop X:12009 freeing invalid memtype d0000000-d8000000
Dec 10 09:17:43 desktop agpgart-amd64 0000:00:00.0: AGP 3.0 bridge
Dec 10 09:17:43 desktop agpgart-amd64 0000:00:00.0: putting AGP V3 device into 8x mode
Dec 10 09:17:43 desktop pci 0000:01:00.0: putting AGP V3 device into 8x mode
Dec 10 09:17:43 desktop [drm] Setting GART location based on new memory map
Dec 10 09:17:43 desktop [drm] Loading R300 Microcode
Dec 10 09:17:43 desktop [drm] Num pipes: 1
Dec 10 09:17:43 desktop [drm] writeback test succeeded in 1 usecs
Dec 10 09:17:44 desktop X:12097 conflicting memory types d0000000-d8000000 write-combining<->uncached-minus
Dec 10 09:17:44 desktop reserve_memtype failed 0xd0000000-0xd8000000, track write-combining, req write-combining
Dec 10 09:17:44 desktop X:12097 conflicting memory types d0000000-d8000000 write-combining<->uncached-minus
Dec 10 09:17:44 desktop reserve_memtype failed 0xd0000000-0xd8000000, track write-combining, req write-combining
Dec 10 09:17:44 desktop X:12101 freeing invalid memtype d0000000-d8000000
Dec 10 09:18:50 desktop [drm] Num pipes: 1
Dec 10 09:18:50 desktop X:12097 freeing invalid memtype d0000000-d8000000
Dec 10 09:19:00 desktop agpgart-amd64 0000:00:00.0: AGP 3.0 bridge
Dec 10 09:19:00 desktop agpgart-amd64 0000:00:00.0: putting AGP V3 device into 8x mode
Dec 10 09:19:00 desktop pci 0000:01:00.0: putting AGP V3 device into 8x mode
Dec 10 09:19:00 desktop [drm] Setting GART location based on new memory map
Dec 10 09:19:00 desktop [drm] Loading R300 Microcode
Dec 10 09:19:00 desktop [drm] Num pipes: 1
Dec 10 09:19:00 desktop [drm] writeback test succeeded in 1 usecs
Dec 10 09:19:01 desktop X:12192 conflicting memory types d0000000-d8000000 write-combining<->uncached-minus
Dec 10 09:19:01 desktop reserve_memtype failed 0xd0000000-0xd8000000, track write-combining, req write-combining
Dec 10 09:19:01 desktop X:12192 conflicting memory types d0000000-d8000000 write-combining<->uncached-minus
Dec 10 09:19:01 desktop reserve_memtype failed 0xd0000000-0xd8000000, track write-combining, req write-combining
Dec 10 09:19:01 desktop X:12196 freeing invalid memtype d0000000-d8000000
Dec 10 09:19:02 desktop X:12192 conflicting memory types d0000000-d8000000 write-combining<->uncached-minus
Dec 10 09:19:02 desktop reserve_memtype failed 0xd0000000-0xd8000000, track write-combining, req write-combining
Dec 10 09:19:02 desktop X:12202 freeing invalid memtype d0000000-d8000000
Dec 10 09:37:33 desktop [drm] Num pipes: 1
Dec 10 09:37:33 desktop X:12192 freeing invalid memtype d0000000-d8000000
Dec 10 09:38:57 desktop agpgart-amd64 0000:00:00.0: AGP 3.0 bridge
Dec 10 09:38:57 desktop agpgart-amd64 0000:00:00.0: putting AGP V3 device into 8x mode
Dec 10 09:38:57 desktop pci 0000:01:00.0: putting AGP V3 device into 8x mode
Dec 10 09:38:57 desktop [drm] Setting GART location based on new memory map
Dec 10 09:38:57 desktop [drm] Loading R300 Microcode
Dec 10 09:38:57 desktop [drm] Num pipes: 1
Dec 10 09:38:57 desktop [drm] writeback test succeeded in 1 usecs
Dec 10 09:38:58 desktop X:18783 conflicting memory types d0000000-d8000000 write-combining<->uncached-minus
Dec 10 09:38:58 desktop reserve_memtype failed 0xd0000000-0xd8000000, track write-combining, req write-combining
Dec 10 09:38:59 desktop X:18783 conflicting memory types d0000000-d8000000 write-combining<->uncached-minus
Dec 10 09:38:59 desktop reserve_memtype failed 0xd0000000-0xd8000000, track write-combining, req write-combining
Dec 10 09:38:59 desktop X:18787 freeing invalid memtype d0000000-d8000000
Dec 10 09:38:59 desktop X:18783 conflicting memory types d0000000-d8000000 write-combining<->uncached-minus
Dec 10 09:38:59 desktop reserve_memtype failed 0xd0000000-0xd8000000, track write-combining, req write-combining
Dec 10 09:38:59 desktop X:18793 freeing invalid memtype d0000000-d8000000
Dec 10 09:40:03 desktop [drm] Num pipes: 1
Dec 10 09:40:03 desktop X:18783 freeing invalid memtype d0000000-d8000000
Dec 10 09:40:07 desktop agpgart-amd64 0000:00:00.0: AGP 3.0 bridge
Dec 10 09:40:07 desktop agpgart-amd64 0000:00:00.0: putting AGP V3 device into 8x mode
Dec 10 09:40:07 desktop pci 0000:01:00.0: putting AGP V3 device into 8x mode
Dec 10 09:40:07 desktop [drm] Setting GART location based on new memory map
Dec 10 09:40:07 desktop [drm] Loading R300 Microcode
Dec 10 09:40:07 desktop [drm] Num pipes: 1
Dec 10 09:40:07 desktop [drm] writeback test succeeded in 1 usecs
Dec 10 09:40:08 desktop X:18974 conflicting memory types d0000000-d8000000 write-combining<->uncached-minus
Dec 10 09:40:08 desktop reserve_memtype failed 0xd0000000-0xd8000000, track write-combining, req write-combining
Dec 10 09:40:08 desktop X:18974 conflicting memory types d0000000-d8000000 write-combining<->uncached-minus
Dec 10 09:40:08 desktop reserve_memtype failed 0xd0000000-0xd8000000, track write-combining, req write-combining
Dec 10 09:40:08 desktop X:18978 freeing invalid memtype d0000000-d8000000
Dec 10 09:40:09 desktop X:18974 conflicting memory types d0000000-d8000000 write-combining<->uncached-minus
Dec 10 09:40:09 desktop reserve_memtype failed 0xd0000000-0xd8000000, track write-combining, req write-combining
Dec 10 09:40:09 desktop X:18984 freeing invalid memtype d0000000-d8000000

Steps to reproduce:
This task depends upon

Closed by  Hugo Doria (hdoria)
Saturday, 21 March 2009, 21:37 GMT
Reason for closing:  Fixed
Comment by Jan de Groot (JGC) - Wednesday, 10 December 2008, 21:29 GMT
I'm seeing this too, but only on my x86_64 systems. This might be a kernel issue also, but I'm not sure which of the two introduced this.
Comment by userlander (userlander) - Wednesday, 10 December 2008, 21:46 GMT
This is an A64 processor. I'm running Arch i686, however.
Comment by Jan de Groot (JGC) - Wednesday, 10 December 2008, 21:56 GMT
How much memory is in your system? I only have this on my desktop that has 8GB, I haven't seen this on my laptop and office workstation which both have 2GB.
Comment by userlander (userlander) - Wednesday, 10 December 2008, 22:25 GMT
1GB. will check my laptop for the errors tonight. it's having many of the same vid problems.
Comment by Miles (Miles28) - Friday, 12 December 2008, 17:51 GMT
I'm seeing this too.

686, agp ati radeon.

Dec 11 14:36:03 Xorg:2480 conflicting memory types e8000000-f0000000 write-combining<->uncached-minus
Dec 11 14:36:03 reserve_memtype failed 0xe8000000-0xf0000000, track write-combining, req write-combining
Dec 11 14:36:03 Xorg:2480 conflicting memory types e8000000-f0000000 write-combining<->uncached-minus
Dec 11 14:36:03 reserve_memtype failed 0xe8000000-0xf0000000, track write-combining, req write-combining
Dec 11 14:36:03 Xorg:2499 freeing invalid memtype e8000000-f0000000
Comment by Jan de Groot (JGC) - Monday, 15 December 2008, 09:47 GMT
It looks like mesa and/or libdrm is using MTRR code which is generating these errors in <2.6.28 kernels.
Comment by Miles (Miles28) - Tuesday, 16 December 2008, 10:49 GMT
In my case, adding 'nopat' to kernel startup string solves this issue.
Comment by Jan de Groot (JGC) - Wednesday, 17 December 2008, 08:36 GMT
Seems PAT can break MTRR things badly in 2.6.27. There's a fix applied in 2.6.28 which should fix these issues. Some people can't even start X at all when PAT is enabled with 2.6.26 and 2.6.27. The patch applies clean, but I don't know if it results in a compilable or bootable kernel yet.

http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff_plain;h=9542ada803198e6eba29d3289abb39ea82047b92
Comment by userlander (userlander) - Wednesday, 17 December 2008, 14:23 GMT
Seems safer just to try the nopat kernel option. Any idea how soon until 2.6.28 is available? At last check, it's still not in testing yet. But hopefully this is the answer and will even fix some of the choppy video problems that have cropped up lately, thanks for all the effort.
Comment by Jan de Groot (JGC) - Wednesday, 17 December 2008, 14:30 GMT
2.6.28 is not released upstream yet, so it will take a while before it makes its way to our distribution. 2.6.28 will also contain GEM, which might affect Intel users a lot.
Comment by Alois Nespor (anespor) - Friday, 26 December 2008, 08:55 GMT
I tested new kernel and big problems with 2.6.28. X server was very unstable and crash after a few minutes. After disable x86 PAT it looks good, errors does not.

----
x86_64, 2GB RAM, Intel GMA950, latest drivers and Xserver.
Comment by Adrian Goll (goll) - Thursday, 01 January 2009, 17:54 GMT
Can confirm the error using 2.6.27.10-1 i686 with 2GB of RAM and intel driver for a 4500MHD card. Hopefully the 2.6.28 together with GEM will fix these issues.
Comment by Musikolo (Musikolo) - Sunday, 08 February 2009, 12:44 GMT
I have the kernel 2.6.28.3-1 on a i686. I also have a radeon 8500 (r200) and getting the same memory errors. After adding 'nopat' my the kernel boot params, the issue seems solved.

Thanks a lot! :-)

Loading...