Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#12361 - sata_nv ata4: SATA link down (SStatus 0 SControl 300)

Attached to Project: Arch Linux
Opened by saro (0s4r) - Saturday, 06 December 2008, 13:43 GMT
Last edited by Tobias Powalowski (tpowa) - Friday, 13 February 2009, 09:42 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas B├Ąchler (brain0)
Architecture i686
Severity High
Priority Normal
Reported Version None
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
When using kernel 2.6.27.7-1, the hdd sata doesn't work and is not possible to use the sata_nv.patch because it's in conflict with the arch patch.

This is the patch that i use in the kernel26-2.6.27.6.
it's ok.
http://rafb.net/p/AcSySi87.html

The kernel.log is in the attach file.
   kernel.log (267.7 KiB)
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Friday, 13 February 2009, 09:42 GMT
Reason for closing:  Implemented
Additional comments about closing:  2.6.28.5
Comment by Tobias Powalowski (tpowa) - Sunday, 07 December 2008, 12:59 GMT Comment by Tobias Powalowski (tpowa) - Sunday, 07 December 2008, 13:00 GMT
You patch only differs in nv_reset part please report it upstream, .28 kernel also doesn't contain more fixes then this.
Comment by saro (0s4r) - Tuesday, 09 December 2008, 11:41 GMT
i have report it to bugzilla.kernel.org, this is the report: http://bugzilla.kernel.org/show_bug.cgi?id=12176
Comment by Glenn Matthys (RedShift) - Thursday, 18 December 2008, 08:37 GMT
What's the status of this issue? This link (http://rafb.net/p/AcSySi87.html) is gone.
Comment by Glenn Matthys (RedShift) - Sunday, 28 December 2008, 05:56 GMT
  • Field changed: Status (Assigned → Waiting on Response)
Do you (the reporter) still have problems with your nvidia SATA controller with kernel 2.6.28 from testing? I myself have a system with a sata_nv controller and can't reproduce the problem you are having.
Comment by saro (0s4r) - Sunday, 28 December 2008, 14:17 GMT
yes, the kernel 2.6.28 don't work.

this is the output

Comment by saro (0s4r) - Thursday, 01 January 2009, 17:06 GMT
no solution?
Comment by Tobias Powalowski (tpowa) - Tuesday, 06 January 2009, 08:21 GMT
well upstream rejects it because it's incorporated, we use latest upstream. Soemthing seems to be wrong here on here.
Comment by saro (0s4r) - Thursday, 12 February 2009, 10:35 GMT
The problem is fixed with the patch of Tejun Heo.
Read thid bug report http://bugzilla.kernel.org/show_bug.cgi?id=12176.

Loading...