Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#12324 - Soprano should depend on java-environment

Attached to Project: Arch Linux
Opened by paul (pwt) - Tuesday, 02 December 2008, 20:19 GMT
Last edited by Pierre Schmitz (Pierre) - Tuesday, 13 January 2009, 23:51 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Pierre Schmitz (Pierre)
Andrea Scarpino (BaSh)
Architecture All
Severity Low
Priority Normal
Reported Version None
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No



Looking at soprano binary package, it seems to be built with sesame2 backend support (it includes the necessary .jar and .so files).
However, looking at soprano sources, this backen is only built if java is detected.
The PKGBUILD does not require a java makedepends or depends. One of these should be added so that makepkg effectively builds the sesame2 support, otherwise it will not be built. I don't understand, by the way, how the binary package currently gets this support.


Additional info:
* package version(s)

* config and/or log files etc.

Steps to reproduce:
This task depends upon

Closed by  Pierre Schmitz (Pierre)
Tuesday, 13 January 2009, 23:51 GMT
Reason for closing:  Fixed
Comment by paul (pwt) - Wednesday, 03 December 2008, 22:12 GMT
To be more accurate: makedepends on java-environment and depends on java-runtime.
Comment by mutlu inek (mutlu_inek) - Monday, 12 January 2009, 16:49 GMT
The x86 soprano package in [testing] (ver. 2.1.65) does not have the sesame2 any more. Obviously, previously it was built accidentally because the build machine had jre or jdk installed. Now, however, only redland is available as a backend and it is _much_ slower than sesame2. I rebuilt using abs, but this should be fixed before the release.