Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#12317 - nfs mount freezes Gnome desktop

Attached to Project: Arch Linux
Opened by Artiom Molchanov (artiom) - Tuesday, 02 December 2008, 09:38 GMT
Last edited by Jan de Groot (JGC) - Friday, 29 May 2009, 17:56 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Jan de Groot (JGC)
Architecture All
Severity Medium
Priority Normal
Reported Version None
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
I have a nfs share mounted to /mnt/nfs and a link on the Gnome desktop to this share.
Normally it works. I can use the files on the volume. No special issue about this.
But sometimes when I try to open file form my local desktop it hangs. The same time it is impossible
to do ls on the /mnt/nfs (it hangs also).
The only solution is to force unmount this share with umount -f /mnt/nfs. While unmountig it says: "device or resource busy" but unmount is done.
There is no messages in the system log about nfs.


Additional info:
Nfs is mounted without any special options. But I have tried different options (packet sizes, hard, soft, etc) it change nothing.
nfs server is FreeBSD 7.0

Steps to reproduce:
Create a nfs mount entry in /etc/fstab
Mount created volume.
Make a link to its mount point on the desktop
Work normally.
...
Open a file on the desktop by any program hangs the open dialog.
ls on the mount point never shows it contents.
This task depends upon

Closed by  Jan de Groot (JGC)
Friday, 29 May 2009, 17:56 GMT
Reason for closing:  Not a bug
Additional comments about closing:  NFS problems cause hanging, GNOME can't avoid this.
Comment by Jan de Groot (JGC) - Tuesday, 02 December 2008, 10:15 GMT
This is not an issue with GNOME, but with the behaviour of NFS mounts. When your NFS server locks up, or something bad happens in the communication between server and client, every application using that NFS mount will wait untill it's killed or the NFS share comes back.
I've had several issues with FreeBSD NFS servers and linux NFS clients. Usually it comes to locking problems. Try mounting with nolock and see if it "fixes" your problem.
Comment by Artiom Molchanov (artiom) - Thursday, 04 December 2008, 10:05 GMT
I am agree with you about locking problems. I will search this way.
Comment by Artiom Molchanov (artiom) - Monday, 05 January 2009, 13:51 GMT
I have tried all lock related options. I have even stopped lockd on the server. Nothing works better. And I still don't have any special message in the log (client or server). How can I debug it?
Comment by Artiom Molchanov (artiom) - Monday, 12 January 2009, 15:39 GMT
Anyway, even it is a NFS problem, why it affects the Gnome Desktop this way? I have only a .desktop file which contains the directory in his options. The directory itself is in /mnt.
And if I put this file to Desktop all my icons disappear when the NFS problem occurs.
Comment by Jan de Groot (JGC) - Monday, 12 January 2009, 15:41 GMT
This is because any program accessing an unreachable NFS share will hang until the NFS server comes back. This is not a bug in GNOME, it's an incompatibility in your NFS setup.
Comment by Artiom Molchanov (artiom) - Monday, 12 January 2009, 15:52 GMT
The problem is that I didn't access this link. It is just present on the Desktop. I can agree that it hangs if I try to open it. But it hangs without my action.
Comment by Jan de Groot (JGC) - Monday, 12 January 2009, 17:44 GMT
It hangs because nautilus tries to stat the directory that is referenced in the link. Each and every way of accessing an unavailable NFS share results in a hanging application.

Loading...