Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#12311 - xf86-video-openchrome unusable with VIA vn896 Chrome 9 HC

Attached to Project: Arch Linux
Opened by gabriele lanaro (gabriele.lanaro) - Monday, 01 December 2008, 23:24 GMT
Last edited by Roman Kyrylych (Romashka) - Saturday, 27 December 2008, 14:06 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Architecture i686
Severity High
Priority Normal
Reported Version None
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:
screen freeze when starting X and moving mouse, don-t quit pressing Ctrl-alt-backspace

Additional info:
* package version(s)
* config and/or log files etc.


Steps to reproduce:
Set video driver "openchrome" in xorg.conf
startx
This task depends upon

Closed by  Roman Kyrylych (Romashka)
Saturday, 27 December 2008, 14:06 GMT
Reason for closing:  None
Additional comments about closing:  solution found in the first comment
Comment by Simon Lipp (moonz) - Thursday, 04 December 2008, 22:46 GMT
Same here. Looks like http://forums.fedoraforum.org/showthread.php?t=189424.

In short, try:

Section "Device"
...
Driver "openchrome"
Option "XaaNoImageWriteRect"
EndSection

or

Section "Device"
...
Driver "openchrome"
Option "NoAccel" "true"
EndSection

or

Section "Device"
...
Driver "openchrome"
Option "AccelMethod" "EXA"
Option "ExaNoComposite" "True"
Option "MigrationHeuristic" "greedy"
Option "ExaScratchSize" "8192"
Option "MaxDRIMem" "16384"
EndSection

No time to test it today, I will try it tomorrow.
Comment by gabriele lanaro (gabriele.lanaro) - Friday, 05 December 2008, 13:29 GMT
:) It seems to be ok with all of these variants!!
thank you very much for the solution, I think that the bug can be closed.
Comment by Gavin Bisesi (Daenyth) - Sunday, 07 December 2008, 01:15 GMT
Someone should add that fix to the wiki.
Comment by Simon Lipp (moonz) - Sunday, 07 December 2008, 09:58 GMT
Done.
For the record, this is openchrome bug #263 (http://www.openchrome.org/trac/ticket/263)
Comment by Gavin Bisesi (Daenyth) - Sunday, 07 December 2008, 13:29 GMT
Thanks.

Loading...