Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#12295 - xosd and xdialog should be compiled with gtk2 instead of gtk

Attached to Project: Arch Linux
Opened by tuxce (tuxce) - Sunday, 30 November 2008, 22:15 GMT
Last edited by Eric Belanger (Snowman) - Saturday, 21 March 2009, 20:21 GMT
Task Type Feature Request
Category Packages: Extra
Status Closed
Assigned To Aaron Griffin (phrakture)
Jürgen Hötzel (juergen)
Architecture All
Severity Medium
Priority Normal
Reported Version None
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Hi, the xosd and xdialog packages depends on gtk, but both can compile with gtk2 instead of gtk.

I think it would be better if they were built with gtk2.

Additional info:
* package version(s)
extra/xdialog 2.3.1-1
extra/xosd 2.2.14-1
This task depends upon

Closed by  Eric Belanger (Snowman)
Saturday, 21 March 2009, 20:21 GMT
Reason for closing:  Fixed
Additional comments about closing:  fixed in xosd-2.2.14-2. gdk-pixbuf is now an optdepends.
Comment by Jürgen Hötzel (juergen) - Friday, 05 December 2008, 22:41 GMT
done for xdialog -> commited/tagged 2.3.1-2

xosd doesn't depend on gtk.
Comment by tuxce (tuxce) - Monday, 08 December 2008, 00:32 GMT
xosd depends on gdk-pixbuf which depends on gtk.
gdk-pixbuf is used for xmms plugin, maybe it should be in optdepends.
Comment by Aaron Griffin (phrakture) - Monday, 08 December 2008, 18:02 GMT
Perhaps we should drop the xmms plugin altogether as xmms is no longer in the repos (oh, and it's crappy, heh)
Comment by Jürgen Hötzel (juergen) - Monday, 08 December 2008, 20:44 GMT
*shrug* bmp (gtk2 port of xmms) plugin also depends on old gdk-pixmap:

ldd ./pkg/usr/lib/bmp/General/libbmp_osd.so
...
libgdk_pixbuf.so.2 => /usr/lib/libgdk_pixbuf.so.2 (0xb7f8e000)
...
Comment by tuxce (tuxce) - Friday, 02 January 2009, 20:44 GMT
Since we can use xosd without bmp, gdk-pixbuf should be in optdeps.

Loading...