FS#12268 - Imlib2 update broke pypanel

Attached to Project: Community Packages
Opened by Florian Pritz (bluewind) - Friday, 28 November 2008, 13:04 GMT
Last edited by Ronald van Haren (pressh) - Tuesday, 02 December 2008, 10:16 GMT
Task Type Bug Report
Status Closed
Assigned To Jeff Mickey (codemac)
Architecture All
Severity High
Priority Normal
Reported Version None
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 5
Private No


Update from imlib2 1.4.1-2 to 1.4.2.-1 causes a general protection fault when starting pypanel. Downgrading fixed it.
Message in dmesg: pypanel[26509] general protection ip:7f6f5bf6d3bf sp:7fff66263f48 error:0 in libImlib2.so.1.4.2[7f6f5bf21000+66000]

Additional info:
pypanel 2.4-4
imlib2 1.4.2.-1

Steps to reproduce:
Install pypanel and imlib2. Start pypanel.
This task depends upon

Closed by  Ronald van Haren (pressh)
Tuesday, 02 December 2008, 10:16 GMT
Reason for closing:  Fixed
Additional comments about closing:  I think it should be fixed with imlib2 1.4.2-2. If not please re-open.
Comment by jasin (rooloo) - Friday, 28 November 2008, 17:10 GMT
I can confirm, pypanel must have imlib2-1.4.1-1 package for it to work. Upgrading to either 1.4.1-2 or 1.4.2-1 breaks pypanel.

Immediate seg fault upon starting the program.

Comment by jasin (rooloo) - Saturday, 29 November 2008, 04:42 GMT
Edit that last post, I rechecked with 1.4.1-2 and all works, so 1.4.2-1 is the offending package.
Comment by Ronald van Haren (pressh) - Sunday, 30 November 2008, 19:41 GMT
please try rebuilding pypanel against the latest imlib2 (via abs)
Comment by Øyvind Wilhelmsen (oew) - Sunday, 30 November 2008, 22:56 GMT
I tried to rebuild via abs, pypanel still segfaults.
Comment by Jeff Cook (cookiecaper) - Tuesday, 02 December 2008, 07:59 GMT
Same here, rebuilding from ABS has no effect. :(
Comment by Jud (judfilm) - Tuesday, 02 December 2008, 08:39 GMT
To try and sort this out, please list:
imlib2 version
pypanel working / non-working
CPU type & model
i686 / x86_64
Python version
If you did a full 'pacman -Syu' or selective upgrade
Comment by Ronald van Haren (pressh) - Tuesday, 02 December 2008, 10:09 GMT
Jud, I should have mentioned it, but I can confirm the issue at least on x86_64. I'll try disabling amd64 optimzalization flags in imlib2 later today (for x86_64 that is), but I hardly doubt that has caused this issue (let's hope I'm wrong).
Either way, pypanel is not maintained upstream for some years now so things like this are bound to happen at some time.

someone can confirm the same issue on i686?