Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#12216 - xulrunner 1.9.0.4 not in repository but required by firefox

Attached to Project: Arch Linux
Opened by Nicolas Doualot (slubman) - Sunday, 23 November 2008, 11:59 GMT
Last edited by Eric Belanger (Snowman) - Sunday, 23 November 2008, 19:33 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture x86_64
Severity Medium
Priority Normal
Reported Version None
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 10
Private No

Details

Description:
Wrong dependency for firefox (requires xulrunner 1.9.0.4 but repos only have 1.9.0.3)

Additional info:
* package version(s) : firefox 3.0.4-1, xulrunner 1.9.0.3-1

Steps to reproduce:
just pacman -Syu

You can also see the problem with this command:
$ pacman -Si firefox xulrunner | grep -E 'Name|Depends'
Name : firefox
Depends On : xulrunner=1.9.0.4 desktop-file-utils shared-mime-info
Name : xulrunner
Depends On : gtk2>=2.12.11 gcc-libs>=4.3.1 libidl2>=0.8.10
This task depends upon

Closed by  Eric Belanger (Snowman)
Sunday, 23 November 2008, 19:33 GMT
Reason for closing:  Fixed
Additional comments about closing:  wait for your mirror to sync.
Comment by Brian Long (vrtladept) - Sunday, 23 November 2008, 15:40 GMT
Confirmed on my system as well.
Comment by Cristian C. (ckristi) - Sunday, 23 November 2008, 16:34 GMT
I confirm this, too.
Comment by Smith Dhumbumroong (zodmaner) - Sunday, 23 November 2008, 16:39 GMT
For some reason, the x86_64 version of xulrunner 1.9.0.4 is not on the repository yet. It usually should be up at the same time as the new version of the Firefox.
Comment by Leonardo Andrés Gallego (sud_crow) - Sunday, 23 November 2008, 17:06 GMT
I can confirm too.
This breaks the system upgrade (pacman -Syu), so it should be marked as critical.
Comment by Cristian C. (ckristi) - Sunday, 23 November 2008, 17:22 GMT
It doesn't break the system upgrade if you do a "pacman -R firefox" for now.
Just a workaround for the moment, but I think it will get fixed soon.
Comment by Leonardo Andrés Gallego (sud_crow) - Sunday, 23 November 2008, 18:15 GMT
It does break the system upgrade if I have to remove a package to get it working.

I know that if I remove firefox, or upgrade xulrunner via the PKGBUILD, I can avoid the problem... but thats just a work around and the thing is the upgrade process is broken until this package gets fixed.

ps. I dont mind that much. I was simply reporting that due to this package, pacman cant get to upgrade the system.
Comment by Peter Kraus (PetoKraus) - Sunday, 23 November 2008, 18:38 GMT
Just fix it, it can't be that hard.... How about rolling back the dependency update for FFx, till xulrunner is REALLY "stabilised" (i know we are talking testing here).
Comment by Nicolas Doualot (slubman) - Sunday, 23 November 2008, 18:50 GMT
@Peter Kraus : I posted the bug about extra packages, I don't have testing enabled in my pacman.conf
Comment by Smith Dhumbumroong (zodmaner) - Sunday, 23 November 2008, 19:18 GMT
Also: http://www.archlinux.org/packages/extra/i686/xulrunner/
and: http://www.archlinux.org/packages/extra/i686/firefox/

As you can see, the i686 xulrunner package (in extra repository, obviously) was upgraded to 1.9.0.4 the same day Firefox for i686 was upgraded. Similar to the i686 packages, the x86_64 xulrunner and Firefox package have always been released together. So the fact that only Firefox package get upgraded this time is definitely a valid bug.

Comment by Peter Kraus (PetoKraus) - Sunday, 23 November 2008, 19:20 GMT
Just fix it, it can't be that hard.... How about rolling back the dependency update for FFx, till xulrunner is REALLY "stabilised" (i know we are talking testing here).

Loading...