Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#12126 - hal fails after update

Attached to Project: Arch Linux
Opened by Richard White (rwhite) - Saturday, 15 November 2008, 02:17 GMT
Last edited by Eduardo Romero (kensai) - Sunday, 16 November 2008, 15:54 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version None
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 6
Private No

Details

hal fails to start after update in testing

$ sudo /etc/rc.d/hal start
:: Starting Hardware Abstraction Layer [FAIL]
This task depends upon

Closed by  Eduardo Romero (kensai)
Sunday, 16 November 2008, 15:54 GMT
Reason for closing:  Fixed
Additional comments about closing:  Original bug has been fixed.
Comment by Eduardo Romero (kensai) - Saturday, 15 November 2008, 03:01 GMT
Yeah, it does fails, I think we are learning far too quick from Allan (Allan Broke It).
Comment by Jan de Groot (JGC) - Saturday, 15 November 2008, 10:24 GMT
Can you give some more details? Isn't hal already running for example? The new version of networkmanager starts it when it's not launched yet for example.
Comment by Eduardo Romero (kensai) - Saturday, 15 November 2008, 12:52 GMT
I am trying to debug this thing, and it is not useful, well, at boot HAL appears to start without error, but when I plug in my USB drive it says, IsCallerPrivileged() failed. I try to restart hal and it fails, and when I shutdown hal fails to stop there as well. So far all logs have been useless. I will try to find something.
Comment by Jan de Groot (JGC) - Saturday, 15 November 2008, 13:12 GMT
Note that hal is using consolekit/policykit since the latest release in testing. If your desktop environment doesn't support consolekit native, you'll have to add the consolekit pam modules to your pam configuration.
Comment by Eduardo Romero (kensai) - Saturday, 15 November 2008, 13:14 GMT
I'm using GNOME with GDM.
Comment by Blazej (blasse) - Saturday, 15 November 2008, 14:07 GMT
Got the same problem. HAL seems to start fine, but fails to restart, also cannot mount an usb drive, with the same error message IsCallerPrivileged() failed. Using latest GNOME from testing with GDM. Problem starts with latest update.
Comment by lorenzo (neuromante) - Saturday, 15 November 2008, 14:46 GMT
So is there any workaround? How do I add the consolekit pam modules to pam configuration?
Comment by Mihael Pranjić (tux) - Saturday, 15 November 2008, 17:38 GMT
Also, I think it should be "fails" and not "fales"...
But: I am experiencing the same problem since updating today
Comment by Qin Zhu (zhuqin) - Saturday, 15 November 2008, 18:04 GMT
Same problem confirmed, gnome and consolekit installed, failed to mount usb driver.
Comment by Alberto Casetta (kasa) - Saturday, 15 November 2008, 20:32 GMT
I had the same problem. Rebuilding HAL with the patch attached solved it for me.
Comment by jesusjimenez (jesusjimenez) - Saturday, 15 November 2008, 21:00 GMT
Yes, mounting works fine again with the patch above.
Comment by Eduardo Romero (kensai) - Saturday, 15 November 2008, 21:22 GMT
yep, patch fixes the problem, thanks kasa.
Comment by lorenzo (neuromante) - Saturday, 15 November 2008, 21:56 GMT
Confirmed. Patch works. Kudos to kasa
Comment by Jan de Groot (JGC) - Saturday, 15 November 2008, 22:16 GMT
hal 0.5.11-6 contains an upstream patch that should do the same as the patch attached in this bugreport.
Comment by Blazej (blasse) - Saturday, 15 November 2008, 22:31 GMT
After update the hal works and restarts ok, bu problem with mounting usb drives remains...
Comment by Qin Zhu (zhuqin) - Saturday, 15 November 2008, 22:32 GMT
the latest hal didn't fix mount problem.
Comment by Eduardo Romero (kensai) - Saturday, 15 November 2008, 22:32 GMT
blasse is right it does fix the stop/start of the service, but usb pendrive still doesn't mount, the patch above fixes this as well, but hal-0.5.11-6 doesn't.
Comment by Blazej (blasse) - Saturday, 15 November 2008, 22:36 GMT
Didn't now that, I'd follow the Jan de Groot comment, that patch in 0.5.11-6 should do the same :)
Comment by lorenzo (neuromante) - Saturday, 15 November 2008, 22:37 GMT
Why not simply implement the patch that kasa suggested? I simply add a command to the original PKGBUILD to apply that patch and hal works as expected. No hassles.
Comment by Blazej (blasse) - Saturday, 15 November 2008, 22:49 GMT
+1 for this, cause on my machine hal builds fails, so i cannot do this myself:/
Comment by jesusjimenez (jesusjimenez) - Saturday, 15 November 2008, 23:00 GMT
yap, that "#ifdef HAVE_CK_0_3" in 0.5.11-6 patch sucks ;)
Comment by lorenzo (neuromante) - Sunday, 16 November 2008, 00:17 GMT
Why not simply implement the patch that kasa suggested? I simply add a command to the original PKGBUILD to apply that patch and hal works as expected. No hassles.
Comment by Qin Zhu (zhuqin) - Sunday, 16 November 2008, 14:06 GMT
wait, my usb drivers cannot be mounted.
my errors.log:
Nov 15 21:56:37 Arch usb 1-5: device descriptor read/64, error -110
Comment by Eduardo Romero (kensai) - Sunday, 16 November 2008, 14:10 GMT
Can someone else confirm this is not fixed in some cases? zhuqin what filesystem do you use on that usb drive? Any other info you can give about it would be appreciated. Although I think the original problem has been fixed and a separate bug report should be made for this.
Comment by Manuel Gaul (Inkaine) - Sunday, 16 November 2008, 14:36 GMT
I had had these issues as well but after recent upgrade to 0.5.11-7 all is fine again. I can mount ext3, vfat and ntfs(-3g) partitions on an external USB HDD.
Comment by Qin Zhu (zhuqin) - Sunday, 16 November 2008, 14:59 GMT
I found out what the problem is: if I start x by xinit /usr/bin/gnome-session, then any usb drivers cannot be mounted, but gdm solved everything, I've no idea what's wrong.

Loading...