Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#12025 - xorg-server 1.5.3-1 breaks USB mice/keyboard

Attached to Project: Arch Linux
Opened by Shem Valentine (xvalentinex) - Friday, 07 November 2008, 00:41 GMT
Last edited by Aaron Griffin (phrakture) - Thursday, 20 November 2008, 20:28 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Jan de Groot (JGC)
Architecture i686
Severity High
Priority Normal
Reported Version None
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No


Description: xorg-server 1.5.3-1 breaks USB mice/keyboard

Additional info:
* xorg-server-1.5.3-1

Steps to reproduce:

Updating to latest xorg-server-1.5.3-1 breaks my ability to use USB keyboard and mice.

I am currently in the process of debugging, will post more info when I get there.
This task depends upon

Closed by  Aaron Griffin (phrakture)
Thursday, 20 November 2008, 20:28 GMT
Reason for closing:  Fixed
Additional comments about closing: _input_hotplugging#FAQ.2FTroubleshooting
Comment by Shem Valentine (xvalentinex) - Friday, 07 November 2008, 01:14 GMT
The relevant Warning is as follows,
(WW) AllowEmptyInput is on, devices using drivers 'kbd' or 'mouse' will be disabled.

Installing xf86-input-evdev resolved my issue. I still get that warning, but hal/evdev autdetect my USB devices now.

Perhaps there should be a warning, or dependancy. I leave that to you smarter people.

I would be happy to test further if you would like.
Comment by Shem Valentine (xvalentinex) - Friday, 07 November 2008, 01:56 GMT
Unfortunately I lost my ability to emulate a wheel with my middle mouse button.

To resolve this I uninstalled evdev and added the following to my xorg.conf

Section "ServerFlags"
Option "AllowEmptyInput" "false"

Which apparently can be resolved with a hal .fdi in the git version of evdev.
Comment by Jan de Groot (JGC) - Friday, 07 November 2008, 08:10 GMT
OK, reopening this issue. I do have hotplugging enabled, but I don't have evdev installed on this box. The default behaviour is broken when this is the case.
Comment by Sébastien (sebcactus) - Friday, 07 November 2008, 10:24 GMT
I can confirm the problem on a laptop (Dell D410): I lost touchpad/keyboard after installing xorg-server 1.5.3
If I install evdev, the keyboard is not working properly (some dead keys, like multimedia keys or page down)
If evdev is not installed, modifying xorg.conf as proposed is working.
Comment by héctor (hacosta) - Friday, 07 November 2008, 17:39 GMT
confirmed on toshiba u205, installing xf86-input-evdev fixes the issue (keyboard works properly)
Comment by Cody Maloney (maloney) - Saturday, 08 November 2008, 02:22 GMT
Confirmed on Dell XPS 410, had to revert to an earlier xserver to fix it
Comment by Andreas Hauser (buggs) - Saturday, 08 November 2008, 10:06 GMT
Here on a Desktop mouse and keyboard are dead, with or without xf86-input-evdev.
Adding the ServerFlags section solves it.
Comment by Damir Perisa (damir.perisa) - Saturday, 08 November 2008, 13:25 GMT
Thinkpad X61t:

without xf86-input-evdev and with AllowEmptyInput=false stylus and keyboard work as before, mouse has some strange behavoiur with the buttons

with xf86-input-evdev lots of dead keys on keyboard (arrow buttons, delete button, ...) but stylus as well as mouse behave normally

Comment by Christos Nouskas (nous) - Saturday, 08 November 2008, 20:54 GMT
Thinkpad R50e: keyboard and trackpoint dead w/o xf86-input-evdev, keyboard back to normal after installing evdev, trackpoint working but lost "scroll wheel" functionality (middle button + trackpoint).

Desktop Pentium III w/ usb keyboard and mouse: both dead before evdev, work fine after.

Dell Vostro 1500: keyboard dead before, ok after - synaptics touchpad worked fine anyway.
Comment by Alberto Gonzalez (Luis) - Sunday, 09 November 2008, 05:56 GMT
Same here: After upgrade dead keyboard and mouse. With xf86-input-evdev, it works, but it ignores my /etc/X11/xorg.conf settings and loads a standard US keyboard layout (I need the Spanish layout). Removing xf86-input-evdev and using the ServerFlags AllowEmptyInput=false thigs work normally again.
Comment by Matt (ilikenwf) - Monday, 10 November 2008, 06:40 GMT
Confirmed again.
I tried all the steps...with/without evdev with/without the AllowEmptInput=false ....

I miss 1.5.2
Comment by Matt (ilikenwf) - Monday, 10 November 2008, 06:41 GMT
And it's not just touchpad on my laptop and my keyboard are both disabled.
Comment by Andreas Hauser (buggs) - Thursday, 20 November 2008, 20:28 GMT
Please elaborate more what has to be done.
My problem is that different installations here need different solutions. Some need evdev, others need it removed. So there seems to be some inconsistency.
What configuration changed exactly?
Which documentation are you exactly refering too?
This is currently eating a lot of time, finding a solution for each and every computer I maintain!
Maybe the previous configuration can be restored?
At least explain, why not, please :-)
Comment by Aaron Griffin (phrakture) - Thursday, 20 November 2008, 20:28 GMT