Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#12022 - miro-1.2.8-1 crash on start

Attached to Project: Arch Linux
Opened by psychodelica (psychodelica) - Thursday, 06 November 2008, 21:43 GMT
Last edited by Ronald van Haren (pressh) - Wednesday, 12 November 2008, 08:37 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Ronald van Haren (pressh)
Architecture All
Severity Low
Priority Normal
Reported Version None
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Miro gives me crash reports during each start. Also it doesn`t save newly added channels.

Additional info:
miro-1.2.8-1

Start log:

[andrey@archserver ~]$ miro &
[1] 7339
[andrey@archserver ~]$ /usr/lib/python2.6/site-packages/miro/util.py:39: DeprecationWarning: the sha module is deprecated; use the hashlib module instead
import sha
/usr/lib/python2.6/site-packages/miro/platform/frontends/html/MainFrame.py:41: DeprecationWarning: the sets module is deprecated
import sets
INFO Starting up Miro
INFO OS: Linux
INFO Version: 1.2.8
INFO Revision: https://svn.participatoryculture.org/svn/dtv/tags/Miro-1.2.8/tv/resources - 8366
INFO Builder: ronald@Miranda
INFO Build Time: 1225709379.01
INFO Starting event loop thread
INFO Restoring database...
INFO Connecting to /home/andrey/.miro/sqlitedb
INFO Spawning global feed dtv:manualFeed
/usr/lib/python2.6/site-packages/miro/util.py:39: DeprecationWarning: the sha module is deprecated; use the hashlib module instead
import sha
INFO Spawning global feed dtv:singleFeed
INFO Spawning global feed dtv:search
INFO Spawning global feed dtv:searchDownloads
INFO wbg: setting autodownload stuff initially to new
INFO Spawning global feed dtv:directoryfeed
INFO wbg: setting autodownload stuff initially to new
INFO Creating channel tab order
INFO Creating playlist tab order
INFO Spawning Miro Guide...
INFO Spawning auto downloader...
INFO *** Launching Downloader Daemon ****
TIMING Icon clear: 0.084
INFO Starting movie data updates
TIMING idle (finalizing startup) too slow (0.585 secs)
INFO Adding default feeds
INFO Displaying main frame...
INFO Creating video display...
WARNING Menu item action "RenameVideo" not implemented
WARNING Menu item action "FastForward" not implemented
WARNING Menu item action "Rewind" not implemented
WARNING Menu item action "UpVolume" not implemented
WARNING Menu item action "DownVolume" not implemented
TIMING gtkAsyncMethod: <function _gtkInit at 0xb6cedf0c> took too long: 1.588
INFO Finished startup sequence
TIMING idle (finishStartup() (using asUrgent)) too slow (1.596 secs)
INFO loaded renderer 'xinerenderer'
TIMING gtkAsyncMethod: <function initRenderers at 0xb6cd325c> took too long: 2.664
WARNING Error setting up drag and drop dummy element
INFO got file:///tmp/tmpDgvYwl.html
TIMING gtkSyncMethod: <function getDisplay at 0xb6cf2144> took too long: 3.914
INFO First URL is https://www.miroguide.com/firsttime
TIMING idle (select initial tab) too slow (3.932 secs)
INFO got file:///tmp/tmpYpq5Bn.html
INFO First URL is https://www.miroguide.com/
INFO Checking for updates...
/usr/lib/python2.6/site-packages/miro/eventloop.py:187: DeprecationWarning: socket.ssl() is deprecated. Use ssl.wrap_socket() instead.
result = func(*args, **kwargs)
INFO got file:///usr/share/miro/resources/html/guide-navigation.html
INFO First URL is https://www.miroguide.com/
INFO got about:blank
INFO First URL is https://www.miroguide.com/
INFO *** Daemon ready ***
INFO got https://www.miroguide.com/firsttime
INFO First URL is https://www.miroguide.com/
INFO unknown url type http://feeds.miroguide.com/~r/miroguide/toprated/~3/347709478/5418, not generating enclosure
INFO Up to date.
INFO failed() called; generating crash report.
INFO ----- CRASH REPORT (DANGER CAN HAPPEN) -----
INFO App: Miro
Publisher: Participatory Culture Foundation
Platform: gtk-x11
Python: 2.6 (r26:66714, Oct 27 2008, 10:50:31) [GCC 4.3.2]
Py Path: ['/usr/bin', '/usr/lib/python26.zip', '/usr/lib/python2.6', '/usr/lib/python2.5/site-packages', '/usr/lib/python2.6/plat-linux2', '/usr/lib/python2.6/lib-tk', '/usr/lib/python2.6/lib-old', '/usr/lib/python2.6/lib-dynload', '/usr/lib/python2.6/site-packages', '/usr/lib/python2.6/site-packages/Numeric', '/usr/lib/python2.6/site-packages/gtk-2.0']
Version: 1.2.8
Serial: 20081024000
Revision: https://svn.participatoryculture.org/svn/dtv/tags/Miro-1.2.8/tv/resources - 8366
Builder: ronald@Miranda
Build Time: 1225709379.01
Time: Fri Nov 7 00:39:03 2008
When: While handling timeout (Save database)

Exception
---------
Traceback (most recent call last):
File "/usr/lib/python2.6/site-packages/miro/trapcall.py", line 43, in trapCall
function(*args, **kwargs)
File "/usr/lib/python2.6/site-packages/miro/storedatabase.py", line 1255, in runUpdate
self.update (object)
File "/usr/lib/python2.6/site-packages/miro/storedatabase.py", line 1292, in update
data = cPickle.dumps(savable,cPickle.HIGHEST_PROTOCOL)
PicklingError: Can't pickle storedatabase.SavableObject: import of module storedatabase failed

Call stack
----------
File "/usr/lib/python2.6/site-packages/miro/trapcall.py", line 48, in trapCall
signals.system.failedExn(when)

Threads
-------
Current: Event Loop
Active:
- MainThread
- ThreadPool - 1 [Daemon]
- ThreadPool - 2 [Daemon]
- ThreadPool - 0 [Daemon]
- Movie Data Thread [Daemon]
- Event Loop

INFO ----- END OF CRASH REPORT -----
TIMING idle (Thread Pool Callback (Feedparser callback - http://feeds.miroguide.com/miroguide/new)) too slow (0.795 secs)
LoadPlugin: failed to initialize shared library /opt/java/jre/plugin/i386/ns7/libjavaplugin_oji.so [/opt/java/jre/plugin/i386/ns7/libjavaplugin_oji.so: undefined symbol: _ZTVN10__cxxabiv121__vmi_class_type_infoE]
TIMING WARNING: Calling <function <lambda> at 0x930c41c> on HTTPClient: http://feeds.pbs.org/pbs/moyers/journal-video too slow (1.969 secs)
INFO unknown url type https://www.miroguide.com/channels/5522, not generating enclosure
INFO unknown url type https://www.miroguide.com/channels/3515, not generating enclosure
INFO unknown url type https://www.miroguide.com/channels/3874, not generating enclosure
TIMING idle (Thread Pool Callback (Feedparser callback - http://feeds.miroguide.com/miroguide/popular)) too slow (0.700 secs)
TIMING feed update for: http://www.fileden.com/files/2008/5/14/1911312/timostrailers.rss too slow (1.325 secs)
TIMING idle (Thread Pool Callback (Feedparser callback - http://www.fileden.com/files/2008/5/14/1911312/timostrailers.rss)) too slow (1.326 secs)
TIMING feed update for: http://www.washingtonpost.com/wp-srv/mmedia/hd_podcast.xml too slow (2.182 secs)
TIMING idle (Thread Pool Callback (Feedparser callback - http://www.washingtonpost.com/wp-srv/mmedia/hd_podcast.xml)) too slow (2.218 secs)
TIMING feed update for: http://feeds.pbs.org/pbs/moyers/journal-video too slow (1.423 secs)
TIMING idle (Thread Pool Callback (Feedparser callback - http://feeds.pbs.org/pbs/moyers/journal-video)) too slow (1.424 secs)



Steps to reproduce:

start miro
This task depends upon

Closed by  Ronald van Haren (pressh)
Wednesday, 12 November 2008, 08:37 GMT
Reason for closing:  Fixed
Additional comments about closing:  fixed in 1.2.8-2. Thanks for the fix.
Comment by Ronald van Haren (pressh) - Thursday, 06 November 2008, 22:17 GMT
This upstream bug report seems to be related: http://bugzilla.pculture.org/show_bug.cgi?id=10719

anyone willing to add his 2cts at that report.
Comment by Jeremy Sands (georgia_tech_swagger) - Sunday, 09 November 2008, 22:10 GMT
http://bbs.archlinux.org/viewtopic.php?pid=446898#p446898

There are two solutions:

1) Roll back to, or at least provide packages of, Python 2.5
2) Simply accept that Miro, and probably many other, Python apps are broken and will remain so until upstream fixes. (Many months).

#2 would probably cause a small riot from me ;)
Comment by Jeremy Sands (georgia_tech_swagger) - Wednesday, 12 November 2008, 06:41 GMT

Loading...