Release Engineering

Tasklist

FS#11953 - LiveCD doesn't boot (itself) on arch with an encrypted root.

Attached to Project: Release Engineering
Opened by Winston Smith (1984) - Friday, 31 October 2008, 16:11 GMT
Last edited by Gerhard Brauer (GerBra) - Saturday, 01 August 2009, 15:46 GMT
Task Type Bug Report
Category ArchISO
Status Closed
Assigned To Tobias Powalowski (tpowa)
Simo Leone (neotuli)
Aaron Griffin (phrakture)
Gerhard Brauer (GerBra)
Dieter Plaetinck (Dieter_be)
Architecture All
Severity Medium
Priority Normal
Reported Version None
Due in Version 2009.08-RC
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Steps to reproduce:
1. Install Arch with an encrypted root partition like described here: http://wiki.archlinux.org/index.php/System_Encryption_with_LUKS_for_dm-crypt
2. Shut down your machine
3. Try to boot from the LiveCD (and boot the LiveCD from there, not the installed system) <= it gets a kernel panic and is useless here
This task depends upon

Closed by  Gerhard Brauer (GerBra)
Saturday, 01 August 2009, 15:46 GMT
Reason for closing:  Works for me
Comment by Jonathan Frazier (wide-eye) - Sunday, 09 November 2008, 01:37 GMT
More info would be helpful. Like which livecd did you use? What was the error (or other messages) before the kernel panicked?
Comment by Winston Smith (1984) - Sunday, 09 November 2008, 07:39 GMT
I used the lastest snapshot... archlinux-2008.06-core-x86_64.iso. I can't look up the errors now because i need to do something with my booted system, but maybe in a week or so i can do that. It was something about the harddrives obviously, but I'll write down the exact error next week.
Comment by Winston Smith (1984) - Friday, 14 November 2008, 19:05 GMT
Here we go (wrote stuff down by hand :V)

::: Adding new union branch: /bootmnt/addons/default-config.sqf
loop: module loaded
ERROR: Cannot mount loop device /dev/loop0
Couldn't mount all addons
Waiting for devices to settle...done.

Root device `` doesn't exist, attempting to create it
ERROR: Failed to parse block device name for ``
ERROR: Unable to create/detect your root device ``
Dropping to a recovery shell...type 'exit' to reboot
[...]

thats it :) Would be nice if someone could fix it.
Comment by Aaron Griffin (phrakture) - Friday, 05 December 2008, 05:16 GMT
Hmm odd, the actual error appears to be loop0 failing...
Comment by Dieter Plaetinck (Dieter_be) - Monday, 26 January 2009, 19:33 GMT
isn't this normal? the livecd does not load the dm_crypt modules, so it can't parse your block device.
Comment by Dieter Plaetinck (Dieter_be) - Friday, 24 July 2009, 16:18 GMT
now that we use aif dm_crypt/lvm setups will become supported installation methods.
so we probably should make it load the necessary modules in initramfs but what would the order be? eg we can't know if the user has lvm on top of dm_crypt or the other way around for example. (but then again i'm not 100% familiar with the early userspace stuff)
I don't think our iso's should actually do the "making available of dm_crypt /lvm volumes" during boot up, but they should be capable of booting up normally, after which the user can unlock his encrypted volumes and bring up his lvm volumes.
I will assign this to 2009.08-rc because we have to think about this.
Comment by Aaron Griffin (phrakture) - Friday, 24 July 2009, 17:25 GMT
Actually, @dieter: I think this original error was caused by the "loop over all block devices" part of the bootup. With the label-based mounting, this shouldn't be an issue anymore
Comment by Gerhard Brauer (GerBra) - Saturday, 01 August 2009, 15:46 GMT
Tested on my LUKS-encrypted laptop. 2009.08-beta1 boot without problems, from within the LiceCD i could open my encrypted partitions. So i close this (Report from 2008!) cause IMHO it is already fixed.
If Winston have currently any problems he could make a reopen request...

Loading...