Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#11948 - cifs file update kernel ug

Attached to Project: Arch Linux
Opened by Damien Guihal (dguihal) - Friday, 31 October 2008, 08:28 GMT
Last edited by Tobias Powalowski (tpowa) - Sunday, 09 November 2008, 08:26 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version None
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

I use a cifs share for my day to day work, but since kernel 2.6.27 from archlinux I can't update files anymore on this filesystem. Kernel 2.6.27-4 does not correct the problem, rebooting on old 2.6.26 archlinux solved the problem.

Note : I can create/delete/rename/... files, but I can't modify then with software like OpenOffice/kate/kedit/... However vim seems to be able to modify files, but I suspect it to create a new file with the new data and simply rename the old file.

Additional infos :
fstab :
//SRV/share /media/SRV/share cifs rw,umask=0000,uid=1000,iocharset=utf8,lfs,credentials=/etc/samba/smbcredentials,file_mode=0666,dir_mode=0777,nobrl 1 2

Serveur:
Fedora Core 6
samba ver 3.0.23c-2



This task depends upon

Closed by  Tobias Powalowski (tpowa)
Sunday, 09 November 2008, 08:26 GMT
Reason for closing:  Fixed
Comment by Glenn Matthys (RedShift) - Friday, 31 October 2008, 12:25 GMT
Can you please show us the specific error messages with the scenario you described above?
Comment by Damien Guihal (dguihal) - Friday, 31 October 2008, 13:01 GMT
As I will not be able to post you the precise error messages before Monday (it's on my office desktop, and I can't reboot today), I'll give you hints today and make another real post on Monday

So, for OpenOffice, I get a General I/O Error, and for kwrite I get a permission denied error.
I didn't see any error message in /var/log/*

I'll try to get a strace of wkrite updating a file (I don't think that an strace of OpenOffice is a good idea), if you want specific filters/options don't hesitate
Comment by Pierre Schmitz (Pierre) - Friday, 31 October 2008, 15:20 GMT
Did you try the noperm mount option?
Comment by Damien Guihal (dguihal) - Monday, 03 November 2008, 08:05 GMT
OK, I got the error messages :

For OpenOffice :
General Error.
General input/output error.

And yes I tried with the noperm mount option with with no luck
Comment by Christophe Meyer (stombi) - Sunday, 09 November 2008, 01:00 GMT
Hi, I have exactly the same problem except that the server is Debian Samba Version 3.0.24 , but this bug is kernel related and apparently has been fixed.

I dont know much about those things but my searches pointed me to this post which explains the problem I think :

https://bugs.launchpad.net/ubuntu/+source/samba/+bug/286828/comments/26

Loading...