Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#11939 - [pptp-1.7.2-1] try to use /bin/ip instead of /usr/sbin/ip

Attached to Project: Arch Linux
Opened by solsTiCe (zebul666) - Thursday, 30 October 2008, 13:27 GMT
Last edited by Isenmann Daniel (ise) - Tuesday, 10 February 2009, 17:02 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Isenmann Daniel (ise)
Architecture All
Severity Low
Priority Normal
Reported Version None
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Summary and Info:
i am trying to use pptp and i see in my console
sh:/bin/ip: file does not exist.

sure because in arch we have /usr/sbin/ip

i don't know if it's critical to pptp but it sure would help if it find ip command.
that should be fixed upstream but they don't even use a configure script and the path of ip is hard coded in routing.c file (what a shame !).

so in the mean time
we could use a sed line like this in the PKGBUILD ?
sed -i 's|/bin/ip|/usr/sbin/ip|g' routing.c
before running make
or create a patch if you want

Steps to Reproduce:
run pptp
or run strings /usr/sbin/pptp|grep /bin/ip
This task depends upon

Closed by  Isenmann Daniel (ise)
Tuesday, 10 February 2009, 17:02 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in latest package version in testing repo.
Comment by Alex Merry (pippin) - Tuesday, 10 February 2009, 00:18 GMT
See http://www.nabble.com/sh:--bin-ip:-No-such-file-or-directory-td17306819.html for what one of the authors of pptp says (which basically amounts to: distros that don't have ip in /bin should patch routing.c).
Comment by Isenmann Daniel (ise) - Tuesday, 10 February 2009, 16:26 GMT
I totally forget that bug. Sorry! Will fix it...

Loading...