Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#11917 - [PATCH] Update libcap from 1.10 to 2.16

Attached to Project: Arch Linux
Opened by Jacob Myers (jacob) - Wednesday, 29 October 2008, 00:12 GMT
Last edited by Hugo Doria (hdoria) - Saturday, 11 April 2009, 15:51 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Tobias Powalowski (tpowa)
Hugo Doria (hdoria)
Architecture All
Severity Medium
Priority Normal
Reported Version None
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:
libcap has not been updated in a long time (it is a major version behind); the package has been marked outdated but no updates have been forthcoming from the maintainer in a long time. I have updated the PKGBUILD file for it.


Additional info:
* Update from 1.10 to 2.16


Steps to reproduce:
pacman -Ss libcap
This task depends upon

Closed by  Hugo Doria (hdoria)
Saturday, 11 April 2009, 15:51 GMT
Reason for closing:  Fixed
Comment by Jacob Myers (jacob) - Wednesday, 29 October 2008, 01:32 GMT
One point I forgot to mention, wireshark and other packages depending on libcap will have to be rebuilt because of this update. Sorry...
Comment by Allan McRae (Allan) - Wednesday, 29 October 2008, 02:35 GMT
Were you intending to attach the updated PKGBUILD?
Comment by Jacob Myers (jacob) - Wednesday, 29 October 2008, 08:50 GMT
I thought I did...
   PKGBUILD (0.4 KiB)
Comment by Jacob Myers (jacob) - Wednesday, 29 October 2008, 17:28 GMT
On another note (should be self-explanatory by the PKGBUILD file), the patches for libcap 1.10 in ABS are no longer necessary.
They can (and probably should) be removed.
Comment by Glenn Matthys (RedShift) - Friday, 05 December 2008, 14:28 GMT
What's the status of this issue?
Comment by Hugo Doria (hdoria) - Friday, 05 December 2008, 15:11 GMT
I just adopted the package and i will plan a rebuild and update.
Comment by Jacob Myers (jacob) - Tuesday, 13 January 2009, 00:34 GMT
Hm, a month later:

$ pacman -Ss libcap
extra/libcap 1.10-2
POSIX 1003.1e capabilities

:p.
Comment by Hugo Doria (hdoria) - Tuesday, 13 January 2009, 00:46 GMT
This upgrade will not be as easy as you think. There are some packages that requires libcap and i need to make sure that all them works with the newer version.

Also, i took a look at others distributions and they seem to stay with libcap1. I am checking the reasons.
Comment by Gerardo Exequiel Pozzi (djgera) - Wednesday, 11 March 2009, 03:54 GMT
Not all soft that use capabilities are linked with libcap (for example syslog-ng-3) simple include sys/capabilities.h
You can check what soft are using them, with "readelf -s | grep capget" for example

Updating this and recompiling soft fixes the kernel warning message:
warning: `program-name' uses 32-bit capabilities (legacy support in use)

This is maybe is important, because the old legacy capabilities are unmantained.
Also this package maybe needed to be moved from extra to core.

What are the status on this upgrade?
Comment by Allan McRae (Allan) - Wednesday, 11 March 2009, 04:38 GMT
Complete libpcap rebuilt list for [core] and [extra]:

etherape
ettercap
ettercap-gtk
hping
kismet
libnids
ngrep
nmap
ntop
ppp
snort
tcpdump
tcptraceroute
wireshark
Comment by Gerardo Exequiel Pozzi (djgera) - Wednesday, 11 March 2009, 05:10 GMT
Allan, is libcap not libpcap ;)

I currently finding what pkgs uses the symbol "capget" in extra/community

[core]
syslog-ng-3.0.1

[extra]
Comment by Gerardo Exequiel Pozzi (djgera) - Wednesday, 11 March 2009, 05:35 GMT
These are list of packages that have the symbol "capget" in ELFs but they don't have a dynamic link to libcap

[core]
glibc-2.9-4 (this seem to only needed for selinux setups) [ nscd/selinux.h ]
syslog-ng-3.0.1

[extra]
dnsmasq-2.45-1
proftpd-1.3.1-2
squid-2.7.STABLE6-1

Maybe a good idea it to put a makedepends=(libcap...) for these packages.

[community]
will come soon...
Comment by Allan McRae (Allan) - Wednesday, 11 March 2009, 05:48 GMT
> Allan, is libcap not libpcap ;)

Oops...
Comment by Gerardo Exequiel Pozzi (djgera) - Wednesday, 11 March 2009, 06:26 GMT
There are no community packages that have the symbol "capget", uses other functions (but this are dyn linked with libcap and uses cap_* functions)

These are packages that are linked with libcap

[extra]
avahi-0.6.24-1
cdrkit-1.1.9-1
dovecot-1.1.11-1
muse-0.9-1 (NOTE: list libcap as depend but don't use it)
pinentry-0.7.5-3
pure-ftpd-1.0.21-2
samba-3.3.1-1
smbclient-3.3.1-1
vsftpd-2.1.0-1
wireshark-1.0.6-1

[community]
osec-1.2.2cvs20081201-1
pulseaudio-0.9.14-1
Comment by Aaron Griffin (phrakture) - Wednesday, 11 March 2009, 19:26 GMT
Would someone mind updating this so that we can fix the syslog-ng issue? Hugo, you're the owner of libcap.
Comment by Hugo Doria (hdoria) - Wednesday, 11 March 2009, 19:36 GMT
Sure! But i did not tested every app against the new libcap version. I will build the newer version and upload to [testing].
Comment by Gerardo Exequiel Pozzi (djgera) - Wednesday, 11 March 2009, 19:44 GMT
Hugo, my previus distro was Slackware (8 years on it), it uses only libcap-2.nn
I personally used samba, vsftpd, pure-ftpd, proftpd, squid and wireshark on it, there are no problems on it.
Comment by Hugo Doria (hdoria) - Wednesday, 11 March 2009, 19:46 GMT
Great! Then everthing will run fine. Anyway, i will upload everything to [testing].
Comment by Gerardo Exequiel Pozzi (djgera) - Wednesday, 11 March 2009, 21:28 GMT
Hugo, in your mail missed deps

Here is the complete list:


-------------------------------------
Packages that have makedepends on libcap (maybe these need to add libcap as makedepends) [uses sys/capability.h when exists]
[core]
syslog-ng-3.0.1

[extra]
dnsmasq-2.45-1
proftpd-1.3.1-2
squid-2.7.STABLE6-1
-------------------------------------
Packages that have depends on libcap
[extra]
avahi-0.6.24-1
cdrkit-1.1.9-1
dovecot-1.1.11-1
muse-0.9-1 (NOTE: list libcap as depend but don't use it)  FS#13756 
pinentry-0.7.5-3
pure-ftpd-1.0.21-2
samba-3.3.1-1
smbclient-3.3.1-1
vsftpd-2.1.0-1
wireshark-1.0.6-1

[community]
osec-1.2.2cvs20081201-1
pulseaudio-0.9.14-1
--------------------------------------
Comment by Hugo Doria (hdoria) - Wednesday, 11 March 2009, 21:32 GMT
Perfect. Thanks. I will use this as a guide.
Comment by Francesco Groccia (fgr) - Friday, 13 March 2009, 17:59 GMT
Description:
libcap doesn't work after upgrading to the last version.

Additional info:
* kernel: 2.6.28.7-2
* x86-64 architecture
* testing repository enabled

Steps to reproduce:
Try to run, e.g., 'pinentry-gtk-2'.

I solved with a symbolic link:
ln -s /lib/libcap.so.2 /lib/libcap.so.1
Comment by Hugo Doria (hdoria) - Friday, 13 March 2009, 18:10 GMT
pinentry is working fine on a i686 machine.

Which pinentry and libcap version are you using? And, please, open a new BR.
Comment by Francesco Groccia (fgr) - Friday, 13 March 2009, 18:10 GMT
I'm sorry. I forgot to report:
pinentry-gtk-2: error while loading shared libraries: libcap.so.1: cannot open shared object file: No such file or directory
Comment by Francesco Groccia (fgr) - Friday, 13 March 2009, 18:12 GMT
pinentry 0.7.5-3
testing/libcap 2.16-2

on Arch64
Comment by Hugo Doria (hdoria) - Friday, 13 March 2009, 18:22 GMT
Try pinentry 0.7.5-4. It's the version that was rebuilt to use libcap. I do not know if this version is already available in the testing repo.
Comment by Gerardo Exequiel Pozzi (djgera) - Friday, 13 March 2009, 18:46 GMT
Hugo, i see that you fixed the invalid muse depends on libcap. Can also fix the jade depends? it's a makedepend
muse-0.9-1 (NOTE: list libcap as depend but don't use it)  FS#13756  so can close this FS entry.

Thanks for your work.
Comment by Francesco Groccia (fgr) - Friday, 13 March 2009, 20:44 GMT
@Hugo: I'll open a new bug report. (The pinentry 0.7.5-4 isn't available yet in the testing repository).
Comment by Gerardo Exequiel Pozzi (djgera) - Saturday, 14 March 2009, 01:22 GMT
bad perms on libcap.so.2.16 (644) should be 755 ;)
Comment by Hugo Doria (hdoria) - Sunday, 15 March 2009, 02:55 GMT
djgera,

I fixed the muse package and the permissions problem of libcap. Thanks again.
Comment by Gerardo Exequiel Pozzi (djgera) - Sunday, 15 March 2009, 05:48 GMT
Excelente Hugo :)

Now the only two packages in queue, that needs a rebuild are in community: pulseaudio and osec ;)

Thanks.

Loading...