Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#11907 - gedit binary is not stripped

Attached to Project: Arch Linux
Opened by Phillip Smith (fukawi2) - Tuesday, 28 October 2008, 07:47 GMT
Last edited by Jan de Groot (JGC) - Monday, 03 November 2008, 09:25 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture i686
Severity Very Low
Priority Normal
Reported Version None
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: gedit binary is not stripped.


Package Version:
root ~ # pacman -Q gedit
gedit 2.24.0-1


Steps to reproduce:
root ~ # pacman -S --noconfirm gedit
warning: gedit-2.24.0-1 is up to date -- reinstalling
resolving dependencies...
looking for inter-conflicts...

Targets (1): gedit-2.24.0-1

Total Download Size: 0.00 MB
Total Installed Size: 20.93 MB

Proceed with installation? [Y/n]
checking package integrity...
(1/1) checking for file conflicts [#####################] 100%
(1/1) upgrading gedit [#####################] 100%
root ~ # ls -lh /usr/bin/gedit
-rwxr-xr-x 1 root root 4.1M 2008-09-28 03:54 /usr/bin/gedit
root ~ # strip /usr/bin/gedit
root ~ # ls -lh /usr/bin/gedit
-rwxr-xr-x 1 root root 1.8M 2008-10-28 18:46 /usr/bin/gedit
root ~ #
This task depends upon

Closed by  Jan de Groot (JGC)
Monday, 03 November 2008, 09:25 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed on buildmachine. The affected packages will fix themselves while they're upgraded or rebuilt.
Comment by Phillip Smith (fukawi2) - Tuesday, 28 October 2008, 07:50 GMT
There's a lot of other files in /usr/bin that aren't stripped either...

root ~ # file /usr/bin/* | grep 'not stripped' | wc -l
182
root ~ #

Some packages in that list not directly related to Gnome are Totem, Synergy and Evolution
Comment by Phillip Smith (fukawi2) - Tuesday, 28 October 2008, 07:53 GMT
root ~ # ls -lh /usr/bin/synergy*
-rwxr-xr-x 1 root root 3.6M 2008-10-13 01:08 /usr/bin/synergyc
-rwxr-xr-x 1 root root 4.9M 2008-10-13 01:08 /usr/bin/synergys
root ~ # strip /usr/bin/synergy*
root ~ # ls -lh /usr/bin/synergy*
-rwxr-xr-x 1 root root 395K 2008-10-28 18:51 /usr/bin/synergyc
-rwxr-xr-x 1 root root 572K 2008-10-28 18:51 /usr/bin/synergys
root ~ # pacman -Q synergy
synergy 1.3.1-2
root ~ #

Perhaps a bug in makepkg if it is supposed to strip the binaries? synergy was installed from AUR so definitely went through makepkg.
Comment by Allan McRae (Allan) - Tuesday, 28 October 2008, 10:38 GMT
Are you sure it was installed from the AUR? There is a synergy package in [extra].
Comment by Sigmund Lahn (gnud) - Tuesday, 28 October 2008, 11:11 GMT
This seems to be a problem with the build enviroment.
I buildt a new package from the abs tree, and my pkg/usr/bin/gedit is stripped.
Comment by Phillip Smith (fukawi2) - Tuesday, 28 October 2008, 21:24 GMT
@Allan - if it's in extra, then maybe it was installed from there. Sorry; I thought it hadn't made it out of AUR yet. Is there a way to tell when it was moved? I'm sure I installed from AUR. It would have been installed around early June this year.
Comment by Allan McRae (Allan) - Tuesday, 28 October 2008, 23:48 GMT
You can use "pacman -Qi <pkg>" to see who built a package.
Comment by Phillip Smith (fukawi2) - Wednesday, 29 October 2008, 00:12 GMT
OK, it was installed from extra. My bad :)
$ pacman -Qi synergy
Name : synergy
Version : 1.3.1-2
URL : http://synergy2.sourceforge.net/
Licenses : GPL2
Groups : None
Provides : None
Depends On : gcc-libs libxtst libsm libxinerama
Optional Deps : None
Required By : None
Conflicts With : None
Replaces : None
Installed Size : 8668.00 K
Packager : Jan de Groot <jgc@archlinux.org>
Architecture : i686
Build Date : Mon 13 Oct 2008 01:08:46 EST
Install Date : Wed 15 Oct 2008 17:36:39 EST
Install Reason : Explicitly installed
Install Script : No
Description : share a single mouse and keyboard between multiple pcs
Comment by Phillip Smith (fukawi2) - Wednesday, 29 October 2008, 00:17 GMT
A problem with Jan de Groot's environment?

root ~ # pacman -Qi `file /usr/bin/* | grep 'not stripped' | awk '{ print $1}' | cut -d/ -f4 | cut -d: -f1` | grep -E 'Packager|Name'
Name : bug-buddy
Packager : Jan de Groot <jgc@archlinux.org>
Name : cheese
Packager : Jan de Groot <jgc@archlinux.org>
Name : dasher
Packager : Jan de Groot <jgc@archlinux.org>
Name : esd
Packager : Jan de Groot <jgc@archlinux.org>
Name : evolution
Packager : Jan de Groot <jgc@archlinux.org>
Name : file-roller
Packager : Jan de Groot <jgc@archlinux.org>
Name : gcalctool
Packager : Jan de Groot <jgc@archlinux.org>
Name : gconf-editor
Packager : Jan de Groot <jgc@archlinux.org>
Name : gnome-control-center
Packager : Jan de Groot <jgc@archlinux.org>
Name : gnome-keyring
Packager : Jan de Groot <jgc@archlinux.org>
Name : gnome-panel
Packager : Jan de Groot <jgc@archlinux.org>
Name : gnome-power-manager
Packager : Jan de Groot <jgc@archlinux.org>
Name : gnome-screensaver
Packager : Jan de Groot <jgc@archlinux.org>
Name : gnome-settings-daemon
Packager : Jan de Groot <jgc@archlinux.org>
Name : gnome-system-monitor
Packager : Jan de Groot <jgc@archlinux.org>
Name : gnome-terminal
Packager : Jan de Groot <jgc@archlinux.org>
Name : gok
Packager : Jan de Groot <jgc@archlinux.org>
Name : gucharmap
Packager : Jan de Groot <jgc@archlinux.org>
Name : metacity
Packager : Jan de Groot <jgc@archlinux.org>
Name : nautilus
Packager : Jan de Groot <jgc@archlinux.org>
Name : nautilus-cd-burner
Packager : Jan de Groot <jgc@archlinux.org>
Name : seahorse
Packager : Jan de Groot <jgc@archlinux.org>
Name : smbclient
Packager : Tobias Powalowski <tpowa@archlinux.org>
Name : sound-juicer
Packager : Jan de Groot <jgc@archlinux.org>
Name : totem
Packager : Jan de Groot <jgc@archlinux.org>
Name : vte
Packager : Jan de Groot <jgc@archlinux.org>
Name : yelp
Packager : Jan de Groot <jgc@archlinux.org>
Name : zenity
Packager : Jan de Groot <jgc@archlinux.org>
Comment by Jan de Groot (JGC) - Wednesday, 29 October 2008, 11:58 GMT
Checked my buildmachine, it had !strip set in makepkg.conf.
Comment by Phillip Smith (fukawi2) - Wednesday, 29 October 2008, 21:16 GMT
I'm guessing this could be closed now then? :)

Loading...