Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#11823 - [e2fsprogs-1.41.2-1] complains about ext3 and ext4 not in mke2fs.conf

Attached to Project: Arch Linux
Opened by solsTiCe (zebul666) - Tuesday, 21 October 2008, 10:41 GMT
Last edited by Ronald van Haren (pressh) - Thursday, 10 September 2009, 21:14 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Ronald van Haren (pressh)
Architecture All
Severity Low
Priority Normal
Reported Version None
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
when i try to run mkfs.ext4 or mkfs.ext3 it complains about the fs not being in mke2fs.conf.

$ mkfs.ext3 /dev/sda8
mke2fs 1.41.2 (02-Oct-2008)

Warning! Your mke2fs.conf file does not define the ext3 filesystem type.
You probably need to install an updated mke2fs.conf file.

Filesystem label=
[...]

what is the reason for not using the default mke2fs.conf in e2fsprogs and use a custom one ? the default one is in misc/mke2fs.conf and installed by default.

at least, undesired features could be commented out (; or #) and explained why they are removed

if it is needed to set inode_size at 128 in the [default], it does not hurt to let the ext3 and ext4 and ext4dev paragraph, and a simple sed could do it

sed -i '/^\tinode_size/s/256/128/' $startdir/pkg/etc/mke2fs.conf

or create a patch


This task depends upon

Closed by  Ronald van Haren (pressh)
Thursday, 10 September 2009, 21:14 GMT
Reason for closing:  Not a bug
Comment by filippo colombo (ombra85) - Tuesday, 18 August 2009, 22:47 GMT
  • Field changed: Percent Complete (100% → 0%)
I have this bug with e2fsprogs 1.41.8
Comment by Ronald van Haren (pressh) - Wednesday, 19 August 2009, 05:40 GMT
check your .pacnew files, we don't install a custom mke2fs.conf since 1.41.4-1 was pushed into the repos 10 months ago

Loading...