Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#11810 - networkmanager crashing if it can't connect to wifi access point

Attached to Project: Arch Linux
Opened by Piotr (riklaunim) - Monday, 20 October 2008, 10:39 GMT
Last edited by Jan de Groot (JGC) - Saturday, 07 February 2009, 20:16 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Architecture All
Severity Low
Priority Normal
Reported Version None
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

I'm using networkmanager 0.6.6-1 and other up to date packages with KDEmod3 with Knetworkmanager. Networkmanager daemons will crash on most times when it can't connect to a wifi (in this case - a weak local wifi network). The traceback is save in logs (see attachment).

This task depends upon

Closed by  Jan de Groot (JGC)
Saturday, 07 February 2009, 20:16 GMT
Reason for closing:  Fixed
Additional comments about closing:  0.7 went to extra.
Comment by Roman Kyrylych (Romashka) - Tuesday, 21 October 2008, 12:24 GMT
knetworkmanager is in AUR/unsupported and kdemod3 is unofficial too,
so _if_ the problem is due to those packages...
did you try using another networkmanager frontend?
Comment by Jan de Groot (JGC) - Tuesday, 21 October 2008, 12:26 GMT
The trace is from networkmanager itself which shouldn't crash, no matter what the frontend thinks it's doing.
Comment by Piotr (riklaunim) - Tuesday, 21 October 2008, 12:31 GMT
using gnome-network-manager also results with deamon death.
Comment by Ronald van Haren (pressh) - Wednesday, 22 October 2008, 21:35 GMT
for what it is worth, I can reproduce it.

Though not sure if it is worth spending too much time in as, according to one of the redhat devs working on networkmanager, 0.7 should be released somewhere near the end of this month (http://mail.gnome.org/archives/networkmanager-list/2008-October/msg00152.html)
Comment by Ronald van Haren (pressh) - Wednesday, 05 November 2008, 23:51 GMT
Just a heads up on the release schedule of nm 0.7:
nm0.7 rc1 has been released last weekend. rc2 is scheduled for next weekend and the final version for November 15 ( http://mail.gnome.org/archives/networkmanager-list/2008-November/msg00067.html ).
Comment by Jan de Groot (JGC) - Friday, 14 November 2008, 22:35 GMT
0.7.0rc2 is in testing for i686 now. Please test.
Comment by Piotr (riklaunim) - Sunday, 16 November 2008, 15:38 GMT
x86_64 please ;)
Comment by João Vieira (Vieira) - Saturday, 07 February 2009, 19:08 GMT
When is 0.7 comming to extra? It's released for a long time now...

Loading...