AUR web interface

**This is the bug tracker for the AUR web interface.**

Use this tracker to report bugs or make feature requests regarding the behaviour or implementation of the AUR software.
Please read the Reporting Bug Guidelines before filing a new task.
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

- Please report bugs related to Arch Linux official packages here: http://bugs.archlinux.org/index.php?project=1
- Please report bugs for [community] packages here: http://bugs.archlinux.org/index.php?project=5
- For any packages in the AUR contact the maintainer or leave a comment on the package's detail page.

Source Code:
https://projects.archlinux.org/aurweb.git/
Tasklist

FS#11793 - vmware-server-modules doesn't compile under 2.6.27-ARCH

Attached to Project: AUR web interface
Opened by robin wood (dninja) - Saturday, 18 October 2008, 18:02 GMT
Last edited by Roman Kyrylych (Romashka) - Tuesday, 21 October 2008, 14:12 GMT
Task Type Bug Report
Category Backend
Status Closed
Assigned To No-one
Architecture All
Severity Critical
Priority Normal
Reported Version 1.5.1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

When I try to compile vmware-server-modules 1.0.7_108231-1 i686 under kernel 2.6.27-ARCH I get this error:

make[1]: Entering directory `/usr/src/linux-2.6.27-ARCH'
CC [M] /var/abs/local/vmware-server-modules/src/vmware-server-distrib/lib/modules/source/vmmon-only/linux/driver.o
In file included from /var/abs/local/vmware-server-modules/src/vmware-server-distrib/lib/modules/source/vmmon-only/./include/machine.h:24,
from /var/abs/local/vmware-server-modules/src/vmware-server-distrib/lib/modules/source/vmmon-only/linux/driver.h:15,
from /var/abs/local/vmware-server-modules/src/vmware-server-distrib/lib/modules/source/vmmon-only/linux/driver.c:49:
/var/abs/local/vmware-server-modules/src/vmware-server-distrib/lib/modules/source/vmmon-only/./include/x86.h:830:1: warning: "PTE_PFN_MASK" redefined
In file included from include/asm/paravirt.h:7,
from include/asm/irqflags.h:55,
from include/linux/irqflags.h:57,
from include/asm/system.h:11,
from include/asm/processor.h:17,
from include/linux/prefetch.h:14,
from include/linux/list.h:6,
from include/linux/module.h:9,
from /var/abs/local/vmware-server-modules/src/vmware-server-distrib/lib/modules/source/vmmon-only/linux/driver.c:12:
include/asm/page.h:22:1: warning: this is the location of the previous definition
In file included from /var/abs/local/vmware-server-modules/src/vmware-server-distrib/lib/modules/source/vmmon-only/linux/vmhost.h:13,
from /var/abs/local/vmware-server-modules/src/vmware-server-distrib/lib/modules/source/vmmon-only/linux/driver.c:71:
/var/abs/local/vmware-server-modules/src/vmware-server-distrib/lib/modules/source/vmmon-only/./include/compat_semaphore.h:5:27: error: asm/semaphore.h: No such file or directory
/var/abs/local/vmware-server-modules/src/vmware-server-distrib/lib/modules/source/vmmon-only/linux/driver.c: In function 'LinuxDriver_Ioctl':
/var/abs/local/vmware-server-modules/src/vmware-server-distrib/lib/modules/source/vmmon-only/linux/driver.c:1626: error: too many arguments to function 'smp_call_function'
make[2]: *** [/var/abs/local/vmware-server-modules/src/vmware-server-distrib/lib/modules/source/vmmon-only/linux/driver.o] Error 1
make[1]: *** [_module_/var/abs/local/vmware-server-modules/src/vmware-server-distrib/lib/modules/source/vmmon-only] Error 2
make[1]: Leaving directory `/usr/src/linux-2.6.27-ARCH'
make: *** [vmmon.ko] Error 2
make: Leaving directory `/var/abs/local/vmware-server-modules/src/vmware-server-distrib/lib/modules/source/vmmon-only'
This task depends upon

Closed by  Roman Kyrylych (Romashka)
Tuesday, 21 October 2008, 14:12 GMT
Reason for closing:  Not a bug
Additional comments about closing:  please report only bugs in AUR webinterface here.
report bugs in packages as comments on their pages

Loading...