Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#11767 - pacman error: could not open file /var/lib/pacman/local/

Attached to Project: Pacman
Opened by ponto (ponto) - Thursday, 16 October 2008, 15:55 GMT
Last edited by Dan McGee (toofishes) - Saturday, 01 November 2008, 01:01 GMT
Task Type Bug Report
Category General
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version 3.2.1
Due in Version 3.2.2
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Summary and Info:

i've made: pacman-optimize
and then: pacman -Syu

and it started to output me this error:

:: Synchronizing package databases...
core is up to date
extra is up to date
community is up to date
:: Starting full system upgrade...
resolving dependencies...
error: could not open file /var/lib/pacman/local/abiword-plugins-2.6.4-1/depends: No such file or directory
error: could not open file /var/lib/pacman/local/acpid-1.0.6-1/depends: No such file or directory
error: could not open file /var/lib/pacman/local/akonadi-1.0.0-2/depends: No such file or directory
error: could not open file /var/lib/pacman/local/alsa-oss-1.0.17-1/depends: No such file or directory
error: could not open file /var/lib/pacman/local/anjuta-2.4.2-2/depends: No such file or directory
error: could not open file /var/lib/pacman/local/antlr-2.7.7-1/depends: No such file or directory
error: could not open file /var/lib/pacman/local/apr-1.3.2-2/depends: No such file or directory
error: could not open file /var/lib/pacman/local/argouml-0.26-1/depends: No such file or directory
error: could not open file /var/lib/pacman/local/at-spi-1.22.1-1/depends: No such file or directory
error: could not open file /var/lib/pacman/local/attr-2.4.41-1/depends: No such file or directory
error: could not open file /var/lib/pacman/local/awesome-2.3.4-1/depends: No such file or directory
error: could not open file /var/lib/pacman/local/b43-fwcutter-011-1/depends: No such file or directory
error: could not open file /var/lib/pacman/local/bigreqsproto-1.0.2-1/depends: No such file or directory
error: could not open file /var/lib/pacman/local/bin2iso-1.9b-1/depends: No such file or directory
error: could not open file /var/lib/pacman/local/bison-2.3-4/depends: No such file or directory
error: could not open file /var/lib/pacman/local/boo-0.8.2.2960-1/depends: No such file or directory
error: could not open file /var/lib/pacman/local/brasero-0.8.2-1/depends: No such file or directory
error: could not open file /var/lib/pacman/local/bug-buddy-2.22.0-1/depends: No such file or directory
error: could not open file /var/lib/pacman/local/bzip2-1.0.5-3/depends: No such file or directory
error: could not open file /var/lib/pacman/local/cairo-dock-themes-svn-1349-1/depends: No such file or directory
error: could not open file /var/lib/pacman/local/cdparanoia-10.2-2/depends: No such file or directory
error: could not open file /var/lib/pacman/local/checkgmail-1.13-3/depends: No such file or directory
error: could not open file /var/lib/pacman/local/clisp-2.45-3/depends: No such file or directory
error: could not open file /var/lib/pacman/local/clucene-0.9.20-1/depends: No such file or directory
error: could not open file /var/lib/pacman/local/cmatrix-1.2a-3/depends: No such file or directory
error: could not open file /var/lib/pacman/local/codecs-20071007-1/depends: No such file or directory
error: could not open file /var/lib/pacman/local/compiz-decorator-gtk-0.7.8-1/depends: No such file or directory
error: could not open file /var/lib/pacman/local/compositeproto-0.4-1/depends: No such file or directory
error: could not open file /var/lib/pacman/local/confuse-2.6-1/depends: No such file or directory
error: could not open file /var/lib/pacman/local/cpudyn-1.0.1-2/depends: No such file or directory
error: could not open file /var/lib/pacman/local/cpufreqd-2.3.3-2/depends: No such file or directory
error: could not open file /var/lib/pacman/local/cracklib-2.8.13-1/depends: No such file or directory
error: could not open file /var/lib/pacman/local/crypto++-5.5.2-1/depends: No such file or directory
error: could not open file /var/lib/pacman/local/csup-20060318-5/depends: No such file or directory
error: could not open file /var/lib/pacman/local/curl-7.19.0-1/depends: No such file or directory
error: could not open file /var/lib/pacman/local/darkstat-3.0.708-1/depends: No such file or directory
error: could not open file /var/lib/pacman/local/db4.1-4.1.25-2/depends: No such file or directory
error: could not open file /var/lib/pacman/local/db4.5-4.5.20-1/depends: No such file or directory
error: could not open file /var/lib/pacman/local/dbus-qt3-0.62-3/depends: No such file or directory
error: could not open file /var/lib/pacman/local/devede-3.11b-2/depends: No such file or directory
error: could not open file /var/lib/pacman/local/devhelp-0.19.1-2/depends: No such file or directory
error: could not open file /var/lib/pacman/local/dia-0.96.1-1/depends: No such file or directory
error: could not open file /var/lib/pacman/local/dosbox-0.72-4/depends: No such file or directory

(and the list goes on)

and i try to cd one of the paths errors, and:

~ # cd /var/lib/pacman/local/acpid-1.0.6-1/depend
bash: cd: /var/lib/pacman/local/acpid-1.0.6-1/depend: No such file or directory

i've already tried: pacman -Scc and then pacman -Syy. but the error pressists.

does anyone knows how to solve this error?

Steps to Reproduce:
pacman-optimize
and then: pacman -Syu
This task depends upon

Closed by  Dan McGee (toofishes)
Saturday, 01 November 2008, 01:01 GMT
Reason for closing:  Fixed
Additional comments about closing:  http://projects.archlinux.org/?p=pacman. git;a=commitdiff;h=a63aeed562c8bdd6604ec 50e6a4b684f6edabda3
Comment by Dan McGee (toofishes) - Thursday, 16 October 2008, 16:04 GMT
Did pacman-optimize give any output indicating failure?

You won't be able to cd to that file- it is a file and not a directory. Can you do "ls -l /var/lib/pacman/local/acpid-1.0.6-1/" for us?
Comment by Xavier (shining) - Thursday, 16 October 2008, 16:07 GMT
You should know that pacman-optimize is a sensitive operation.
So you should have put high attention to its output. Did you? If so, did everything go fine? Otherwise can you paste the output?

You might also have a look at pacman-optimize code, it is a simple script. IIRC, it is supposed to make a backup of the local database, so you should check if you have one.
Otherwise if you used locate before, it can be a nice trick to rebuild your local database.
You can also use /var/log/pacman.log .
Comment by ponto (ponto) - Thursday, 16 October 2008, 16:09 GMT
i've tried to force reinstall some packages and that solves the error messages.

but i've several packages, and do it manually is not a good option:
~ # pacman -Qqe > pkglist
~ # cat pkglist | grep error | wc --line
323

acpid is one of the packages that i've reinstalled.

trying with another one gives me:
~ $ ls -l /var/lib/pacman/local/dosbox-0.72-4/
total 0


i think that pacman-optmize didn't advice, but i am not sure.
Comment by Allan McRae (Allan) - Thursday, 16 October 2008, 16:10 GMT
It looks like pacman-optimize failed for some reason. If you haven't rebooted your computer there should be a backup of you pacman database in /tmp/pacman-optimize.XXXXXXXXXX/pacmanDB.tgz (where XXXX is some random characters). Copy it somewhere safe and extract it to /var/lib/pacman/local/

Edit: it appears the temporary directory is removed at the end of the script.
Comment by ponto (ponto) - Thursday, 16 October 2008, 16:11 GMT
pacman.log doest not have any relevant information about this.

i will try to locate the database.
Comment by Dan McGee (toofishes) - Thursday, 16 October 2008, 16:12 GMT
Did you check your disk space? Is it nearing full capacity?
Comment by ponto (ponto) - Thursday, 16 October 2008, 16:13 GMT
hum : x

i've rebooted. this error appears before lunch, and i've shutdowned the laptop : x
Comment by ponto (ponto) - Thursday, 16 October 2008, 16:14 GMT
yes, i've 3,7GiB free.
Comment by ponto (ponto) - Thursday, 16 October 2008, 16:28 GMT
so, i've to force the reinstall of packages that appears to misse on pacman's db?
Comment by ponto (ponto) - Thursday, 16 October 2008, 22:01 GMT
ok, i've solved this issue.

it was a poor solution, but it worked.

first i've saved all the packages that i've installed on my system:
~ # pacman -Qqe > pkglist

this list has lines with the errors above mencioned.

has a filter i've written this piece of code:
#!/usr/bin/perl
use strict;
use warnings;

open INFILE, "pkglist" or die $!;
open OUTFILE, ">errlist" or die $!;

my $line;
my $next_line;
while($line=<INFILE>) {
if($line =~ /error/) {
$next_line=<INFILE>;
print $next_line;
print OUTFILE $next_line;
}
}

then since that i've had aur packages installed on my system, i've made:
yaourt -Sf $(cat errlist)

the final result: everything ok. at least it's seems so.

Comment by Dan McGee (toofishes) - Saturday, 01 November 2008, 00:01 GMT
pacman-optimize changes have been pushed to the maint branch of pacman.git. Hopefully this will resolve any possible issues.

Loading...