Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#11765 - XFS root filesystem read-only in 2.6.27

Attached to Project: Arch Linux
Opened by Witold Czaplewski (Witi) - Thursday, 16 October 2008, 13:08 GMT
Last edited by Tobias Powalowski (tpowa) - Friday, 17 October 2008, 10:56 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas Bächler (brain0)
Architecture All
Severity High
Priority Normal
Reported Version None
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

http://www.linuxquestions.org/questions/linux-software-2/2.6.27-xfs-root-filesystem-read-only-problem-676304/

With kernel 2.6.26 and older I used successfully the following mount options in my fstab:
/dev/sda2 / xfs defaults,noatime,nodiratime,logbufs=8,nobarrier 0 1

But with 2.6.27 the root-partition is mounted read only, although mount and cat /proc/mounts shows rw! E.g. I can create a directory, but can't do a chmod on it. And on boot many commands fail.

But I discovered a workaround. You have to remove all mount options except for defaults.
Nevertheless it seems to be a kernel or xfs bug.

Steps to reproduce:
use kernel 2.6.27 mount an xfs root partition with the options named above.

workaround:
remove all options except for defaults
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Friday, 17 October 2008, 10:56 GMT
Reason for closing:  Fixed
Comment by Hao (qft) - Thursday, 16 October 2008, 19:40 GMT
I'm having the same problem after upgrading to kernel 2.6.27. I have several XFS partitions with exactly the same mount options but only the root partition is affected.
Comment by Thomas Bächler (brain0) - Friday, 17 October 2008, 06:59 GMT
I don't know anything about XFS, could you search the kernel.org bugzilla for such a bug?
Comment by Thomas Bächler (brain0) - Friday, 17 October 2008, 07:08 GMT
tpowa just told me that there are patches for XFS in GKH's stable queue. The new 2.6.27.1-1 package will contain those in addition to the .1 patches.
Comment by Tobias Powalowski (tpowa) - Friday, 17 October 2008, 08:01 GMT
should be fixed in 2.6.27.1-1 in testing
Comment by Witold Czaplewski (Witi) - Friday, 17 October 2008, 10:54 GMT
Yep, it's fixed.

Thanks a lot.

Loading...