Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#11756 - wxGTK --enable-mediactrl

Attached to Project: Arch Linux
Opened by Michael Pfeuti (mpfeuti) - Wednesday, 15 October 2008, 19:31 GMT
Last edited by Aaron Griffin (phrakture) - Monday, 09 February 2009, 17:43 GMT
Task Type Feature Request
Category Packages: Extra
Status Closed
Assigned To Eric Belanger (Snowman)
Architecture All
Severity Low
Priority Normal
Reported Version None
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

it would be great if wxGTK were compiled with the --enable-mediactrl option. I compiled it with this option and it worked without any troubles.
This task depends upon

Closed by  Aaron Griffin (phrakture)
Monday, 09 February 2009, 17:43 GMT
Reason for closing:  Not a bug
Comment by Eric Belanger (Snowman) - Thursday, 16 October 2008, 19:07 GMT
The wxgtk in the repo (2.8.9) is already built with the --enable-mediactrl option.
Comment by Michael Pfeuti (mpfeuti) - Thursday, 16 October 2008, 21:12 GMT
weird, i had to recompile it in order to compile an application which uses mediactrl
Comment by Eric Belanger (Snowman) - Friday, 05 December 2008, 17:28 GMT
Michael: Can you tell me what application uses mediactrl? I would like to test it out myself. Maybe I missed something.
Comment by Gibheer (Gibheer) - Saturday, 17 January 2009, 07:54 GMT
I've found a rubypackage, which needs mediactrl. It is the rubygem wxruby and without mediactrl compiled in, it won't work.
Comment by Eric Belanger (Snowman) - Saturday, 17 January 2009, 09:09 GMT
Can you test it with the wxgtk in extra and report if it works or not?
Comment by Gibheer (Gibheer) - Saturday, 17 January 2009, 13:38 GMT
Hello,

/usr/bin/ruby: symbol lookup
error: /usr/lib/ruby/gems/1.8/gems/wxruby-1.9.8-x86_64-linux/lib/wxruby2.so:
undefined symbol: Init_wxMediaCtrl

I tried the original archlinuxpackage from extra, a selfcompiled one,
but none of them worked. I tried to compile the gem myself
(http://wxruby.rubyforge.org/wiki/wiki.pl?InstallingFromSource), but I
got the following message:

The following wxWidgets features are not available and will be skipped:
MediaCtrl
MediaEvent
PrinterDC

At some point, there has to be something wrong, but where?

Gibheer
Comment by Eric Belanger (Snowman) - Monday, 19 January 2009, 02:20 GMT
I found the problem. You need to add a gstreamer0.10-base depends and a gstreamer0.10-base-plugins makedepends. It also brings on a gconf depends among other things. Some users might not like having all these new depends. I'm not sure if I still want to add mediactrl support. Is mediactrl something that is used a lot?
Comment by BoppreH (BoppreH) - Sunday, 08 February 2009, 23:03 GMT
It affects wxPython as well. And mediactrl is the only media player included in the module, so every program that uses wxPython and plays something is likely to suffer from this.

Although it's mostly in "amateur" programs, it's something that is bothering, for example.
Comment by Michael Pfeuti (mpfeuti) - Sunday, 08 February 2009, 23:17 GMT
I guess it's not worth the trouble. so better leave it in the repos without mediactrl enabled. there are just a few apps that need it anyway.

Loading...