Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#11747 - Kernel 2.6.27 - System don't boot with SpeedTouch 330

Attached to Project: Arch Linux
Opened by Peter (Trickster) - Wednesday, 15 October 2008, 05:37 GMT
Last edited by Tobias Powalowski (tpowa) - Friday, 17 October 2008, 10:52 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To No-one
Architecture i686
Severity Critical
Priority Normal
Reported Version None
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 5
Private No

Details

Description:
After kernel upgrade system freeze system freeze at boot on "Loading UDev Uevents" when mod Thomson SpeedTouch 330 is plugged in.

Additional info:
kernel26-2.6.27


Steps to reproduce:
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Friday, 17 October 2008, 10:52 GMT
Reason for closing:  Fixed
Comment by Radu Potop (wooptoo) - Wednesday, 15 October 2008, 06:20 GMT
I can confirm this.
Actually the system does boot, but it gives a lot of ATM module errors.
I'll be back with more details.
Comment by Radu Potop (wooptoo) - Wednesday, 15 October 2008, 14:04 GMT
I attached the relevant parts of dmesg and error.log
Comment by Rulatir (Rulatir) - Wednesday, 15 October 2008, 15:09 GMT
I can confirm this too. Pleasepleaseplease fix!
Comment by Thomas Bächler (brain0) - Thursday, 16 October 2008, 07:33 GMT
This is not the right place to report this. We don't know much about these bugs, go to http://bugzilla.kernel.org and open a bug report there (or look if one already exists). This way, you'll actually get the bug fixed.
Comment by Rulatir (Rulatir) - Thursday, 16 October 2008, 09:28 GMT
It is already reported upstream:

http://bugzilla.kernel.org/show_bug.cgi?id=11767

Now the Excruciatingly Long Wait begins...
Comment by Thomas Bächler (brain0) - Thursday, 16 October 2008, 11:07 GMT
I see that there is a patch attached to this bugzilla. We can include that in the next kernel rebuild.
Comment by Rulatir (Rulatir) - Thursday, 16 October 2008, 11:34 GMT
It is already reported upstream:

http://bugzilla.kernel.org/show_bug.cgi?id=11767

Now the Excruciatingly Long Wait begins...
Comment by Radu Potop (wooptoo) - Thursday, 16 October 2008, 18:28 GMT
You can download a patched version from here: http://wooptoo.com/misc/kernel26-2.6.27-2-i686.pkg.tar.gz
I couldn't wait for the official one.
Also, keep an eye on the kernel changelog before upgrading, since version 2.6.27.1 didn't fix this yet.
Comment by Michel (michel) - Thursday, 16 October 2008, 18:30 GMT
I can confirm this for another speedtouch I think. Anyway for a speedtouch. This kernel also has problems with usb-sticks and utf-8. Really, I came very close in my mind of tossing linux out of the window (I'm using it for 4-6 years or so). But Windows is also not so good.

I had to go back to 2.6.17 for the moment (from cd), and now I have internet again and copying files to the usb-stick works well. Really, there is soemthing wrong with copying to usb-sticks and utf-8. The error was caused by null-dereferences in the mutex-code I think. Anyway, if it has been reported, they hopefully know where the problem is. Else, they can ask, but then I have to go back to the bad kernel ... (for me anyway).

I would recommend to remove this update immediately. I actually would recommend to go back to 2.6.27.1 or even to the latest of 2.6.26.

Kind regards,

Michel
Comment by Grzegorz Skowron (rezzy) - Thursday, 16 October 2008, 20:40 GMT
I confirm the error as well...

As the others have already said it doesn't stop booting but takes much time (about two minutes) and produces many errors... I have this error with Speedtouch 330 modem and Wacom tablet. It seems it happens to some usb devices...

It happened just after updating kernel to the latest version
Comment by Tobias Powalowski (tpowa) - Friday, 17 October 2008, 08:00 GMT
should be fixed in 2.6.27.1-1 in testing
Comment by Radu Potop (wooptoo) - Friday, 17 October 2008, 10:30 GMT
yes, it works with 2.6.27.1

Loading...