Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#11746 - kernel26-2.6.27-2 breaks wifi/wpa2 on Prism 2.5 Wavelan

Attached to Project: Arch Linux
Opened by Marshall Scorcio (marshalium) - Wednesday, 15 October 2008, 02:55 GMT
Last edited by Tobias Powalowski (tpowa) - Sunday, 26 October 2008, 20:41 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas Bächler (brain0)
Architecture i686
Severity Medium
Priority Normal
Reported Version None
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

The new kernel26-2.6.27-2 breaks wifi using wpa2 on my Prism 2.5 Wavelan.

Thinkpad A30 2652

02:02.0 Network controller: Intersil Corporation Prism 2.5 Wavelan chipset (rev 01)


dmesg gives this relevent error message when attempting to connect:

wlan0: Trying to join BSSID 00:1d:7e:2f:95:ba
wifi0: LinkStatus=1 (Connected)
wifi0: LinkStatus: BSSID=00:1d:7e:2f:95:ba
wifi0: invalid skb->cb magic (0x00000099, expected 0xf08a36a2)
wifi0: invalid skb->cb magic (0x00000099, expected 0xf08a36a2)
wifi0: invalid skb->cb magic (0x00000099, expected 0xf08a36a2)
wifi0: invalid skb->cb magic (0x00000099, expected 0xf08a36a2)
wifi0: LinkStatus=2 (Disconnected)


NetworkManager can see my local network and keeps trying to join.
Eventully it asks for the key again and resumes its connecting efforts.

Wifi worked great before I upgraded to the 2.6.27 kernel and when I downgraded to kernel26-2.6.26.5-1 it worked great again.


Outputs from lsmod and dmesg under 2.6.27 attached.


   dmesg (35.6 KiB)
   lsmod (3.3 KiB)
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Sunday, 26 October 2008, 20:41 GMT
Reason for closing:  Fixed
Additional comments about closing:  2.6.27.4
Comment by Thomas Bächler (brain0) - Friday, 17 October 2008, 07:01 GMT
Could you try the pci=nomsi kernel option? Can you search the kernel.org bugzilla for this problem?
Comment by Marshall Scorcio (marshalium) - Friday, 17 October 2008, 20:55 GMT
pci=nomsi doesn't fix the problem.

I cannot find any related bugs on kernel.org bugzilla.




Comment by Marshall Scorcio (marshalium) - Saturday, 18 October 2008, 04:25 GMT
I would like to clarify that the problem is not just with wpa2. Connecting to an open/insecure network is broken as well.

Tried kernel 2.6.27.1-1 from testing. It did not fix the problem.
Comment by David Kessler (kopsis) - Saturday, 25 October 2008, 03:52 GMT
I'm seeing the same thing. Thinkpad T30, Intel High-Rate Wireless LAN PCI card (Prism 2.5). Orinoco driver works (but doesn't support WPA).
Comment by David Kessler (kopsis) - Saturday, 25 October 2008, 04:51 GMT
Looks like this has been reported upstream.

http://bugzilla.kernel.org/show_bug.cgi?id=11802

I have confirmed that the one line patch provided in the bug report response does appear to work on 2.6.27.1

Loading...