Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#11728 - proftpd, mod_tls as default

Attached to Project: Arch Linux
Opened by Jakob Hallerod (WeeDie) - Monday, 13 October 2008, 21:02 GMT
Last edited by Hugo Doria (hdoria) - Tuesday, 14 April 2009, 13:15 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Dale Blount (dale)
Hugo Doria (hdoria)
Architecture All
Severity Medium
Priority Normal
Reported Version None
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Greetings,

This was a letter to the most recent maintainer of the proftpd repository package, Eric Belanger,
who no longer maintains it, so it seems to be without maintainer. He asked me to file a bugreport for this issue.
Could someone in TU please adopt this package so that it can be maintained? Same goes for the gmpc package, for which I made a PKGBUILD in AUR which was removed, I know not why..
I would love to help but I'm fairly new here, so I guess I don't fall into the T-category.

Anyway,
Might I suggest configuring proftpd with module mod_tls as default? I
can see it is compiled with support for quotas so it isn't a barebone
package to begin with.
I ran into some trouble using gadmin-proftpd with this package and
after consulting the developer we concurred that it was because of the missing
encryption support.
In trying to maintain a secure linuxdistribution I would think sending
login information in clear text should not be encouraged.
The only reason I could find not to include mod_tls is that it would
trigger an ssl library dependency, and I guess not everybody wants
that. But I would think most people got the openssl package installed
so it shouldn't be a problem.

I've attached a PKGBUILD I used to build the latest proftpd 1.3.2rc2,
it might go into testing if someone is able to maintain it. The patches in the PKGBUILD are already applied in latest release, so they can be removed.

Thank you,

Kind regards,
Jakob
   PKGBUILD (1.5 KiB)
This task depends upon

Closed by  Hugo Doria (hdoria)
Tuesday, 14 April 2009, 13:15 GMT
Reason for closing:  Fixed
Additional comments about closing:  fixed on proftpd 1.3.2-4
Comment by Andrea Scarpino (BaSh) - Monday, 13 October 2008, 21:12 GMT
  • Field changed: Attached to Project (Community Packages → Arch Linux)
proftpd is in [extra].
moved to right bug project category
Comment by Dale Blount (dale) - Thursday, 04 December 2008, 13:16 GMT
I'll add this on next rebuild. Everyone has openssl installed, so it shouldn't be a big issue.
Comment by Eric Belanger (Snowman) - Sunday, 22 March 2009, 05:18 GMT
Hugo: Could you also implement this in the package in testing? I saw you did the pid file fix.

Loading...