Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#11716 - [extra/openoffice-base 3.0.0-1] Crash in the "Tools" Menu

Attached to Project: Arch Linux
Opened by Georg Grabler (STiAT) - Monday, 13 October 2008, 09:59 GMT
Last edited by Andreas Radke (AndyRTR) - Monday, 22 December 2008, 17:46 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture All
Severity Medium
Priority Normal
Reported Version None
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 5
Private No

Details

Description:


Additional info:
* extra/openoffice-base 3.0.0-1
* Deleted all configurations for openoffice in my home directory.
* Running KDE


Steps to reproduce:
Start OpenOffice Writer, and click the "Tools" menu.
-> Crash (at least here, tested and confirmed on 3 different machines).
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Monday, 22 December 2008, 17:46 GMT
Reason for closing:  Fixed
Comment by Allan McRae (Allan) - Monday, 13 October 2008, 10:15 GMT
Read the post install message:

please preset Gnome appearance always with "export OOO_FORCE_DESKTOP=gnome" even when you are runnning a different desktop!
Comment by Georg Grabler (STiAT) - Monday, 13 October 2008, 11:06 GMT
Is it a mainstream bug? That fixes the problem, anyway, I thought it's defaulting if i don't have the variable exported at all...
Comment by Pierre Schmitz (Pierre) - Monday, 13 October 2008, 12:41 GMT
One could check if this is also reproducable with the official build from openoffice.org.
Comment by Georg Grabler (STiAT) - Thursday, 16 October 2008, 16:12 GMT
Could be hard - would probably need to completely do the install manually.
OOo Binary Distribution either needs rpm or the deb command (to extract / install files).

I couldn't find any packages bringing any of those package management tools for arch. Probably I just didn't look close enough ;-)
Comment by Dan Vratil (progdan) - Thursday, 16 October 2008, 18:56 GMT
I can confirm this bug. OOo 3 freezes when opening menu "Tools"....this is in console:

[progdan@notas ~]$ soffice -writer

(process:5345): GLib-GObject-CRITICAL **: gtype.c:2458: initialization assertion failed, use IA__g_type_init()prior to this function

(process:5345): GLib-GObject-CRITICAL **: g_type_interface_add_prerequisite: assertion `G_TYPE_IS_INTERFACE (interface_type)' failed

(process:5345): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed

(process:5345): GLib-GObject-CRITICAL **: gtype.c:2458: initialization assertion failed, use IA__g_type_init()prior to this function

(process:5345): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed

(process:5345): GLib-GObject-CRITICAL **: gtype.c:2458: initialization assertion failed, use IA__g_type_init()prior to this function

(process:5345): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed

I'm running KDE 4. It occurs with OOO_FORCE_DESKTOP="kde" and also with ="gnome".
Comment by Flagada Jones (Bobyl) - Saturday, 18 October 2008, 09:12 GMT
Using Arch64:
- the freeze occurs event with OOO_FORCE_DESKTOP=gnome
- the freeze also occurs when you try to enter the 'Window' menu
- the freeze occurs in twm and kde4
Comment by Pavel (Mr. Ego) - Monday, 20 October 2008, 10:09 GMT
Try to run from console:

OOO_FORCE_DESKTOP=gnome soffice

This works for me.
I am running KDE 4.

Without OOO_FORCE_DESKTOP=gnome OpenOffice freezes:
* sometimes when started from console with "soffice" command - spash screen shows, progress reaches 100% and then nothing happens
* when running "soffice -writer" program loads, and freeze occurs when I type space or when I enter Tools menu

When those freezes occur, processor is at 100% until I kill OpenOffice.
Comment by Matt (ilikenwf) - Friday, 31 October 2008, 18:01 GMT
The gnome UI is slow and ugly on KDE. Any possibility of fixing this? I've found I can configure most things in gnome mode (with the exception of the UI font size), and then switch back to KDE to have speed, and better looks.

I'm sure we could figure this out and hack a fix together.
Comment by Pawel (kraftman) - Sunday, 23 November 2008, 17:59 GMT
I can confirm this bug.

@ Georg Grabler (STiAT)

>Could be hard - would probably need to completely do the install manually.
>OOo Binary Distribution either needs rpm or the deb command (to extract / install files).

As far as I know you don't need special tools to extract debs. Maybe you can extract them using gzip etc.
Comment by Georg Grabler (STiAT) - Thursday, 27 November 2008, 20:24 GMT
Argh, i should have put me on the comment notificaiton >.<.

I'll test that tomorrow.
Comment by Matt (ilikenwf) - Thursday, 11 December 2008, 04:05 GMT
I found a way to fix the uglyassed fonts in gnome mode...here's a PKGBUILD that should fix it.

http://aur.archlinux.org/packages.php?ID=22147
Comment by Andreas Radke (AndyRTR) - Thursday, 18 December 2008, 15:26 GMT
openoffice-base I: File ['opt/openoffice/basis-link/program/libvcllx.so', 'opt/openoffice/basis-link/program/libvclplug_gtklx.so', 'opt/openoffice/basis-link/program/fps_gnome.uno.so', 'opt/openoffice/basis-link/program/cairocanvas.uno.so'] link-level dependence on freetype2

there shouldn't be any problem with the freetype2 pkg from extra repo.

do users with that problem have a custom cairo package installed?

Comment by Faelar (Faelar) - Monday, 22 December 2008, 17:08 GMT
I'm running arch64
I need to do "export OOO_FORCE_DESKTOP=gnome" and then to launch "soffice" in the same terminal, or it crash (splash screen frozen at 100%).
I tried different files, like my openbox autostart configuration file, but the only thing that "works" is adding the export line directly in soffice (I think it will broke on every update).
Comment by Andreas Radke (AndyRTR) - Monday, 22 December 2008, 17:46 GMT
I'm going to close this one. the "export OOO_FORCE_DESKTOP=gnome" is included for a while and solved - so closing this one as "fxied". for everything else please open new reports and also give the openoffice-base-beta and -devel a try where many upstream issues are solved.

Loading...