Release Engineering

This project is intented for all release related issues (isos, installer, etc), under the umbrella of the ArchLinux Release Engineers
Tasklist

FS#11515 - Installer uses tty5 for loggin and login

Attached to Project: Release Engineering
Opened by eliott (cactus) - Thursday, 18 September 2008, 04:52 GMT
Last edited by Dieter Plaetinck (Dieter_be) - Monday, 26 January 2009, 19:51 GMT
Task Type Bug Report
Category ArchISO
Status Closed
Assigned To Simo Leone (neotuli)
Dieter Plaetinck (Dieter_be)
Architecture All
Severity Low
Priority Normal
Reported Version None
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

The arch installation cd starts a getty on tty5, as well as uses that tty for output of package installs (pacman stdout).

Both tty5 and tty6 should not have gettys on them. 1-4 should be sufficient.


Additional info:
* package version(s)
* config and/or log files etc.


Steps to reproduce:
Install packages during new installation. Switch to tty5. Look at the garbled output.

Recommendation:

Simple do not spawn getty's on tty5 and tty6.
This task depends upon

Closed by  Dieter Plaetinck (Dieter_be)
Monday, 26 January 2009, 19:51 GMT
Reason for closing:  Duplicate
Additional comments about closing:  http://bugs.archlinux.org/task/11152?pro ject=6&status[0]=
Comment by Dan McGee (toofishes) - Friday, 23 January 2009, 02:41 GMT
  • Field changed: Attached to Project (Arch Linux → Release Engineering)
I believe this is all on tty7 now, at least in the installer. I'm guessing AIF made the same switch.
Comment by Dieter Plaetinck (Dieter_be) - Saturday, 24 January 2009, 14:07 GMT
Yep AIF uses tty7. Although nowhere in the code i can find something like "starting a getty".
Does this mean the problem is still the same? What exactly is the problem? starting a getty process which is not really needed? What do you mean with garbled output?
Comment by Dieter Plaetinck (Dieter_be) - Monday, 26 January 2009, 19:50 GMT
This is a duplicate of http://bugs.archlinux.org/task/11152?project=6&status[0]=
If you can answer my questions or provide more info, please do so in the above ticket.

Loading...