Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#11503 - Evolution Crashes when adding a new appointment

Attached to Project: Arch Linux
Opened by Jelle van der Waa (jelly) - Tuesday, 16 September 2008, 19:00 GMT
Last edited by Jan de Groot (JGC) - Monday, 20 October 2008, 08:32 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Architecture i686
Severity Medium
Priority Normal
Reported Version None
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Evolution crashes when making a new appointment

Additional info:
* package version(s) evolution 2.22.3.1-2
* config and/or log files etc.
** (evolution:28270): DEBUG: mailto URL command: evolution %s
** (evolution:28270): DEBUG: mailto URL program: evolution
libnm_glib_nm_state_cb: dbus returned an error.
(org.freedesktop.DBus.Error.ServiceUnknown) The name org.freedesktop.NetworkManager was not provided by any .service files
(evolution:28270): e-data-server-DEBUG: Loading categories from "/home/jelle/.evolution/categories.xml"
(evolution:28270): e-data-server-DEBUG: Loaded 29 categories

(evolution:28270): libecal-WARNING **: e-cal.c:319: Unexpected response


Steps to reproduce:
This task depends upon

Closed by  Jan de Groot (JGC)
Monday, 20 October 2008, 08:32 GMT
Reason for closing:  Fixed
Additional comments about closing:  Assuming fixed, reopen if you can reproduce it with 2.24.x
Comment by Jelle van der Waa (jelly) - Tuesday, 16 September 2008, 19:05 GMT
(evolution:28270): libecal-WARNING **: e-cal.c:319: Unexpected response
BBDB spinning up...

(evolution:28270): evolution-mail-WARNING **: Cannot activate OAFIID:GNOME_Spell_Dictionary:0.3

** (evolution:28270): CRITICAL **: gaim_source_changed_cb: assertion `source != NULL' failed

** (evolution:28270): CRITICAL **: gaim_source_changed_cb: assertion `source != NULL' failed

** (evolution:28270): CRITICAL **: gaim_source_changed_cb: assertion `source != NULL' failed

** (evolution:28270): CRITICAL **: gaim_source_changed_cb: assertion `source != NULL' failed

** (evolution:28270): CRITICAL **: gaim_source_changed_cb: assertion `source != NULL' failed

** (evolution:28270): CRITICAL **: gaim_source_changed_cb: assertion `source != NULL' failed

** (evolution:28270): CRITICAL **: source_changed_cb: assertion `source != NULL' failed

** (evolution:28270): CRITICAL **: source_changed_cb: assertion `source != NULL' failed

** (evolution:28270): CRITICAL **: source_changed_cb: assertion `source != NULL' failed

** (evolution:28270): CRITICAL **: source_changed_cb: assertion `source != NULL' failed

** (evolution:28270): CRITICAL **: source_changed_cb: assertion `source != NULL' failed

** (evolution:28270): CRITICAL **: source_changed_cb: assertion `source != NULL' failed
calendar-gui-Message: Clearing selection
calendar-gui-Message: Unsetting for Personal
calendar-gui-Message: Unsetting for Birthdays & Anniversaries
calendar-gui-Message: Setting for Personal
calendar-gui-Message: Setting for Birthdays & Anniversaries

(evolution:28270): e-data-server-WARNING **: e_source_get_uri () called on source with no absolute URI!

(evolution:28270): e-data-server-WARNING **: e_source_get_uri () called on source with no absolute URI!

(evolution:28270): Pango-WARNING **: Invalid UTF-8 string passed to pango_layout_set_text()

(evolution:28270): Pango-WARNING **: Invalid UTF-8 string passed to pango_layout_set_text()

(evolution:28270): Pango-WARNING **: Invalid UTF-8 string passed to pango_layout_set_text()

(evolution:28270): Pango-WARNING **: Invalid UTF-8 string passed to pango_layout_set_text()

(evolution:28270): Pango-WARNING **: Invalid UTF-8 string passed to pango_layout_set_text()

(evolution:28270): Pango-WARNING **: Invalid UTF-8 string passed to pango_layout_set_text()

(evolution:28270): Pango-WARNING **: Invalid UTF-8 string passed to pango_layout_set_text()

(evolution:28270): Pango-WARNING **: Invalid UTF-8 string passed to pango_layout_set_text()

(evolution:28270): Pango-WARNING **: Invalid UTF-8 string passed to pango_layout_set_text()

(evolution:28270): Pango-WARNING **: Invalid UTF-8 string passed to pango_layout_set_text()

(evolution:28270): Pango-WARNING **: Invalid UTF-8 string passed to pango_layout_set_text()

(evolution:28270): Pango-WARNING **: Invalid UTF-8 string passed to pango_layout_set_text()

(evolution:28270): Pango-WARNING **: Invalid UTF-8 string passed to pango_layout_set_text()

(evolution:28270): Pango-WARNING **: Invalid UTF-8 string passed to pango_layout_set_text()

(evolution:28270): Pango-WARNING **: Invalid UTF-8 string passed to pango_layout_set_text()

(evolution:28270): Pango-WARNING **: Invalid UTF-8 string passed to pango_layout_set_text()

(evolution:28270): Pango-WARNING **: Invalid UTF-8 string passed to pango_layout_set_text()

(evolution:28270): Pango-WARNING **: Invalid UTF-8 string passed to pango_layout_set_text()

(evolution:28270): Pango-WARNING **: Invalid UTF-8 string passed to pango_layout_set_text()

(evolution:28270): Pango-WARNING **: Invalid UTF-8 string passed to pango_layout_set_text()

(evolution:28270): Pango-WARNING **: Invalid UTF-8 string passed to pango_layout_set_text()

(evolution:28270): Pango-WARNING **: Invalid UTF-8 string passed to pango_layout_set_text()

(evolution:28270): Pango-WARNING **: Invalid UTF-8 string passed to pango_layout_set_text()

(evolution:28270): Gtk-WARNING **: Failed to set text from markup due to error parsing markup: Error on line 1 char 23: Invalid UTF-8 encoded text - not valid '<b>Objectgeori?nteerd Programmeren PracticumDW_1-160, DW_1-170, DW_1-010</b>'

(evolution:28270): Gtk-WARNING **: Failed to set text from markup due to error parsing markup: Error on line 1 char 23: Invalid UTF-8 encoded text - not valid '<b>Objectgeori?nteerd Programmeren PracticumDW_1-160, DW_1-170, DW_1-010</b>'

(evolution:28270): Pango-WARNING **: Invalid UTF-8 string passed to pango_layout_set_text()

(evolution:28270): Pango-WARNING **: Invalid UTF-8 string passed to pango_layout_set_text()

(evolution:28270): Pango-WARNING **: Invalid UTF-8 string passed to pango_layout_set_text()

(evolution:28270): Pango-WARNING **: Invalid UTF-8 string passed to pango_layout_set_text()

(evolution:28270): Pango-WARNING **: Invalid UTF-8 string passed to pango_layout_set_text()

(evolution:28270): Pango-WARNING **: Invalid UTF-8 string passed to pango_layout_set_text()

(evolution:28270): Gtk-WARNING **: Failed to set text from markup due to error parsing markup: Error on line 1 char 23: Invalid UTF-8 encoded text - not valid '<b>Objectgeori?nteerd Programmeren PracticumDW_1-160, DW_1-170, DW_1-010</b>'

(evolution:28270): Gtk-WARNING **: Failed to set text from markup due to error parsing markup: Error on line 1 char 23: Invalid UTF-8 encoded text - not valid '<b>Objectgeori?nteerd Programmeren PracticumDW_1-160, DW_1-170, DW_1-010</b>'

(evolution:28270): Pango-WARNING **: Invalid UTF-8 string passed to pango_layout_set_text()

(evolution:28270): Pango-WARNING **: Invalid UTF-8 string passed to pango_layout_set_text()

(evolution:28270): Pango-WARNING **: Invalid UTF-8 string passed to pango_layout_set_text()

(evolution:28270): Pango-WARNING **: Invalid UTF-8 string passed to pango_layout_set_text()

(evolution:28270): Pango-WARNING **: Invalid UTF-8 string passed to pango_layout_set_text()

(evolution:28270): Pango-WARNING **: Invalid UTF-8 string passed to pango_layout_set_text()

(evolution:28270): Pango-WARNING **: Invalid UTF-8 string passed to pango_layout_set_text()

(evolution:28270): Pango-WARNING **: Invalid UTF-8 string passed to pango_layout_set_text()

(evolution:28270): Pango-WARNING **: Invalid UTF-8 string passed to pango_layout_set_text()

(evolution:28270): Pango-WARNING **: Invalid UTF-8 string passed to pango_layout_set_text()

(evolution:28270): Pango-WARNING **: Invalid UTF-8 string passed to pango_layout_set_text()

(evolution:28270): Pango-WARNING **: Invalid UTF-8 string passed to pango_layout_set_text()

(evolution:28270): Pango-WARNING **: Invalid UTF-8 string passed to pango_layout_set_text()

(evolution:28270): Pango-WARNING **: Invalid UTF-8 string passed to pango_layout_set_text()

(evolution:28270): Pango-WARNING **: Invalid UTF-8 string passed to pango_layout_set_text()

(evolution:28270): Pango-WARNING **: Invalid UTF-8 string passed to pango_layout_set_text()

(evolution:28270): Pango-WARNING **: Invalid UTF-8 string passed to pango_layout_set_text()

(evolution:28270): Pango-WARNING **: Invalid UTF-8 string passed to pango_layout_set_text()

(evolution:28270): Pango-WARNING **: Invalid UTF-8 string passed to pango_layout_set_text()

(evolution:28270): Pango-WARNING **: Invalid UTF-8 string passed to pango_layout_set_text()

(evolution:28270): Pango-WARNING **: Invalid UTF-8 string passed to pango_layout_set_text()

(evolution:28270): Pango-WARNING **: Invalid UTF-8 string passed to pango_layout_set_text()


I can add appointments when i don' t use my student mail from my university, it's a exchange mailservice
Comment by Jelle van der Waa (jelly) - Tuesday, 16 September 2008, 19:13 GMT
Also i get this error
** (evolution:12390): WARNING **: couldn't connect to daemon at $GNOME_KEYRING_SOCKET: /tmp/keyring-k8b7Xe/socket: Connection refused





Comment by Jan de Groot (JGC) - Sunday, 12 October 2008, 12:42 GMT
Is this fixed with evolution and evolution-exchange from testing (2.24.0)?
Comment by Jelle van der Waa (jelly) - Sunday, 12 October 2008, 12:52 GMT
It doesn't happen anymore when i dont use my school mail, know i only use gmail and that works fine and i don't get any errors like my post above

Nederlands:
Ik neem aan de je nederlands bent:
Toen ik gmail en mijn mail van de Tu Delft (exchange mail) gebruikte kon ik geen afspraken toevoegen maar nadat ik de mail van de Tu delft heb verwijderd werkt alles goed en krijg ik de bovenstaande errors ook niet meer.
Comment by Jan de Groot (JGC) - Sunday, 12 October 2008, 13:04 GMT
This is a bug in evolution-exchange, not in Evolution, so the only way to test if your bug is still valid is by testing the new version of evolution-exchange with an Exchange server.

Loading...