Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#11499 - cpufreqd tries to open non-existing file

Attached to Project: Arch Linux
Opened by Sander Jansen (GogglesGuy) - Tuesday, 16 September 2008, 02:52 GMT
Last edited by Anonymous Submitter - Sunday, 28 September 2008, 17:04 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture x86_64
Severity Medium
Priority Normal
Reported Version None
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I'm getting the following error messages in my systemlog:

Sep 15 21:38:52 huygens cpufreqd: get_class_device_attribute: couldn't open /sys/class/power_supply/BAT1/energy_full (No such file or directory)
Sep 15 21:38:52 huygens cpufreqd: get_class_device_attribute: couldn't open /sys/class/power_supply/BAT1/energy_now (No such file or directory)

With:
kernel26 2.6.26.5-1
cpufreqd 2.3.3-1

ls of /sys/class/power_supply/BAT1 shows:

-rw-r--r-- 1 root root 4096 2008-09-15 21:45 alarm
drwxr-xr-x 2 root root 0 2008-09-15 21:45 power
-r--r--r-- 1 root root 4096 2008-09-15 21:38 charge_full_design
lrwxrwxrwx 1 root root 0 2008-09-15 21:38 device -> ../../../devices/LNXSYSTM:00/device:00/PNP0C0A:00
-r--r--r-- 1 root root 4096 2008-09-15 21:38 manufacturer
-r--r--r-- 1 root root 4096 2008-09-15 21:38 model_name
-r--r--r-- 1 root root 4096 2008-09-15 21:38 serial_number
lrwxrwxrwx 1 root root 0 2008-09-15 21:38 subsystem -> ../../power_supply
-r--r--r-- 1 root root 4096 2008-09-15 21:38 technology
-r--r--r-- 1 root root 4096 2008-09-15 21:38 voltage_min_design
-r--r--r-- 1 root root 4096 2008-09-15 21:38 voltage_now
-r--r--r-- 1 root root 4096 2008-09-15 21:38 charge_full
-r--r--r-- 1 root root 4096 2008-09-15 21:38 charge_now
-r--r--r-- 1 root root 4096 2008-09-15 21:38 current_now
-r--r--r-- 1 root root 4096 2008-09-15 21:38 present
-r--r--r-- 1 root root 4096 2008-09-15 21:38 status
-r--r--r-- 1 root root 4096 2008-09-15 21:38 type
-rw-r--r-- 1 root root 4096 2008-09-15 21:38 uevent

I think energy_now should be charge_now...
This task depends upon

Closed by  Anonymous Submitter
Sunday, 28 September 2008, 17:04 GMT
Reason for closing:  Not a bug
Comment by Sander Jansen (GogglesGuy) - Tuesday, 16 September 2008, 03:09 GMT
Ok, it's not really a bug... but it is kind of annoying. cpufreqd-2.3.3 will first try to open "energy_full". If it doesn't succeed it will spit out a warning, and then try to open "charge_full" (which succeeds). It seems both charge_full and energy_full are correct names. I just wish it wouldn't fill my log with the useless message.
Comment by Anonymous Submitter - Sunday, 28 September 2008, 17:04 GMT
I will not fix other software.
Please, fill a bug report to coder project.

Loading...