Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#11498 - wvdial needs /var/lock directory

Attached to Project: Arch Linux
Opened by Andrea Zucchelli (zukka) - Tuesday, 16 September 2008, 00:19 GMT
Last edited by Andrea Scarpino (BaSh) - Saturday, 10 January 2009, 02:29 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Aaron Griffin (phrakture)
Roman Kyrylych (Romashka)
Dan McGee (toofishes)
Andrea Scarpino (BaSh)
Architecture All
Severity Low
Priority Normal
Reported Version None
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
wvdial doesn't work without /var/lock directory it just says that the device is busy
here's what it tries to do (strace output)
open("/var/lock/LCK..rfcomm0", O_RDWR|O_CREAT|O_EXCL|O_NONBLOCK|O_LARGEFILE, 0644) = -1 ENOENT (No such file or directory)

I didn't have /var/lock on my eeepc (very slim installation) I don't know which package created it in my other installations.

Additional info:
* package version(s)
1.60-2
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Saturday, 10 January 2009, 02:29 GMT
Reason for closing:  Not a bug
Comment by Jens Adam (byte) - Tuesday, 16 September 2008, 05:16 GMT
/var/lock is part of the filesystem package, it doesn't get any more mandatory.
You surely had that directory at one point.
Comment by Andrea Zucchelli (zukka) - Tuesday, 16 September 2008, 06:04 GMT
maybe pacman -Rcs kde removed it ? I had just switched from kde to xfce...
Comment by Dan McGee (toofishes) - Sunday, 28 September 2008, 18:09 GMT
If there was nothing in /var/lock besides files from the package you uninstalled, pacman automatically removes the directory, regardless of whether it is in another package or not. Pacman does not explicitly track directory ownership because of the complications of multiple owners, which is never the case with a file. (Think of /usr/bin/ - it would have ~2000 owners).
Comment by Roman Kyrylych (Romashka) - Monday, 29 September 2008, 22:42 GMT
so the question is - what package had some file in /var/lock (or its subdirectory)?
I cannot think about any valid reason for this to be allowed.

@ Andrea: can you please post your pacman.log?
Comment by Andrea Zucchelli (zukka) - Monday, 29 September 2008, 22:53 GMT
here's the log, from the kde removal to the strace installation.
Note that I don't know if I had a /var/lock directory, I didn't had any problem so I didn't check...
I don't know what the solution is but I think that's there's something wrong in wvdial if it says that a device is busy while a directory is missing (maybe it should verify if the directory is there).

P.S.
Excuse for my english, as you see it's not my native language :)
Comment by Dan McGee (toofishes) - Friday, 05 December 2008, 13:14 GMT
Not sure what to do here. Seems like 'not a bug' to me, at least from our end, unless we add a '.keepme' in /var/lock or something.

Loading...