Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#11456 - Dragon Media-player, sound and color problems

Attached to Project: Arch Linux
Opened by David Leutzinger (leutzdave) - Friday, 12 September 2008, 08:05 GMT
Last edited by Pierre Schmitz (Pierre) - Wednesday, 14 January 2009, 00:20 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Pierre Schmitz (Pierre)
Architecture x86_64
Severity Low
Priority Normal
Reported Version None
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: Dragon Media-player, sound and color problems, forcing use of alternative media player such as MPlayer

Additional info:
* package version(s)
dave@dellazoid ~ $ dragon -v
Qt: 4.4.1
KDE: 4.1.1 (KDE 4.1.1)
Dragon Player: 2.0
Up to date Arch Linux (Core Dump) 2007.6

* config and/or log files etc.

Problem #1
Steps to reproduce:
1) System Settings -> Sound -> Backend
Set Preferred to Xine, reboot
2) Use dragon to play an mp4 file
Results: Video plays without sound

Problem #2
Steps to reproduce:
1) System Settings -> Sound -> Backend
Set Preferred to GStreamer, reboot
2) Use dragon to play an mp4 file
Results:
1) Video plays with sound, but the "faces are blue", use Settings -> Video Settings and adjust Hue complete left or right and the "faces are correct color"
2) Amarok sound doesn't work (Amarok: 1.4.9.1)

Problem #2 - output when starting dragon from console:
dave@dellazoid ~ $ dragon ~/Download/redirect.mp4
virtual bool Phonon::Gstreamer::AudioOutput::setOutputDevice(const Phonon::AudioOutputDevice&) "HDA Intel, ALC883 Analog (Front speakers)"
virtual bool Phonon::Gstreamer::AudioOutput::setOutputDevice(const Phonon::AudioOutputDevice&) ("front:CARD=Intel,DEV=0")
virtual bool Phonon::Gstreamer::AudioOutput::setOutputDevice(const Phonon::AudioOutputDevice&) setProperty(device, "front:CARD=Intel,DEV=0" ) succeeded
virtual bool Phonon::Gstreamer::AudioOutput::setOutputDevice(const Phonon::AudioOutputDevice&) go to old state on device "front:CARD=Intel,DEV=0" succeeded
Object::connect: No such signal Phonon::Gstreamer::MediaObject::availableSubtitlesChanged()
Object::connect: No such signal Phonon::Gstreamer::MediaObject::availableAudioChannelsChanged()
Object::connect: No such signal Phonon::Gstreamer::MediaObject::titleChanged(int)
Object::connect: No such signal Phonon::Gstreamer::MediaObject::availableTitlesChanged(int)
Object::connect: No such signal Phonon::Gstreamer::MediaObject::chapterChanged(int)
Object::connect: No such signal Phonon::Gstreamer::MediaObject::availableChaptersChanged(int)
Object::connect: No such signal Phonon::Gstreamer::MediaObject::angleChanged(int)
Object::connect: No such signal Phonon::Gstreamer::MediaObject::availableAnglesChanged(int)
Object::connect: No such signal Phonon::Gstreamer::MediaObject::availableSubtitlesChanged()
Object::connect: No such signal Phonon::Gstreamer::MediaObject::availableAudioChannelsChanged()
Object::connect: No such signal Phonon::Gstreamer::MediaObject::titleChanged(int)
Object::connect: No such signal Phonon::Gstreamer::MediaObject::availableTitlesChanged(int)
Object::connect: No such signal Phonon::Gstreamer::MediaObject::chapterChanged(int)
Object::connect: No such signal Phonon::Gstreamer::MediaObject::availableChaptersChanged(int)
Object::connect: No such signal Phonon::Gstreamer::MediaObject::angleChanged(int)
Object::connect: No such signal Phonon::Gstreamer::MediaObject::availableAnglesChanged(int)
This task depends upon

Closed by  Pierre Schmitz (Pierre)
Wednesday, 14 January 2009, 00:20 GMT
Reason for closing:  Works for me
Additional comments about closing:  Is this still a problem? You might want to test with KDE 4.2 from testing.

Otherwise you should open a report at bugs.kde.org. ATM I don't see any problem with our packages.
Comment by David Leutzinger (leutzdave) - Friday, 12 September 2008, 08:15 GMT
After filing this bug report, I reset sound to prefer Xine, rebooted, now dragon plays the file without error, color fine, sound works.
I don't know what to say, other than this has been a recurring problem for me here, with dragon usually no sound under Xine.

dave@dellazoid ~ $ lspci
00:00.0 Host bridge: Intel Corporation 82G33/G31/P35/P31 Express DRAM Controller (rev 02)
00:01.0 PCI bridge: Intel Corporation 82G33/G31/P35/P31 Express PCI Express Root Port (rev 02)
00:19.0 Ethernet controller: Intel Corporation 82562V-2 10/100 Network Connection (rev 02)
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 02)
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 02)
00:1a.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 02)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 02)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 92)
00:1f.0 ISA bridge: Intel Corporation 82801IR (ICH9R) LPC Interface Controller (rev 02)
00:1f.2 IDE interface: Intel Corporation 82801IR/IO/IH (ICH9R/DO/DH) 4 port SATA IDE Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 02)
00:1f.5 IDE interface: Intel Corporation 82801I (ICH9 Family) 2 port SATA IDE Controller (rev 02)
01:00.0 VGA compatible controller: nVidia Corporation GeForce 8300 GS (rev a1)
02:01.0 Multimedia video controller: Brooktree Corporation Bt878 Video Capture (rev 11)
02:01.1 Multimedia controller: Brooktree Corporation Bt878 Audio Capture (rev 11)
Comment by David Leutzinger (leutzdave) - Friday, 12 September 2008, 09:15 GMT
GStreamer and Xine packages installed are:

dave@dellazoid ~ $ yaourt -Ss gstreamer | grep installed
extra/gstreamer0.10 0.10.20-1 [installed]
extra/gstreamer0.10-bad 0.10.7-1 [installed]
extra/gstreamer0.10-bad-plugins 0.10.7-3 [installed] (gstreamer0.10-plugins)
extra/gstreamer0.10-base 0.10.20-1 [installed]
extra/gstreamer0.10-base-plugins 0.10.20-1 [installed] (gstreamer0.10-plugins)
extra/gstreamer0.10-ffmpeg 0.10.4-1 [installed] (gstreamer0.10-plugins)
extra/gstreamer0.10-good 0.10.8-1 [installed]
extra/gstreamer0.10-good-plugins 0.10.8-4 [installed] (gstreamer0.10-plugins)
extra/gstreamer0.10-ugly 0.10.8-1 [installed]
extra/gstreamer0.10-ugly-plugins 0.10.8-1 [installed] (gstreamer0.10-plugins)
dave@dellazoid ~ $ yaourt -Ss xine | grep installed
core/xinetd 2.3.14-3 [installed]
extra/amarok-engine-xine 1.4.9.1-2 [installed]
extra/libxinerama 1.0.3-1 [installed]
extra/xine-lib 1.1.15-2 [installed]
extra/xineramaproto 1.1.2-1 [installed]
community/lib32-libxinerama 1.0.3-1 [installed] (lib32)
Comment by David Leutzinger (leutzdave) - Friday, 12 September 2008, 13:14 GMT
GStreamer and Xine packages installed are:

dave@dellazoid ~ $ yaourt -Ss gstreamer | grep installed
extra/gstreamer0.10 0.10.20-1 [installed]
extra/gstreamer0.10-bad 0.10.7-1 [installed]
extra/gstreamer0.10-bad-plugins 0.10.7-3 [installed] (gstreamer0.10-plugins)
extra/gstreamer0.10-base 0.10.20-1 [installed]
extra/gstreamer0.10-base-plugins 0.10.20-1 [installed] (gstreamer0.10-plugins)
extra/gstreamer0.10-ffmpeg 0.10.4-1 [installed] (gstreamer0.10-plugins)
extra/gstreamer0.10-good 0.10.8-1 [installed]
extra/gstreamer0.10-good-plugins 0.10.8-4 [installed] (gstreamer0.10-plugins)
extra/gstreamer0.10-ugly 0.10.8-1 [installed]
extra/gstreamer0.10-ugly-plugins 0.10.8-1 [installed] (gstreamer0.10-plugins)
dave@dellazoid ~ $ yaourt -Ss xine | grep installed
core/xinetd 2.3.14-3 [installed]
extra/amarok-engine-xine 1.4.9.1-2 [installed]
extra/libxinerama 1.0.3-1 [installed]
extra/xine-lib 1.1.15-2 [installed]
extra/xineramaproto 1.1.2-1 [installed]
community/lib32-libxinerama 1.0.3-1 [installed] (lib32)
Comment by Allan McRae (Allan) - Saturday, 13 September 2008, 01:59 GMT
So is this a KDE bug or Dragon Media Player bug (which is an AUR package)?
Comment by David Leutzinger (leutzdave) - Saturday, 13 September 2008, 07:52 GMT
This is a KDE4 bug because:

dave@dellazoid ~ $ yaourt -Ss dragonplayer
aur/dragonplayer 2.0.1-1
Dragon Player is a simple video player for KDE 4 developed by Ian Monroe, based on Codeine by Max Howell.

Note that there is no "installed" notation (a feature of yaourt).

Using the Dragonplyer "Help About" I see this:
Dragon Player
Version 2.0
Using KDE 4.1.1 (KDE 4.1.1)

I don't recall ever seeing Dragonplayer when using KDE3, so isn't this newly included in KDE4?
Comment by David Leutzinger (leutzdave) - Saturday, 13 September 2008, 07:54 GMT
Additional proof this must be a KDE4 included program:

yaourt -Rcsn dragonplayer
dragonplayer not found, searching for group...
error: 'dragonplayer': not found in local db
Comment by Pierre Schmitz (Pierre) - Sunday, 28 September 2008, 16:52 GMT
Please update your system and recheck. dragin should be the following version:
Qt: 4.4.2
KDE: 4.1.2 (KDE 4.1.2)
Dragon Player: 2.0

Anyway: Is this only valid for mp4 or are other formats affected?
Comment by David Leutzinger (leutzdave) - Sunday, 28 September 2008, 23:07 GMT
KDE4 Bumped to 4.1.2-1, problem still exists

Bug is not related to mp4 files.
Comment by David Leutzinger (leutzdave) - Sunday, 28 September 2008, 23:11 GMT
Note: KDE4's dragon player and KDE3's amarok with kde3libs, old amarok uses xine engine, new dragon player seems to only play audio portion with gstreamer
Comment by David Leutzinger (leutzdave) - Sunday, 28 September 2008, 23:20 GMT
Isn't Phonon supposed to negotiate all these different audio providers? Isn't this what "Preferred vs Deferred" is for?
Comment by Pierre Schmitz (Pierre) - Friday, 05 December 2008, 04:49 GMT
Sorry, I am not able to reproduce this problem.

Loading...