Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#11426 - swfdec 0.8.0 - needs gstreamer0.10-ffmpeg

Attached to Project: Arch Linux
Opened by Alois Nespor (anespor) - Monday, 08 September 2008, 21:52 GMT
Last edited by Andreas Radke (AndyRTR) - Wednesday, 10 September 2008, 14:49 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture All
Severity Medium
Priority Normal
Reported Version None
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Swfdec 0.8.0 dependence on gstreamer0.10-ffmpeg. Without gstreamer0.10-ffmpeg
hear the sound, but do not see anything.

fixed by adding to PKGBUILD:

depends=('gstreamer0.10-base>=0.10.20' 'alsa-lib>=1.0.17a' 'liboil>=0.3.14' 'gtk2>=2.12.11-3' 'libsoup>=2.4.1-2' 'gstreamer0.10-ffmpeg')

Thanks!
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Wednesday, 10 September 2008, 14:49 GMT
Reason for closing:  Implemented
Additional comments about closing:  as optional deps. see comments.
Comment by Jake (Spewns) - Tuesday, 09 September 2008, 00:36 GMT
I can confirm this.
Comment by Xyne (Xyne) - Tuesday, 09 September 2008, 18:33 GMT
I can partially confirm this. Without gstreamer0.10-ffmpeg, I can neither hear nor see video. With gstreamer0.10-ffmpeg, I can see it but not hear it (on youtube at least).

Could someone explain why swfdec suddenly needs other packages to do what it could do without them before? I'm not being sarcastic... I really don't understand why it now needs this.
Comment by Alois Nespor (anespor) - Tuesday, 09 September 2008, 19:01 GMT
Hi Xyne.
This is easy. Changes to the API for 0.8.0 (major version).

When you look at PKGBUILD swfdec-0.6.4, see:

./configure --prefix=/usr --disable-static --enable-gtk --enable-mad --enable-ffmpeg --disable-gnome-vfs --enable-gstreamer --enable-soup --with-audio=alsa

if you see PKGBUILD swfdec-0.8.0 :

./configure --prefix=/usr --disable-static --enable-gtk --enable-gstreamer --enable-soup --with-audio=alsa

=> missing : --enable-mad and --enable-ffmpeg, so that must be taken external of the library gstreamer0.10-ffmpeg and libmad provides gstreamer0.10-ugly-plugins.


I have installed gstreamer0.10-base, gstreamer0.10-good-plugins, gstreamer0.10-ffmpeg and gstreamer0.10-ugly-plugins. And everything works well, I hear the sound and see the video.

At least you think that this is so. Swfdec leaves coding for gstreamer. (And sorry for my english).

Comment by Alois Nespor (anespor) - Tuesday, 09 September 2008, 19:04 GMT
Of course, i see PKGBUIL of swfdec-0.6.8 (last old), not 0.6.4.
Comment by Andreas Radke (AndyRTR) - Wednesday, 10 September 2008, 14:21 GMT
gstreamer0.10-ffmpeg isn't needed to satisfy swfdec build and runtime dependencies. see http://gitweb.freedesktop.org/?p=swfdec/swfdec.git;a=blob;h=f9e06325d6e03cfe5b3d8401dee1910130e792f1;hb=5ff9ae7d126502330f6e6dab05f9afcdea31748c;f=README

I could even put gstreamer0.10-base to optdepends and you will have to give it some additional plugins you want to use. Think I'll do this for next update.
Comment by Alois Nespor (anespor) - Wednesday, 10 September 2008, 14:36 GMT

...not for building, but to play it so.

as "optdepends" this would be good - at least gstreamer0.10-ffmpeg and also gstreamer0.10-ugly-plugins (for MP3 decoding) or add swfdec.install


Dependencies:

"GStreamer (> = 0.10.15 - optional, required for various audio and video formats)" - when the developer states GStreamer not believe this whole package? Not only -base, but also -good, -bag, -ugly, etc. ?

Thanks for you works, Andreas !
Comment by Andreas Radke (AndyRTR) - Wednesday, 10 September 2008, 14:48 GMT
I've just talked to Benjamin, the main swfdec developer:

andyrtr hi. I'm packaging swfdec for ArchLinux. our users claim they want to have gstreamer0.10-ffmpeg to be a must have dependency.
andyrtr documentation says gstreamer is optional
andyrtr can swfdec be used in a useful way without it?
Company andyrtr: you must have the right gstreamer plugins to get audio and video
Company andyrtr: which will be taken care of by gstreamer missing plugins support, if the distro supports it
Company so if arch doesn't do it and you think youtube is essential, then yes, you must install gst-ffmpeg
Company if you just wanna play desktop tower defense and navigate pesky flash menus, then no, gstreamer is not needed
andyrtr good explenation. I'll make gstreamer-base and maybe also -ffmpeg optional dependencies.


So go and try to play that tower defense game. Ok. I'll add gst-base+ffmpeg to optdepends for next release. Commited it to svn for next rebuils/update.

Loading...